]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/chloe/production.nix
Upgrade to latest nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / production.nix
1 { lib, pkgs, config, ... }:
2 let
3 apacheUser = config.services.httpd.Prod.user;
4 apacheGroup = config.services.httpd.Prod.group;
5 ccfg = config.myEnv.websites.chloe.production;
6 app = pkgs.callPackage ./app {
7 inherit (ccfg) environment;
8 inherit (pkgs.webapps) spip;
9 varDir = "/var/lib/chloe_production";
10 };
11 cfg = config.myServices.websites.chloe.production;
12 webappdir = config.services.websites.webappDirsPaths.chloe_production;
13 in {
14 options.myServices.websites.chloe.production.enable = lib.mkEnableOption "enable Chloe's website in production";
15
16 config = lib.mkIf cfg.enable {
17 services.duplyBackup.profiles.chloe_production.rootDir = app.varDir;
18 secrets.keys = [
19 {
20 dest = "websites/chloe/production";
21 user = apacheUser;
22 group = apacheGroup;
23 permissions = "0400";
24 text = ''
25 SetEnv SPIP_CONFIG_DIR "${./config}"
26 SetEnv SPIP_VAR_DIR "${app.varDir}"
27 SetEnv SPIP_SITE "chloe-${app.environment}"
28 SetEnv SPIP_LDAP_BASE "dc=immae,dc=eu"
29 SetEnv SPIP_LDAP_HOST "ldaps://ldap.immae.eu"
30 SetEnv SPIP_LDAP_SEARCH_DN "${ccfg.ldap.dn}"
31 SetEnv SPIP_LDAP_SEARCH_PW "${ccfg.ldap.password}"
32 SetEnv SPIP_LDAP_SEARCH "${ccfg.ldap.filter}"
33 SetEnv SPIP_MYSQL_HOST "${ccfg.mysql.host}"
34 SetEnv SPIP_MYSQL_PORT "${ccfg.mysql.port}"
35 SetEnv SPIP_MYSQL_DB "${ccfg.mysql.database}"
36 SetEnv SPIP_MYSQL_USER "${ccfg.mysql.user}"
37 SetEnv SPIP_MYSQL_PASSWORD "${ccfg.mysql.password}"
38 '';
39 }
40 ];
41 services.webstats.sites = [ { name = "osteopathe-cc.fr"; } ];
42
43 systemd.services.phpfpm-chloe_production.after = lib.mkAfter [ "mysql.service" ];
44 systemd.services.phpfpm-chloe_production.wants = [ "mysql.service" ];
45 services.phpfpm.pools.chloe_production = {
46 user = config.services.httpd.Prod.user;
47 group = config.services.httpd.Prod.group;
48 settings = {
49 "listen.owner" = apacheUser;
50 "listen.group" = apacheGroup;
51 "php_admin_value[upload_max_filesize]" = "20M";
52 "php_admin_value[post_max_size]" = "20M";
53 # "php_admin_flag[log_errors]" = "on";
54 "php_admin_value[open_basedir]" = "${app.spipConfig}:${./config}:${app}:${app.varDir}:/tmp";
55 "php_admin_value[session.save_path]" = "${app.varDir}/phpSessions";
56 "pm" = "dynamic";
57 "pm.max_children" = "20";
58 "pm.start_servers" = "2";
59 "pm.min_spare_servers" = "1";
60 "pm.max_spare_servers" = "3";
61 };
62 phpPackage = pkgs.php72;
63 };
64 system.activationScripts.chloe_production = {
65 deps = [ "wrappers" ];
66 text = ''
67 install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir} ${app.varDir}/IMG ${app.varDir}/tmp ${app.varDir}/local
68 install -m 0750 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir}/phpSessions
69 '';
70 };
71 services.websites.webappDirs.chloe_production = app.webRoot;
72 services.websites.env.production.modules = [ "proxy_fcgi" ];
73 services.websites.env.production.vhostConfs.chloe = {
74 certName = "chloe";
75 certMainHost = "osteopathe-cc.fr";
76 hosts = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
77 root = webappdir;
78 extraConfig = [
79 ''
80 Use Stats osteopathe-cc.fr
81
82 RewriteEngine On
83 RewriteCond "%{HTTP_HOST}" "!^www\.osteopathe-cc\.fr$" [NC]
84 RewriteRule ^(.+)$ https://www.osteopathe-cc.fr$1 [R=302,L]
85
86 Include ${config.secrets.fullPaths."websites/chloe/production"}
87
88 RewriteEngine On
89 RewriteRule ^/news.rss /spip.php?page=backend&id_rubrique=1
90
91 <FilesMatch "\.php$">
92 SetHandler "proxy:unix:${config.services.phpfpm.pools.chloe_production.socket}|fcgi://localhost"
93 </FilesMatch>
94
95 <Directory ${webappdir}>
96 DirectoryIndex index.php index.htm index.html
97 Options -Indexes +FollowSymLinks +MultiViews +Includes
98 Include ${webappdir}/htaccess.txt
99
100 AllowOverride AuthConfig FileInfo Limit
101 Require all granted
102 </Directory>
103
104 <DirectoryMatch "${webappdir}/squelettes">
105 Require all denied
106 </DirectoryMatch>
107
108 <FilesMatch "(.htaccess|rewrite-rules|.gitignore)$">
109 Require all denied
110 </FilesMatch>
111 ''
112 ];
113 };
114 services.websites.env.production.watchPaths = [
115 config.secrets.fullPaths."websites/chloe/production"
116 ];
117 };
118 }