]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/system/backup-2.nix
Add new machine to nixops
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
1 { privateFiles }:
2 { config, pkgs, myconfig, ... }:
3 {
4 boot.kernelPackages = pkgs.linuxPackages_latest;
5 _module.args.privateFiles = privateFiles;
6 imports = builtins.attrValues (import ../..);
7
8 deployment = {
9 targetEnv = "hetznerCloud";
10 hetznerCloud = {
11 authToken = myconfig.env.hetznerCloud.authToken;
12 datacenter = "hel1-dc2";
13 location ="hel1";
14 serverType = "cx11";
15 };
16 };
17
18 # This value determines the NixOS release with which your system is
19 # to be compatible, in order to avoid breaking some software such as
20 # database servers. You should change this only after NixOS release
21 # notes say you should.
22 # https://nixos.org/nixos/manual/release-notes.html
23 system.stateVersion = "19.03"; # Did you read the comment?
24 }