]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_monitoring-1.nix
Add some monitoring services (eriomem)
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_monitoring-1.nix
1 { config, pkgs, ... }:
2 {
3 host = {
4 # Dummy host for testing
5 # "dummy-host" = {
6 # alias = "dummy.host";
7 # address = "dummy.host";
8 # use = "linux-server";
9 # check_command = "check_ok";
10 # };
11 };
12 service = [
13 # Dummy service for testing
14 # {
15 # service_description = "Dummy failing test";
16 # host_name = "dummy-host";
17 # use = "local-service";
18 # check_interval = "0.3";
19 # max_check_attempts = "1";
20 # flap_detection_enabled = "0";
21 # notification_interval = "0.1";
22 # check_command = "check_critical";
23 # }
24
25 {
26 service_description = "ftp has access to database for authentication";
27 host_name = "eldiron.immae.eu";
28 use = "external-service";
29 check_command = "check_ftp_database";
30
31 servicegroups = "webstatus-remote-services";
32 _webstatus_name = "FTP";
33 _webstatus_url = "ftp.immae.eu";
34 }
35
36 {
37 service_description = "gitolite is working";
38 host_name = "eldiron.immae.eu";
39 use = "external-web-service";
40 check_command = "check_git";
41
42 servicegroups = "webstatus-remote-services";
43 _webstatus_name = "Git";
44 _webstatus_url = "git.immae.eu";
45 }
46
47 {
48 service_description = "postfix SSL is up to date";
49 host_name = "eldiron.immae.eu";
50 use = "external-service";
51 check_command = "check_smtp";
52
53 servicegroups = "webstatus-ssl";
54 _webstatus_name = "SMTP";
55 _webstatus_url = "smtp.immae.eu";
56 }
57
58 {
59 service_description = "imap SSL is up to date";
60 host_name = "eldiron.immae.eu";
61 use = "external-service";
62 check_command = ["check_tcp_ssl" "993"];
63
64 servicegroups = "webstatus-ssl";
65 _webstatus_name = "IMAP";
66 _webstatus_url = "imap.immae.eu";
67 }
68
69 {
70 service_description = "imap connection works";
71 host_name = "eldiron.immae.eu";
72 use = "external-service";
73 check_command = "check_imap_connection";
74
75 servicegroups = "webstatus-remote-services,webstatus-email";
76 _webstatus_name = "IMAP";
77 _webstatus_url = "imap.immae.eu";
78 }
79
80 # Backup services
81 {
82 service_description = "Eriomem backup is up and not full";
83 host_name = "eldiron.immae.eu";
84 use = "external-service";
85 check_command = "check_eriomem";
86
87 check_interval = "120";
88 notification_interval = "120";
89
90 servicegroups = "webstatus-backup";
91 }
92
93 # DNS services
94 {
95 service_description = "eldiron dns is active and authoritative for aten.pro";
96 host_name = "eldiron.immae.eu";
97 use = "dns-service";
98 check_command = ["check_dns" "aten.pro" "-A"];
99
100 servicegroups = "webstatus-dns";
101 _webstatus_name = "aten.pro";
102 }
103
104 {
105 service_description = "eldiron dns is active and authoritative for bouya.org";
106 host_name = "eldiron.immae.eu";
107 use = "dns-service";
108 check_command = ["check_dns" "bouya.org" "-A"];
109
110 servicegroups = "webstatus-dns";
111 _webstatus_name = "bouya.org";
112 }
113
114 {
115 service_description = "eldiron dns is active and authoritative for filedesreves.fr";
116 host_name = "eldiron.immae.eu";
117 use = "dns-service";
118 check_command = ["check_dns" "filedesreves.fr" "-A"];
119
120 servicegroups = "webstatus-dns";
121 _webstatus_name = "filedesreves.fr";
122 }
123
124 {
125 service_description = "eldiron dns is active and authoritative for ludivinecassal.com";
126 host_name = "eldiron.immae.eu";
127 use = "dns-service";
128 check_command = ["check_dns" "ludivinecassal.com" "-A"];
129
130 servicegroups = "webstatus-dns";
131 _webstatus_name = "ludivinecassal.com";
132 }
133
134 {
135 service_description = "eldiron dns is active and authoritative for icommandeur.org";
136 host_name = "eldiron.immae.eu";
137 use = "dns-service";
138 check_command = ["check_dns" "icommandeur.org" "-A"];
139
140 servicegroups = "webstatus-dns";
141 _webstatus_name = "icommandeur.org";
142 }
143
144 {
145 service_description = "eldiron dns is active and authoritative for immae.eu";
146 host_name = "eldiron.immae.eu";
147 use = "dns-service";
148 check_command = ["check_dns" "immae.eu" "-A"];
149
150 servicegroups = "webstatus-dns";
151 _webstatus_name = "immae.eu";
152 }
153
154 {
155 service_description = "eldiron dns is active and authoritative for immae.fr";
156 host_name = "eldiron.immae.eu";
157 use = "dns-service";
158 check_command = ["check_dns" "immae.fr" "-A"];
159
160 servicegroups = "webstatus-dns";
161 _webstatus_name = "immae.fr";
162 }
163
164 {
165 service_description = "eldiron dns is active and authoritative for piedsjaloux.fr";
166 host_name = "eldiron.immae.eu";
167 use = "dns-service";
168 check_command = ["check_dns" "piedsjaloux.fr" "-A"];
169
170 servicegroups = "webstatus-dns";
171 _webstatus_name = "piedsjaloux.fr";
172 }
173
174 {
175 service_description = "eldiron dns is active and authoritative for saison-photo.org";
176 host_name = "eldiron.immae.eu";
177 use = "dns-service";
178 check_command = ["check_dns" "saison-photo.org" "-A"];
179
180 servicegroups = "webstatus-dns";
181 _webstatus_name = "saison-photo.org";
182 }
183
184 {
185 service_description = "eldiron dns is active and authoritative for tellesflorian.com";
186 host_name = "eldiron.immae.eu";
187 use = "dns-service";
188 check_command = ["check_dns" "tellesflorian.com" "-A"];
189
190 servicegroups = "webstatus-dns";
191 _webstatus_name = "tellesflorian.com";
192 }
193
194 {
195 service_description = "eldiron dns is active and authoritative for capitaines.fr";
196 host_name = "eldiron.immae.eu";
197 use = "dns-service";
198 check_command = ["check_dns" "capitaines.fr" "-A"];
199
200 servicegroups = "webstatus-dns";
201 _webstatus_name = "capitaines.fr";
202 }
203
204 {
205 service_description = "cloudns dns is active and authoritative for aten.pro";
206 host_name = "eldiron.immae.eu";
207 use = "dns-service";
208 check_command = ["check_external_dns" "pns1.cloudns.net" "aten.pro" "-A"];
209
210 servicegroups = "webstatus-dns";
211 _webstatus_name = "aten.pro (Secondary DNS ClouDNS)";
212 }
213
214 {
215 service_description = "cloudns dns is active and authoritative for bouya.org";
216 host_name = "eldiron.immae.eu";
217 use = "dns-service";
218 check_command = ["check_external_dns" "pns1.cloudns.net" "bouya.org" "-A"];
219
220 servicegroups = "webstatus-dns";
221 _webstatus_name = "bouya.org (Secondary DNS ClouDNS)";
222 }
223
224 {
225 service_description = "cloudns dns is active and authoritative for filedesreves.fr";
226 host_name = "eldiron.immae.eu";
227 use = "dns-service";
228 check_command = ["check_external_dns" "pns1.cloudns.net" "filedesreves.fr" "-A"];
229
230 servicegroups = "webstatus-dns";
231 _webstatus_name = "filedesreves.fr (Secondary DNS ClouDNS)";
232 }
233
234 {
235 service_description = "cloudns dns is active and authoritative for ludivinecassal.com";
236 host_name = "eldiron.immae.eu";
237 use = "dns-service";
238 check_command = ["check_external_dns" "pns1.cloudns.net" "ludivinecassal.com" "-A"];
239
240 servicegroups = "webstatus-dns";
241 _webstatus_name = "ludivinecassal.com (Secondary DNS ClouDNS)";
242 }
243
244 {
245 service_description = "cloudns dns is active and authoritative for icommandeur.org";
246 host_name = "eldiron.immae.eu";
247 use = "dns-service";
248 check_command = ["check_external_dns" "pns1.cloudns.net" "icommandeur.org" "-A"];
249
250 servicegroups = "webstatus-dns";
251 _webstatus_name = "icommandeur.org (Secondary DNS ClouDNS)";
252 }
253
254 {
255 service_description = "cloudns dns is active and authoritative for immae.eu";
256 host_name = "eldiron.immae.eu";
257 use = "dns-service";
258 check_command = ["check_external_dns" "pns1.cloudns.net" "immae.eu" "-A"];
259
260 servicegroups = "webstatus-dns";
261 _webstatus_name = "immae.eu (Secondary DNS ClouDNS)";
262 }
263
264 {
265 service_description = "cloudns dns is active and authoritative for immae.fr";
266 host_name = "eldiron.immae.eu";
267 use = "dns-service";
268 check_command = ["check_external_dns" "pns1.cloudns.net" "immae.fr" "-A"];
269
270 servicegroups = "webstatus-dns";
271 _webstatus_name = "immae.fr (Secondary DNS ClouDNS)";
272 }
273
274 {
275 service_description = "cloudns dns is active and authoritative for piedsjaloux.fr";
276 host_name = "eldiron.immae.eu";
277 use = "dns-service";
278 check_command = ["check_external_dns" "pns1.cloudns.net" "piedsjaloux.fr" "-A"];
279
280 servicegroups = "webstatus-dns";
281 _webstatus_name = "piedsjaloux.fr (Secondary DNS ClouDNS)";
282 }
283
284 {
285 service_description = "cloudns dns is active and authoritative for tellesflorian.com";
286 host_name = "eldiron.immae.eu";
287 use = "dns-service";
288 check_command = ["check_external_dns" "pns1.cloudns.net" "tellesflorian.com" "-A"];
289
290 servicegroups = "webstatus-dns";
291 _webstatus_name = "tellesflorian.com (Secondary DNS ClouDNS)";
292 }
293
294 {
295 service_description = "cloudns dns is active and authoritative for saison-photo.org";
296 host_name = "eldiron.immae.eu";
297 use = "dns-service";
298 check_command = ["check_external_dns" "pns1.cloudns.net" "saison-photo.org" "-A"];
299
300 servicegroups = "webstatus-dns";
301 _webstatus_name = "saison-photo.org (Secondary DNS ClouDNS)";
302 }
303
304 #### Web scenarios
305 {
306 service_description = "blog website is running on immae.eu";
307 host_name = "eldiron.immae.eu";
308 use = "external-web-service";
309 check_command = ["check_https" "www.immae.eu" "/blog/" "egrep -ri TODO /etc"];
310
311 servicegroups = "webstatus-websites";
312 _webstatus_name = "Immae’s Blog";
313 _webstatus_url = "https://www.immae.eu/blog";
314 }
315
316 {
317 service_description = "owncloud website is running on cloud.immae.eu";
318 host_name = "eldiron.immae.eu";
319 use = "external-web-service";
320 check_command = ["check_https" "cloud.immae.eu" "/" "a safe home for all your data"];
321
322 servicegroups = "webstatus-webapps";
323 _webstatus_name = "Nextcloud";
324 _webstatus_url = "https://cloud.immae.eu";
325 }
326
327 {
328 service_description = "davical website is running on dav.immae.eu";
329 host_name = "eldiron.immae.eu";
330 use = "external-web-service";
331 check_command = ["check_https" "dav.immae.eu" "/davical/" "Log On Please"];
332
333 servicegroups = "webstatus-webapps";
334 _webstatus_name = "Davical";
335 _webstatus_url = "https://dav.immae.eu/davical";
336 }
337
338 {
339 service_description = "adminer website is running on tools.immae.eu";
340 host_name = "eldiron.immae.eu";
341 use = "external-web-service";
342 check_command = ["check_https_auth" "tools.immae.eu" "/adminer/" "www.adminer.org"];
343
344 servicegroups = "webstatus-webapps";
345 _webstatus_name = "Adminer";
346 _webstatus_url = "https://tools.immae.eu/adminer/";
347 }
348
349 {
350 service_description = "ttrss website is running on tools.immae.eu";
351 host_name = "eldiron.immae.eu";
352 use = "external-web-service";
353 check_command = ["check_https" "tools.immae.eu" "/ttrss/" "<title>Tiny Tiny RSS"];
354
355 servicegroups = "webstatus-webapps";
356 _webstatus_name = "TT-RSS";
357 _webstatus_url = "https://tools.immae.eu/ttrss/";
358 }
359
360 {
361 service_description = "mpd website is running on tools.immae.eu";
362 host_name = "eldiron.immae.eu";
363 use = "external-web-service";
364 check_command = ["check_https_auth" "tools.immae.eu" "/mpd/" "<title>ympd"];
365
366 servicegroups = "webstatus-webapps";
367 _webstatus_name = "MPD (YMPD)";
368 _webstatus_url = "https://tools.immae.eu/mpd/";
369 }
370
371 {
372 service_description = "rompr mpd website is running on tools.immae.eu";
373 host_name = "eldiron.immae.eu";
374 use = "external-web-service";
375 check_command = ["check_https_auth" "tools.immae.eu" "/rompr/" "<title>RompЯ"];
376
377 servicegroups = "webstatus-webapps";
378 _webstatus_name = "MPD (ROMPR)";
379 _webstatus_url = "https://tools.immae.eu/rompr/";
380 }
381
382 {
383 service_description = "wallabag website is running on tools.immae.eu";
384 host_name = "eldiron.immae.eu";
385 use = "external-web-service";
386 check_command = ["check_https" "tools.immae.eu" "/wallabag/" "<title>Bienvenue sur wallabag"];
387
388 servicegroups = "webstatus-webapps";
389 _webstatus_name = "Wallabag";
390 _webstatus_url = "https://tools.immae.eu/wallabag/";
391 }
392
393 {
394 service_description = "yourl website is running on tools.immae.eu";
395 host_name = "eldiron.immae.eu";
396 use = "external-web-service";
397 check_command = ["check_https" "tools.immae.eu" "/url/admin/" "<title>YOURLS"];
398
399 servicegroups = "webstatus-webapps";
400 _webstatus_name = "YOURLS";
401 _webstatus_url = "https://tools.immae.eu/url/admin/";
402 }
403
404 {
405 service_description = "roundcube website is running on mail.immae.eu";
406 host_name = "eldiron.immae.eu";
407 use = "external-web-service";
408 check_command = ["check_https_code" "mail.immae.eu" "/roundcube/" "401" "<title>Roundcube"];
409
410 servicegroups = "webstatus-webapps,webstatus-email";
411 _webstatus_name = "Roundcube";
412 _webstatus_url = "https://mail.immae.eu/roundcube/";
413 }
414
415 {
416 service_description = "dokuwiki website is running on tools.immae.eu";
417 host_name = "eldiron.immae.eu";
418 use = "external-web-service";
419 check_command = ["check_https" "tools.immae.eu" "/dokuwiki/" "<title>start"];
420
421 servicegroups = "webstatus-webapps";
422 _webstatus_name = "Dokuwiki";
423 _webstatus_url = "https://tools.immae.eu/dokuwiki/";
424 }
425
426 {
427 service_description = "shaarli website is running on tools.immae.eu";
428 host_name = "eldiron.immae.eu";
429 use = "external-web-service";
430 check_command = ["check_https" "tools.immae.eu" "/Shaarli/immae" "<title>Immae"];
431
432 servicegroups = "webstatus-webapps";
433 _webstatus_name = "Shaarli";
434 _webstatus_url = "https://tools.immae.eu/Shaarli/";
435 }
436
437 {
438 service_description = "ldap website is running on tools.immae.eu";
439 host_name = "eldiron.immae.eu";
440 use = "external-web-service";
441 check_command = ["check_https" "tools.immae.eu" "/ldap/" "<title>phpLDAPadmin"];
442
443 servicegroups = "webstatus-webapps";
444 _webstatus_name = "LDAP";
445 _webstatus_url = "https://tools.immae.eu/ldap/";
446 }
447
448 {
449 service_description = "gitweb website is running on git.immae.eu";
450 host_name = "eldiron.immae.eu";
451 use = "external-web-service";
452 check_command = ["check_https" "git.immae.eu" "/" "git web interface"];
453
454 servicegroups = "webstatus-webapps";
455 _webstatus_name = "Git";
456 _webstatus_url = "https://git.immae.eu/";
457 }
458
459 {
460 service_description = "mantisbt website is running on git.immae.eu";
461 host_name = "eldiron.immae.eu";
462 use = "external-web-service";
463 check_command = ["check_https" "git.immae.eu" "/mantisbt/" "<title>My View - MantisBT"];
464
465 servicegroups = "webstatus-webapps";
466 _webstatus_name = "Mantisbt";
467 _webstatus_url = "https://git.immae.eu/mantisbt";
468 }
469
470 {
471 service_description = "diaspora website is running on diaspora.immae.eu";
472 host_name = "eldiron.immae.eu";
473 use = "external-web-service";
474 check_command = ["check_https" "diaspora.immae.eu" "/" "is the online social world where you are in control"];
475
476 servicegroups = "webstatus-webapps";
477 _webstatus_name = "Diaspora";
478 _webstatus_url = "https://diaspora.immae.eu/";
479 }
480
481 {
482 service_description = "peertube website is running on peertube.immae.eu";
483 host_name = "eldiron.immae.eu";
484 use = "external-web-service";
485 check_command = ["check_https" "peertube.immae.eu" "/" "<title>Immae’s PeerTube"];
486
487 servicegroups = "webstatus-webapps";
488 _webstatus_name = "Peertube";
489 _webstatus_url = "https://peertube.immae.eu/";
490 }
491
492 {
493 service_description = "etherpad website is running on ether.immae.eu";
494 host_name = "eldiron.immae.eu";
495 use = "external-web-service";
496 check_command = ["check_https" "ether.immae.eu" "/" "<title>Etherpad"];
497
498 servicegroups = "webstatus-webapps";
499 _webstatus_name = "Etherpad";
500 _webstatus_url = "https://ether.immae.eu/";
501 }
502
503 {
504 service_description = "mediagoblin website is running on mgoblin.immae.eu";
505 host_name = "eldiron.immae.eu";
506 use = "external-web-service";
507 check_command = ["check_https" "mgoblin.immae.eu" "/" "<title>GNU MediaGoblin"];
508
509 servicegroups = "webstatus-webapps";
510 _webstatus_name = "Mediagoblin";
511 _webstatus_url = "https://mgoblin.immae.eu/";
512 }
513
514 {
515 service_description = "mastodon website is running on mastodon.immae.eu";
516 host_name = "eldiron.immae.eu";
517 use = "external-web-service";
518 check_command = ["check_https" "mastodon.immae.eu" "/" "Mastodon</title>"];
519
520 servicegroups = "webstatus-webapps";
521 _webstatus_name = "Mastodon";
522 _webstatus_url = "https://mastodon.immae.eu/";
523 }
524
525 # Other web pages
526 {
527 service_description = "Jerome website is running on naturaloutil.immae.eu";
528 host_name = "eldiron.immae.eu";
529 use = "external-web-service";
530 check_command = ["check_https" "naturaloutil.immae.eu" "/ping.php" "YES"];
531
532 servicegroups = "webstatus-websites";
533 _webstatus_name = "naturaloutil.immae.eu";
534 _webstatus_url = "https://naturaloutil.immae.eu/";
535 }
536
537 {
538 service_description = "Telio website is running on realistesmedia.fr";
539 host_name = "eldiron.immae.eu";
540 use = "external-web-service";
541 check_command = ["check_https" "realistesmedia.fr" "/" "<title>Réal'istes"];
542 contact_groups = "telio-tortay";
543 }
544
545 {
546 service_description = "Chloe website site is running on osteopathe-cc.fr";
547 host_name = "eldiron.immae.eu";
548 use = "external-web-service";
549 check_command = ["check_https" "www.osteopathe-cc.fr" "/" "<title>Chloé Condamin ostéopathe D.O."];
550
551 servicegroups = "webstatus-websites";
552 _webstatus_name = "osteopathe-cc.fr";
553 _webstatus_url = "https://www.osteopathe-cc.fr/";
554 }
555
556 {
557 service_description = "Richie website is running on europe-richie.org";
558 host_name = "eldiron.immae.eu";
559 use = "external-web-service";
560 check_command = ["check_https" "www.europe-richie.org" "/" "<title>.Europe Richie]"];
561
562 servicegroups = "webstatus-websites";
563 _webstatus_name = "europe-richie.org";
564 _webstatus_url = "https://www.europe-richie.org/";
565 }
566
567 {
568 service_description = "Ludivine website site is running on ludivinecassal.com";
569 host_name = "eldiron.immae.eu";
570 use = "external-web-service";
571 check_command = ["check_https" "www.ludivinecassal.com" "/" "<title>Ludivine Cassal"];
572
573 servicegroups = "webstatus-websites";
574 _webstatus_name = "ludivinecassal.com";
575 _webstatus_url = "https://www.ludivinecassal.com/";
576 }
577
578 {
579 service_description = "Aten website site is running on aten.pro";
580 host_name = "eldiron.immae.eu";
581 use = "external-web-service";
582 check_command = ["check_https" "aten.pro" "/" "<title>ATEN"];
583
584 servicegroups = "webstatus-websites";
585 _webstatus_name = "aten.pro";
586 _webstatus_url = "https://aten.pro/";
587 }
588
589 {
590 service_description = "PiedsJaloux website site is running on piedsjaloux.fr";
591 host_name = "eldiron.immae.eu";
592 use = "external-web-service";
593 check_command = ["check_https" "www.piedsjaloux.fr" "/" "<title>Les Pieds Jaloux"];
594
595 servicegroups = "webstatus-websites";
596 _webstatus_name = "piedsjaloux.fr";
597 _webstatus_url = "https://www.piedsjaloux.fr/";
598 }
599
600 {
601 service_description = "Denise and Jerome website site is running on denisejerome.piedsjaloux.fr";
602 host_name = "eldiron.immae.eu";
603 use = "external-web-service";
604 check_command = ["check_https" "denisejerome.piedsjaloux.fr" "/" "<title>Accueil - Mariage"];
605
606 servicegroups = "webstatus-websites";
607 _webstatus_name = "denisejerome.piedsjaloux.fr";
608 _webstatus_url = "https://denisejerome.piedsjaloux.fr/";
609 }
610
611 {
612 service_description = "Connexionswing website site is running on connexionswing.com";
613 host_name = "eldiron.immae.eu";
614 use = "external-web-service";
615 check_command = ["check_https" "www.connexionswing.com" "/" "<title>Cours, stages"];
616
617 servicegroups = "webstatus-websites";
618 _webstatus_name = "connexionswing.com";
619 _webstatus_url = "https://www.connexionswing.com/";
620 }
621
622 {
623 service_description = "Sandetludo website site is running on sandetludo.com";
624 host_name = "eldiron.immae.eu";
625 use = "external-web-service";
626 check_command = ["check_https" "www.sandetludo.com" "/" "<title>Cours de West Coast"];
627
628 servicegroups = "webstatus-websites";
629 _webstatus_name = "sandetludo.com";
630 _webstatus_url = "https://www.sandetludo.com/";
631 }
632
633 {
634 service_description = "Maison bbc accepts add requests on http";
635 host_name = "eldiron.immae.eu";
636 use = "external-web-service";
637 check_command = [ "check_http" "maison.bbc.bouya.org" "/add.php" "^$"];
638 }
639
640 {
641 service_description = "Maison bbc has up to date data";
642 host_name = "eldiron.immae.eu";
643 use = "generic-service";
644 contact_groups = "maison-bbc";
645 notification_interval = "1440";
646 check_command = "check_maison_bbc";
647 flap_detection_enabled = "0";
648 max_check_attempts = "1";
649 }
650
651 # SSL
652 {
653 service_description = "ldap SSL is up to date";
654 host_name = "eldiron.immae.eu";
655 use = "external-service";
656 check_command = ["check_tcp_ssl" "636"];
657
658 servicegroups = "webstatus-ssl";
659 _webstatus_name = "LDAP";
660 _webstatus_url = "ldap.immae.eu";
661 }
662 ];
663 contact = {
664 telio-tortay = config.myEnv.monitoring.contacts.telio-tortay // {
665 use = "generic-contact";
666 contactgroups = "telio-tortay";
667 };
668 papa = config.myEnv.monitoring.contacts.papa // {
669 use = "generic-contact";
670 contactgroups = "maison-bbc";
671 service_notification_commands = "notify-maison-bbc-by-email";
672 };
673 };
674 contactgroup = {
675 maison-bbc = { alias = "Maison BBC"; };
676 telio-tortay = { alias = "Telio Tortay"; members = "immae"; };
677 };
678 }