]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_monitoring-1.nix
Add monitoring for quatresaisons
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_monitoring-1.nix
1 { config, pkgs, nodes, hostFQDN, emailCheck, lib, ... }:
2 let
3 to_resource = func: cfg: lib.flatten (lib.optionals cfg.enable (lib.mapAttrsToList func cfg.profiles));
4 to_backup_age_dependency = name: profile: map (remote:
5 {
6 dependent_host_name = "eldiron.immae.eu";
7 host_name = "eldiron.immae.eu";
8 dependent_service_description = "${remote} backup for ${name} is not too old";
9 service_description = "${remote} backup is up and not full";
10 execution_failure_criteria = "u";
11 notification_failure_criteria = "u";
12 }) profile.remotes;
13 to_backup_age = name: profile: map (remote:
14 {
15 service_description = "${remote} backup for ${name} is not too old";
16 host_name = "eldiron.immae.eu";
17 use = "external-service";
18 check_command = ["check_backup_${remote}_age" name];
19
20 check_interval = "120";
21 notification_interval = "1440";
22 }) profile.remotes;
23 in
24 {
25 activatedPlugins = [ "dns" "ftp" "git" "http" "imap" "ovh" "tcp" ];
26 host = {
27 # Dummy host for testing
28 # "dummy-host" = {
29 # alias = "dummy.host";
30 # address = "dummy.host";
31 # use = "linux-server";
32 # check_command = "check_ok";
33 # };
34 };
35 service = [
36 # Dummy service for testing
37 # {
38 # service_description = "Dummy failing test";
39 # host_name = "dummy-host";
40 # use = "local-service";
41 # check_interval = "0.3";
42 # max_check_attempts = "1";
43 # flap_detection_enabled = "0";
44 # notification_interval = "0.1";
45 # check_command = "check_critical";
46 # }
47
48 (emailCheck "monitoring-1" hostFQDN)
49
50 {
51 service_description = "ftp has access to database for authentication";
52 host_name = "eldiron.immae.eu";
53 use = "external-service";
54 check_command = "check_ftp_database";
55
56 servicegroups = "webstatus-remote-services";
57 _webstatus_name = "FTP";
58 _webstatus_url = "ftp.immae.eu";
59 }
60
61 {
62 service_description = "gitolite is working";
63 host_name = "eldiron.immae.eu";
64 use = "external-web-service";
65 check_command = "check_git";
66
67 servicegroups = "webstatus-remote-services";
68 _webstatus_name = "Git";
69 _webstatus_url = "git.immae.eu";
70 }
71
72 {
73 service_description = "postfix SSL is up to date";
74 host_name = "eldiron.immae.eu";
75 use = "external-service";
76 check_command = "check_smtp";
77
78 servicegroups = "webstatus-ssl";
79 _webstatus_name = "SMTP";
80 _webstatus_url = "smtp.immae.eu";
81 }
82
83 {
84 service_description = "imap SSL is up to date";
85 host_name = "eldiron.immae.eu";
86 use = "external-service";
87 check_command = ["check_tcp_ssl" "993"];
88
89 servicegroups = "webstatus-ssl";
90 _webstatus_name = "IMAP";
91 _webstatus_url = "imap.immae.eu";
92 }
93
94 {
95 service_description = "imap connection works";
96 host_name = "eldiron.immae.eu";
97 use = "external-service";
98 check_command = "check_imap_connection";
99
100 servicegroups = "webstatus-remote-services,webstatus-email";
101 _webstatus_name = "IMAP";
102 _webstatus_url = "imap.immae.eu";
103 }
104
105 # Third party services
106 {
107 service_description = "OVH account has enough sms";
108 host_name = "eldiron.immae.eu";
109 use = "external-service";
110 check_command = "check_ovh_sms";
111
112 check_interval = "120";
113 notification_interval = "1440";
114 }
115
116 # Backup services
117 # {
118 # service_description = "eriomem backup is up and not full";
119 # host_name = "eldiron.immae.eu";
120 # use = "external-service";
121 # check_command = "check_backup_eriomem";
122
123 # check_interval = "120";
124 # notification_interval = "1440";
125
126 # servicegroups = "webstatus-backup";
127 # }
128 {
129 service_description = "ovh backup is up and not full";
130 host_name = "eldiron.immae.eu";
131 use = "external-service";
132 check_command = "check_ok";
133
134 check_interval = "120";
135 notification_interval = "1440";
136
137 servicegroups = "webstatus-backup";
138 }
139
140 # DNS services
141 {
142 service_description = "eldiron dns is active and authoritative for aten.pro";
143 host_name = "eldiron.immae.eu";
144 use = "dns-service";
145 check_command = ["check_dns" "aten.pro" "-A"];
146
147 servicegroups = "webstatus-dns";
148 _webstatus_name = "aten.pro";
149 }
150
151 {
152 service_description = "eldiron dns is active and authoritative for bouya.org";
153 host_name = "eldiron.immae.eu";
154 use = "dns-service";
155 check_command = ["check_dns" "bouya.org" "-A"];
156
157 servicegroups = "webstatus-dns";
158 _webstatus_name = "bouya.org";
159 }
160
161 {
162 service_description = "eldiron dns is active and authoritative for filedesreves.fr";
163 host_name = "eldiron.immae.eu";
164 use = "dns-service";
165 check_command = ["check_dns" "filedesreves.fr" "-A"];
166
167 servicegroups = "webstatus-dns";
168 _webstatus_name = "filedesreves.fr";
169 }
170
171 {
172 service_description = "eldiron dns is active and authoritative for ludivinecassal.com";
173 host_name = "eldiron.immae.eu";
174 use = "dns-service";
175 check_command = ["check_dns" "ludivinecassal.com" "-A"];
176
177 servicegroups = "webstatus-dns";
178 _webstatus_name = "ludivinecassal.com";
179 }
180
181 {
182 service_description = "eldiron dns is active and authoritative for icommandeur.org";
183 host_name = "eldiron.immae.eu";
184 use = "dns-service";
185 check_command = ["check_dns" "icommandeur.org" "-A"];
186
187 servicegroups = "webstatus-dns";
188 _webstatus_name = "icommandeur.org";
189 }
190
191 {
192 service_description = "eldiron dns is active and authoritative for immae.eu";
193 host_name = "eldiron.immae.eu";
194 use = "dns-service";
195 check_command = ["check_dns" "immae.eu" "-A"];
196
197 servicegroups = "webstatus-dns";
198 _webstatus_name = "immae.eu";
199 }
200
201 {
202 service_description = "eldiron dns is active and authoritative for immae.fr";
203 host_name = "eldiron.immae.eu";
204 use = "dns-service";
205 check_command = ["check_dns" "immae.fr" "-A"];
206
207 servicegroups = "webstatus-dns";
208 _webstatus_name = "immae.fr";
209 }
210
211 {
212 service_description = "eldiron dns is active and authoritative for piedsjaloux.fr";
213 host_name = "eldiron.immae.eu";
214 use = "dns-service";
215 check_command = ["check_dns" "piedsjaloux.fr" "-A"];
216
217 servicegroups = "webstatus-dns";
218 _webstatus_name = "piedsjaloux.fr";
219 }
220
221 {
222 service_description = "eldiron dns is active and authoritative for saison-photo.org";
223 host_name = "eldiron.immae.eu";
224 use = "dns-service";
225 check_command = ["check_dns" "saison-photo.org" "-A"];
226
227 servicegroups = "webstatus-dns";
228 _webstatus_name = "saison-photo.org";
229 }
230
231 {
232 service_description = "eldiron dns is active and authoritative for tellesflorian.com";
233 host_name = "eldiron.immae.eu";
234 use = "dns-service";
235 check_command = ["check_dns" "tellesflorian.com" "-A"];
236
237 servicegroups = "webstatus-dns";
238 _webstatus_name = "tellesflorian.com";
239 }
240
241 {
242 service_description = "eldiron dns is active and authoritative for capitaines.fr";
243 host_name = "eldiron.immae.eu";
244 use = "dns-service";
245 check_command = ["check_dns" "capitaines.fr" "-A"];
246
247 servicegroups = "webstatus-dns";
248 _webstatus_name = "capitaines.fr";
249 }
250
251 {
252 service_description = "cloudns dns is active and authoritative for aten.pro";
253 host_name = "eldiron.immae.eu";
254 use = "dns-service";
255 check_command = ["check_external_dns" "pns1.cloudns.net" "aten.pro" "-A"];
256
257 servicegroups = "webstatus-dns";
258 _webstatus_name = "aten.pro (Secondary DNS ClouDNS)";
259 }
260
261 {
262 service_description = "cloudns dns is active and authoritative for bouya.org";
263 host_name = "eldiron.immae.eu";
264 use = "dns-service";
265 check_command = ["check_external_dns" "pns1.cloudns.net" "bouya.org" "-A"];
266
267 servicegroups = "webstatus-dns";
268 _webstatus_name = "bouya.org (Secondary DNS ClouDNS)";
269 }
270
271 {
272 service_description = "cloudns dns is active and authoritative for filedesreves.fr";
273 host_name = "eldiron.immae.eu";
274 use = "dns-service";
275 check_command = ["check_external_dns" "pns1.cloudns.net" "filedesreves.fr" "-A"];
276
277 servicegroups = "webstatus-dns";
278 _webstatus_name = "filedesreves.fr (Secondary DNS ClouDNS)";
279 }
280
281 {
282 service_description = "cloudns dns is active and authoritative for ludivinecassal.com";
283 host_name = "eldiron.immae.eu";
284 use = "dns-service";
285 check_command = ["check_external_dns" "pns1.cloudns.net" "ludivinecassal.com" "-A"];
286
287 servicegroups = "webstatus-dns";
288 _webstatus_name = "ludivinecassal.com (Secondary DNS ClouDNS)";
289 }
290
291 {
292 service_description = "cloudns dns is active and authoritative for icommandeur.org";
293 host_name = "eldiron.immae.eu";
294 use = "dns-service";
295 check_command = ["check_external_dns" "pns1.cloudns.net" "icommandeur.org" "-A"];
296
297 servicegroups = "webstatus-dns";
298 _webstatus_name = "icommandeur.org (Secondary DNS ClouDNS)";
299 }
300
301 {
302 service_description = "cloudns dns is active and authoritative for immae.eu";
303 host_name = "eldiron.immae.eu";
304 use = "dns-service";
305 check_command = ["check_external_dns" "pns1.cloudns.net" "immae.eu" "-A"];
306
307 servicegroups = "webstatus-dns";
308 _webstatus_name = "immae.eu (Secondary DNS ClouDNS)";
309 }
310
311 {
312 service_description = "cloudns dns is active and authoritative for immae.fr";
313 host_name = "eldiron.immae.eu";
314 use = "dns-service";
315 check_command = ["check_external_dns" "pns1.cloudns.net" "immae.fr" "-A"];
316
317 servicegroups = "webstatus-dns";
318 _webstatus_name = "immae.fr (Secondary DNS ClouDNS)";
319 }
320
321 {
322 service_description = "cloudns dns is active and authoritative for piedsjaloux.fr";
323 host_name = "eldiron.immae.eu";
324 use = "dns-service";
325 check_command = ["check_external_dns" "pns1.cloudns.net" "piedsjaloux.fr" "-A"];
326
327 servicegroups = "webstatus-dns";
328 _webstatus_name = "piedsjaloux.fr (Secondary DNS ClouDNS)";
329 }
330
331 {
332 service_description = "cloudns dns is active and authoritative for tellesflorian.com";
333 host_name = "eldiron.immae.eu";
334 use = "dns-service";
335 check_command = ["check_external_dns" "pns1.cloudns.net" "tellesflorian.com" "-A"];
336
337 servicegroups = "webstatus-dns";
338 _webstatus_name = "tellesflorian.com (Secondary DNS ClouDNS)";
339 }
340
341 {
342 service_description = "cloudns dns is active and authoritative for saison-photo.org";
343 host_name = "eldiron.immae.eu";
344 use = "dns-service";
345 check_command = ["check_external_dns" "pns1.cloudns.net" "saison-photo.org" "-A"];
346
347 servicegroups = "webstatus-dns";
348 _webstatus_name = "saison-photo.org (Secondary DNS ClouDNS)";
349 }
350
351 #### Web scenarios
352 {
353 service_description = "blog website is running on immae.eu";
354 host_name = "eldiron.immae.eu";
355 use = "external-web-service";
356 check_command = ["check_https" "www.immae.eu" "/blog/" "egrep -ri TODO /etc"];
357
358 servicegroups = "webstatus-websites";
359 _webstatus_name = "Immae’s Blog";
360 _webstatus_url = "https://www.immae.eu/blog";
361 }
362
363 {
364 service_description = "owncloud website is running on cloud.immae.eu";
365 host_name = "eldiron.immae.eu";
366 use = "external-web-service";
367 check_command = ["check_https" "cloud.immae.eu" "/" "a safe home for all your data"];
368
369 servicegroups = "webstatus-webapps";
370 _webstatus_name = "Nextcloud";
371 _webstatus_url = "https://cloud.immae.eu";
372 }
373
374 {
375 service_description = "nextcloud website is running on nextcloud.4c.salle-s.org";
376 host_name = "quatresaisons.immae.eu";
377 use = "external-web-service";
378 check_command = ["check_https" "nextcloud.4c.salle-s.org" "/" "a safe home for all your data"];
379
380 servicegroups = "webstatus-webapps";
381 _webstatus_name = "Nextcloud";
382 _webstatus_url = "https://nextcloud.4c.salle-s.org";
383 }
384
385 {
386 service_description = "davical website is running on dav.immae.eu";
387 host_name = "eldiron.immae.eu";
388 use = "external-web-service";
389 check_command = ["check_https" "dav.immae.eu" "/davical/" "Log On Please"];
390
391 servicegroups = "webstatus-webapps";
392 _webstatus_name = "Davical";
393 _webstatus_url = "https://dav.immae.eu/davical";
394 }
395
396 {
397 service_description = "adminer website is running on tools.immae.eu";
398 host_name = "eldiron.immae.eu";
399 use = "external-web-service";
400 check_command = ["check_https_auth" "tools.immae.eu" "/adminer/" "www.adminer.org"];
401
402 servicegroups = "webstatus-webapps";
403 _webstatus_name = "Adminer";
404 _webstatus_url = "https://tools.immae.eu/adminer/";
405 }
406
407 {
408 service_description = "ttrss website is running on tools.immae.eu";
409 host_name = "eldiron.immae.eu";
410 use = "external-web-service";
411 check_command = ["check_https" "tools.immae.eu" "/ttrss/" "<title>Tiny Tiny RSS"];
412
413 servicegroups = "webstatus-webapps";
414 _webstatus_name = "TT-RSS";
415 _webstatus_url = "https://tools.immae.eu/ttrss/";
416 }
417
418 {
419 service_description = "mpd website is running on tools.immae.eu";
420 host_name = "eldiron.immae.eu";
421 use = "external-web-service";
422 check_command = ["check_https_auth" "tools.immae.eu" "/mpd/" "<title>ympd"];
423
424 servicegroups = "webstatus-webapps";
425 _webstatus_name = "MPD (YMPD)";
426 _webstatus_url = "https://tools.immae.eu/mpd/";
427 }
428
429 {
430 service_description = "rompr mpd website is running on tools.immae.eu";
431 host_name = "eldiron.immae.eu";
432 use = "external-web-service";
433 check_command = ["check_https_auth" "tools.immae.eu" "/rompr/" "<title>RompЯ"];
434
435 servicegroups = "webstatus-webapps";
436 _webstatus_name = "MPD (ROMPR)";
437 _webstatus_url = "https://tools.immae.eu/rompr/";
438 }
439
440 {
441 service_description = "wallabag website is running on tools.immae.eu";
442 host_name = "eldiron.immae.eu";
443 use = "external-web-service";
444 check_command = ["check_https" "tools.immae.eu" "/wallabag/" "<title>Bienvenue sur wallabag"];
445
446 servicegroups = "webstatus-webapps";
447 _webstatus_name = "Wallabag";
448 _webstatus_url = "https://tools.immae.eu/wallabag/";
449 }
450
451 {
452 service_description = "yourl website is running on tools.immae.eu";
453 host_name = "eldiron.immae.eu";
454 use = "external-web-service";
455 check_command = ["check_https" "tools.immae.eu" "/url/admin/" "<title>YOURLS"];
456
457 servicegroups = "webstatus-webapps";
458 _webstatus_name = "YOURLS";
459 _webstatus_url = "https://tools.immae.eu/url/admin/";
460 }
461
462 {
463 service_description = "roundcube website is running on mail.immae.eu";
464 host_name = "eldiron.immae.eu";
465 use = "external-web-service";
466 check_command = ["check_https" "mail.immae.eu" "/roundcube/" "<title>Roundcube"];
467
468 servicegroups = "webstatus-webapps,webstatus-email";
469 _webstatus_name = "Roundcube";
470 _webstatus_url = "https://mail.immae.eu/roundcube/";
471 }
472
473 {
474 service_description = "dokuwiki website is running on tools.immae.eu";
475 host_name = "eldiron.immae.eu";
476 use = "external-web-service";
477 check_command = ["check_https" "tools.immae.eu" "/dokuwiki/" "<title>start"];
478
479 servicegroups = "webstatus-webapps";
480 _webstatus_name = "Dokuwiki";
481 _webstatus_url = "https://tools.immae.eu/dokuwiki/";
482 }
483
484 {
485 service_description = "shaarli website is running on tools.immae.eu";
486 host_name = "eldiron.immae.eu";
487 use = "external-web-service";
488 check_command = ["check_https" "tools.immae.eu" "/Shaarli/immae" "<title>Immae"];
489
490 servicegroups = "webstatus-webapps";
491 _webstatus_name = "Shaarli";
492 _webstatus_url = "https://tools.immae.eu/Shaarli/";
493 }
494
495 {
496 service_description = "ldap website is running on tools.immae.eu";
497 host_name = "eldiron.immae.eu";
498 use = "external-web-service";
499 check_command = ["check_https" "tools.immae.eu" "/ldap/" "<title>phpLDAPadmin"];
500
501 servicegroups = "webstatus-webapps";
502 _webstatus_name = "LDAP";
503 _webstatus_url = "https://tools.immae.eu/ldap/";
504 }
505
506 {
507 service_description = "gitweb website is running on git.immae.eu";
508 host_name = "eldiron.immae.eu";
509 use = "external-web-service";
510 check_command = ["check_https" "git.immae.eu" "/cgit" "<title>Immae’s git"];
511
512 servicegroups = "webstatus-webapps";
513 _webstatus_name = "Git";
514 _webstatus_url = "https://git.immae.eu/";
515 }
516
517 {
518 service_description = "mantisbt website is running on git.immae.eu";
519 host_name = "eldiron.immae.eu";
520 use = "external-web-service";
521 check_command = ["check_https" "git.immae.eu" "/mantisbt/" "<title>My View - MantisBT"];
522
523 servicegroups = "webstatus-webapps";
524 _webstatus_name = "Mantisbt";
525 _webstatus_url = "https://git.immae.eu/mantisbt";
526 }
527
528 {
529 service_description = "diaspora website is running on diaspora.immae.eu";
530 host_name = "eldiron.immae.eu";
531 use = "external-web-service";
532 check_command = ["check_https" "diaspora.immae.eu" "/" "is the online social world where you are in control"];
533
534 servicegroups = "webstatus-webapps";
535 _webstatus_name = "Diaspora";
536 _webstatus_url = "https://diaspora.immae.eu/";
537 }
538
539 {
540 service_description = "peertube website is running on peertube.immae.eu";
541 host_name = "eldiron.immae.eu";
542 use = "external-web-service";
543 check_command = ["check_https" "peertube.immae.eu" "/" "<title>Immae’s PeerTube"];
544
545 servicegroups = "webstatus-webapps";
546 _webstatus_name = "Peertube";
547 _webstatus_url = "https://peertube.immae.eu/";
548 }
549
550 {
551 service_description = "etherpad website is running on ether.immae.eu";
552 host_name = "eldiron.immae.eu";
553 use = "external-web-service";
554 check_command = ["check_https" "ether.immae.eu" "/" "<title>Etherpad"];
555
556 servicegroups = "webstatus-webapps";
557 _webstatus_name = "Etherpad";
558 _webstatus_url = "https://ether.immae.eu/";
559 }
560
561 {
562 service_description = "mediagoblin website is running on mgoblin.immae.eu";
563 host_name = "eldiron.immae.eu";
564 use = "external-web-service";
565 check_command = ["check_https" "mgoblin.immae.eu" "/" "<title>GNU MediaGoblin"];
566
567 servicegroups = "webstatus-webapps";
568 _webstatus_name = "Mediagoblin";
569 _webstatus_url = "https://mgoblin.immae.eu/";
570 }
571
572 {
573 service_description = "mastodon website is running on mastodon.immae.eu";
574 host_name = "eldiron.immae.eu";
575 use = "external-web-service";
576 check_command = ["check_https" "mastodon.immae.eu" "/" "Mastodon</title>"];
577
578 servicegroups = "webstatus-webapps";
579 _webstatus_name = "Mastodon";
580 _webstatus_url = "https://mastodon.immae.eu/";
581 }
582
583 # Other web pages
584 {
585 service_description = "Jerome website is running on naturaloutil.immae.eu";
586 host_name = "eldiron.immae.eu";
587 use = "external-web-service";
588 check_command = ["check_https" "naturaloutil.immae.eu" "/ping.php" "YES"];
589
590 servicegroups = "webstatus-websites";
591 _webstatus_name = "naturaloutil.immae.eu";
592 _webstatus_url = "https://naturaloutil.immae.eu/";
593 }
594
595 {
596 service_description = "Telio website is running on realistesmedia.fr";
597 host_name = "eldiron.immae.eu";
598 use = "external-web-service";
599 check_command = ["check_https" "realistesmedia.fr" "/" "doctype html"];
600 contact_groups = "telio-tortay";
601 }
602
603 {
604 service_description = "Chloe website site is running on osteopathe-cc.fr";
605 host_name = "eldiron.immae.eu";
606 use = "external-web-service";
607 check_command = ["check_https" "www.osteopathe-cc.fr" "/" "<title>Chloé Condamin ostéopathe D.O."];
608
609 servicegroups = "webstatus-websites";
610 _webstatus_name = "osteopathe-cc.fr";
611 _webstatus_url = "https://www.osteopathe-cc.fr/";
612 }
613
614 {
615 service_description = "Richie website is running on europe-richie.org";
616 host_name = "eldiron.immae.eu";
617 use = "external-web-service";
618 check_command = ["check_https" "www.europe-richie.org" "/" "<title>.Europe Richie]"];
619
620 servicegroups = "webstatus-websites";
621 _webstatus_name = "europe-richie.org";
622 _webstatus_url = "https://www.europe-richie.org/";
623 }
624
625 {
626 service_description = "Ludivine website site is running on ludivinecassal.com";
627 host_name = "eldiron.immae.eu";
628 use = "external-web-service";
629 check_command = ["check_https" "www.ludivinecassal.com" "/" "<title>Ludivine Cassal"];
630
631 servicegroups = "webstatus-websites";
632 _webstatus_name = "ludivinecassal.com";
633 _webstatus_url = "https://www.ludivinecassal.com/";
634 }
635
636 {
637 service_description = "Aten website site is running on aten.pro";
638 host_name = "eldiron.immae.eu";
639 use = "external-web-service";
640 check_command = ["check_https" "aten.pro" "/" "<title>ATEN"];
641
642 servicegroups = "webstatus-websites";
643 _webstatus_name = "aten.pro";
644 _webstatus_url = "https://aten.pro/";
645 }
646
647 {
648 service_description = "PiedsJaloux website site is running on piedsjaloux.fr";
649 host_name = "eldiron.immae.eu";
650 use = "external-web-service";
651 check_command = ["check_https" "www.piedsjaloux.fr" "/" "<title>Les Pieds Jaloux"];
652
653 servicegroups = "webstatus-websites";
654 _webstatus_name = "piedsjaloux.fr";
655 _webstatus_url = "https://www.piedsjaloux.fr/";
656 }
657
658 {
659 service_description = "Denise and Jerome website site is running on denisejerome.piedsjaloux.fr";
660 host_name = "eldiron.immae.eu";
661 use = "external-web-service";
662 check_command = ["check_https" "denisejerome.piedsjaloux.fr" "/" "<title>Accueil - Mariage"];
663
664 servicegroups = "webstatus-websites";
665 _webstatus_name = "denisejerome.piedsjaloux.fr";
666 _webstatus_url = "https://denisejerome.piedsjaloux.fr/";
667 }
668
669 {
670 service_description = "Connexionswing website site is running on connexionswing.com";
671 host_name = "eldiron.immae.eu";
672 use = "external-web-service";
673 check_command = ["check_https" "www.connexionswing.com" "/" "<title>Cours, stages"];
674
675 servicegroups = "webstatus-websites";
676 _webstatus_name = "connexionswing.com";
677 _webstatus_url = "https://www.connexionswing.com/";
678 }
679
680 {
681 service_description = "Sandetludo website site is running on sandetludo.com";
682 host_name = "eldiron.immae.eu";
683 use = "external-web-service";
684 check_command = ["check_https" "www.sandetludo.com" "/" "<title>Cours de West Coast"];
685
686 servicegroups = "webstatus-websites";
687 _webstatus_name = "sandetludo.com";
688 _webstatus_url = "https://www.sandetludo.com/";
689 }
690
691 # SSL
692 {
693 service_description = "ldap SSL is up to date";
694 host_name = "eldiron.immae.eu";
695 use = "external-service";
696 check_command = ["check_tcp_ssl" "636"];
697
698 servicegroups = "webstatus-ssl";
699 _webstatus_name = "LDAP";
700 _webstatus_url = "ldap.immae.eu";
701 }
702
703 # Tiboqorl
704 {
705 service_description = "Cyllene support page is running";
706 host_name = "tiboqorl.fr";
707 use = "external-web-service";
708 contact_groups = "tiboqorl";
709 check_command = [ "check_https" "sc.groupe-cyllene.com" "/" "<title>Support Client Cyllene" ];
710 _webstatus_namespace = "tiboqorl";
711 }
712
713 {
714 service_description = "Origny page is running";
715 host_name = "tiboqorl.fr";
716 use = "external-web-service";
717 contact_groups = "tiboqorl";
718 check_command = [ "check_https" "origny.tiboqorl.fr" "/" "<title>Home Assistant" ];
719 _webstatus_namespace = "tiboqorl";
720 }
721 ] ++ to_resource to_backup_age nodes.eldiron.config.services.duplyBackup;
722 contact = {
723 telio-tortay = config.myEnv.monitoring.contacts.telio-tortay // {
724 use = "generic-contact";
725 contactgroups = "telio-tortay";
726 };
727 thibault = config.myEnv.monitoring.contacts.thibault // {
728 use = "generic-contact";
729 contactgroups = "tiboqorl";
730 };
731 };
732 contactgroup = {
733 telio-tortay = { alias = "Telio Tortay"; members = "immae"; };
734 tiboqorl = { alias = "Tiboqorl"; members = "immae"; };
735 };
736 servicedependency = to_resource to_backup_age_dependency nodes.eldiron.config.services.duplyBackup;
737 }