]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_immae-eu.nix
Add discourse capitaine landing page
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_immae-eu.nix
1 { ... }:
2 let
3 defaultPassiveInfo = {
4 use = "external-passive-service";
5 freshness_threshold = "450";
6 retry_interval = "1";
7 host_name = "immae.eu";
8 };
9 in
10 {
11 host = {
12 "immae.eu" = {
13 alias = "immae.eu";
14 address = "immae.eu";
15 use = "linux-server";
16 hostgroups = "webstatus-hosts";
17 _webstatus_name = "immaeEu";
18 };
19 };
20 service = map (s: defaultPassiveInfo // s) [
21 {
22 service_description = "size on root partition";
23 servicegroups = "webstatus-resources";
24 }
25
26 {
27 service_description = "total number of process";
28 servicegroups = "webstatus-resources";
29 }
30
31 {
32 service_description = "average load";
33 servicegroups = "webstatus-resources";
34 }
35
36 {
37 service_description = "swap usage";
38 servicegroups = "webstatus-resources";
39 }
40
41 {
42 service_description = "no mdadm array is degraded";
43 servicegroups = "webstatus-resources";
44 }
45
46 {
47 service_description = "ntp is activated and working";
48 servicegroups = "webstatus-resources";
49 }
50
51 {
52 service_description = "ssh connexion responds";
53 }
54
55 {
56 service_description = "fail2ban is active";
57 servicegroups = "webstatus-resources";
58 }
59
60 {
61 service_description = "pacman packages are not too old";
62 servicegroups = "webstatus-resources";
63 freshness_threshold = "10800";
64 notification_interval = "0";
65 }
66
67 {
68 service_description = "rsync backup happened not too long ago";
69 servicegroups = "webstatus-backup";
70 }
71
72 {
73 service_description = "eriomem backup is up and not full";
74 freshness_threshold = "10800";
75 notification_interval = "120";
76 servicegroups = "webstatus-backup";
77 }
78
79 {
80 service_description = "postfix service is active";
81 }
82
83 {
84 service_description = "tinc@Immae service is active";
85 }
86
87 {
88 service_description = "sshd service is active";
89 }
90
91 {
92 service_description = "httpd service is active";
93 servicegroups = "webstatus-resources";
94 }
95
96 {
97 service_description = "postfix SSL is up to date";
98 }
99
100 {
101 service_description = "mailq is empty";
102 servicegroups = "webstatus-email";
103 }
104
105 ## Sending e-mail
106 {
107 service_description = "immae.eu email service is active";
108 servicegroups = "webstatus-email";
109 freshness_threshold = "1350";
110 }
111
112 #### Web scenarios
113 {
114 service_description = "Default website site is running on ns208507.ip-188-165-209.eu";
115 freshness_threshold = "1800";
116 }
117 ];
118 }