]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_immae-eu.nix
Add rsync backup via dilion
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_immae-eu.nix
1 { ... }:
2 let
3 defaultPassiveInfo = {
4 use = "external-passive-service";
5 freshness_threshold = "450";
6 retry_interval = "1";
7 host_name = "immae.eu";
8 };
9 in
10 {
11 host = {
12 "immae.eu" = {
13 alias = "immae.eu";
14 address = "immae.eu";
15 use = "linux-server";
16 hostgroups = "webstatus-hosts";
17 _webstatus_name = "immaeEu";
18 };
19 };
20 service = map (s: defaultPassiveInfo // s) [
21 {
22 service_description = "size on root partition";
23 servicegroups = "webstatus-resources";
24 }
25
26 {
27 service_description = "total number of process";
28 servicegroups = "webstatus-resources";
29 }
30
31 {
32 service_description = "average load";
33 servicegroups = "webstatus-resources";
34 }
35
36 {
37 service_description = "swap usage";
38 servicegroups = "webstatus-resources";
39 }
40
41 {
42 service_description = "no mdadm array is degraded";
43 servicegroups = "webstatus-resources";
44 }
45
46 {
47 service_description = "ntp is activated and working";
48 servicegroups = "webstatus-resources";
49 }
50
51 {
52 service_description = "ssh connexion responds";
53 }
54
55 {
56 service_description = "pacman packages are not too old";
57 servicegroups = "webstatus-resources";
58 freshness_threshold = "10800";
59 notification_interval = "0";
60 }
61
62 {
63 service_description = "tinc@Immae service is active";
64 }
65
66 {
67 service_description = "sshd service is active";
68 }
69 ];
70 }