]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_eban.nix
Add Eban monitoring
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_eban.nix
1 { ... }:
2 let
3 serviceTemplate = rest: {
4 host_name = "eban.bzh";
5 use = "external-web-service";
6 contacts = "eban";
7 contact_groups = "null";
8 check_interval = "15";
9
10 servicegroups = "webstatus-resources";
11 } // rest;
12 in
13 {
14 contact = {
15 eban = {
16 use = "generic-contact";
17 host_notification_commands = "notify-host-eban-url";
18 service_notification_commands = "notify-service-eban-url";
19 };
20 };
21 host = {
22 "eban.bzh" = {
23 alias = "eban.bzh";
24 address = "eban.bzh";
25 use = "linux-server";
26 hostgroups = "webstatus-hosts";
27 contacts = "eban";
28 contact_groups = "null";
29 _webstatus_name = "Eban";
30 _webstatus_vhost = "status.eban.bzh";
31 };
32 };
33 service = [
34 (serviceTemplate {
35 service_description = "Eban website is up and running";
36 check_command = ["check_https" "eban.bzh" "/" "<title>"];
37 _webstatus_name = "Main Website";
38 _webstatus_url = "https://eban.bzh/";
39 })
40 (serviceTemplate {
41 service_description = "Eban blog is up and running";
42 check_command = ["check_https" "blog.eban.bzh" "/" "<title>"];
43 _webstatus_name = "Blog";
44 _webstatus_url = "https://blog.eban.bzh/";
45 })
46 (serviceTemplate {
47 service_description = "Eban gitea is up and running";
48 check_command = ["check_https" "git.eban.bzh" "/" "<title>"];
49 _webstatus_name = "Git";
50 _webstatus_url = "https://git.eban.bzh/";
51 })
52 (serviceTemplate {
53 service_description = "Eban Cloud is up and running";
54 check_command = ["check_https" "cloud.eban.bzh" "/" "<title>"];
55
56 _webstatus_name = "Cloud";
57 _webstatus_url = "https://cloud.eban.bzh/";
58 })
59 ];
60 }