]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_eban.nix
Refactor monitoring to avoid useless resources in each machine
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_eban.nix
1 { ... }:
2 let
3 serviceTemplate = rest: {
4 host_name = "eban.bzh";
5 use = "external-web-service";
6 contacts = "eban";
7 contact_groups = "null";
8 check_interval = "15";
9
10 servicegroups = "webstatus-resources";
11 _webstatus_namespace = "eban";
12 } // rest;
13 in
14 {
15 activatedPlugins = [ "http" ];
16 contact = {
17 eban = {
18 use = "generic-contact";
19 host_notification_commands = "notify-host-eban-url";
20 service_notification_commands = "notify-service-eban-url";
21 };
22 };
23 host = {
24 "eban.bzh" = {
25 alias = "eban.bzh";
26 address = "eban.bzh";
27 use = "linux-server";
28 hostgroups = "webstatus-hosts";
29 contacts = "eban";
30 contact_groups = "null";
31 _webstatus_name = "Eban";
32 _webstatus_vhost = "status.eban.bzh";
33 _webstatus_namespace = "eban";
34 };
35 };
36 service = [
37 (serviceTemplate {
38 service_description = "Eban website is up and running";
39 check_command = ["check_https" "eban.bzh" "/" "<title>"];
40 _webstatus_name = "Main Website";
41 _webstatus_url = "https://eban.bzh/";
42 })
43 (serviceTemplate {
44 service_description = "Eban blog is up and running";
45 check_command = ["check_https" "blog.eban.bzh" "/" "<title>"];
46 _webstatus_name = "Blog";
47 _webstatus_url = "https://blog.eban.bzh/";
48 })
49 (serviceTemplate {
50 service_description = "Eban gitea is up and running";
51 check_command = ["check_https" "git.eban.bzh" "/" "<title>"];
52 _webstatus_name = "Git";
53 _webstatus_url = "https://git.eban.bzh/";
54 })
55 (serviceTemplate {
56 service_description = "Eban Bitwarden is up and running";
57 check_command = ["check_https" "bitwarden.eban.bzh" "/" "<title"];
58
59 _webstatus_name = "Bitwarden";
60 _webstatus_url = "https://bitwarden.eban.bzh/";
61 })
62 ];
63 }