]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_dilion.nix
Refactor monitoring to avoid useless resources in each machine
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_dilion.nix
1 { lib, hostFQDN, emailCheck, ... }:
2 let
3 defaultPassiveInfo = {
4 filter = lib.attrsets.filterAttrs
5 (k: v: builtins.elem k ["service_description"] || builtins.substring 0 1 k == "_");
6 use = "external-passive-service";
7 freshness_threshold = "450";
8 retry_interval = "1";
9 servicegroups = "webstatus-resources";
10 host_name = hostFQDN;
11 };
12 in
13 {
14 activatedPlugins = [ "zfs" ];
15 service = [
16 {
17 passiveInfo = defaultPassiveInfo // { servicegroups = "webstatus-resources"; };
18 service_description = "No ZFS pool is degraded";
19 use = "local-service";
20 check_command = ["check_zfs"];
21 }
22 ];
23 }