]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_common.nix
Add monitoring host
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_common.nix
1 { hostFQDN
2 , hostName
3 , processWarn ? "250"
4 , processAlert ? "400"
5 , loadWarn ? "8.0"
6 , loadAlert ? "10.0"
7 , mdadm
8 , sudo
9 , master
10 , lib
11 , ...
12 }:
13 let
14 defaultPassiveInfo = {
15 filter = lib.attrsets.filterAttrs
16 (k: v: builtins.elem k ["service_description"] || builtins.substring 0 1 k == "_");
17 use = "external-passive-service";
18 freshness_threshold = "450";
19 retry_interval = "1";
20 servicegroups = "webstatus-resources";
21 host_name = hostFQDN;
22 };
23 in
24 {
25 host = {
26 "${hostFQDN}" = {
27 alias = hostFQDN;
28 address = hostFQDN;
29 use = "linux-server";
30 hostgroups = "webstatus-hosts";
31 _webstatus_name = hostName;
32 };
33 };
34 service = [
35 {
36 passiveInfo = defaultPassiveInfo;
37 service_description = "Size on root partition";
38 use = "local-service";
39 check_command = ["check_local_disk" "20%" "10%" "/"];
40 }
41 {
42 passiveInfo = defaultPassiveInfo;
43 service_description = "Total number of process";
44 use = "local-service";
45 check_command = [
46 "check_local_procs"
47 processWarn
48 processAlert
49 "RSZDT"
50 ];
51 }
52 {
53 passiveInfo = defaultPassiveInfo;
54 service_description = "Average load";
55 use = "local-service";
56 check_command = [
57 "check_local_load"
58 "${loadWarn},${loadWarn},${loadWarn}"
59 "${loadAlert},${loadAlert},${loadAlert}"
60 ];
61 }
62 {
63 passiveInfo = defaultPassiveInfo;
64 service_description = "Swap usage";
65 use = "local-service";
66 check_command = ["check_local_swap" "20" "10"];
67 }
68 {
69 passiveInfo = defaultPassiveInfo;
70 service_description = "Memory usage";
71 use = "local-service";
72 check_command = ["check_memory" "80" "90"];
73 }
74 {
75 passiveInfo = defaultPassiveInfo;
76 service_description = "NTP is activated and working";
77 use = "local-service";
78 check_command = ["check_ntp"];
79 }
80 {
81 passiveInfo = defaultPassiveInfo;
82 service_description = "No mdadm array is degraded";
83 use = "local-service";
84 check_command = [
85 "check_command_output"
86 "${mdadm}/bin/mdadm --monitor --scan -1"
87 "^$"
88 "-s 0 -r root"
89 ];
90 }
91 ];
92 command = {
93 check_dns = "$USER1$/check_dns -H $ARG1$ -s $HOSTADDRESS$ $ARG2$";
94 check_external_dns = "$USER1$/check_dns -H $ARG2$ -s $ARG1$ $ARG3$";
95 check_ftp_database = "$USER2$/check_ftp_database";
96 check_git = "$USER2$/check_git $USER203$";
97 check_http = "$USER1$/check_http --sni -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
98 check_https = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
99 check_https_auth = "$USER1$/check_http --sni --ssl -a \"$USER202$\" -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
100 check_https_certificate = "$USER1$/check_http --sni --ssl -H \"$ARG1$\" -C 21,15";
101 check_https_code = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -e \"$ARG3$\" -r \"$ARG4$\"";
102 check_imap_connection = "$USER2$/check_imap_connection -u \"$USER204$\" -p \"$USER205$\" -H \"imap.immae.eu:143\"";
103 check_local_disk = "$USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$";
104 check_local_procs = "$USER1$/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$";
105 check_local_load = "$USER1$/check_load -w $ARG1$ -c $ARG2$";
106 check_local_swap = "$USER1$/check_swap -n ok -w $ARG1$ -c $ARG2$";
107 check_memory = "$USER2$/check_mem.sh -w $ARG1$ -c $ARG2$";
108 check_command_match = "$USER2$/check_command -c \"$ARG1$\" -C \"$ARG2$\" $ARG3$";
109 check_command_output = "$USER2$/check_command -c \"$ARG1$\" -s 0 -o \"$ARG2$\" $ARG3$";
110 check_command_status = "$USER2$/check_command -c \"$ARG1$\" -s \"$ARG2$\" $ARG3$";
111 check_ntp = "$USER1$/check_ntp_time -t 30 -q -H 0.arch.pool.ntp.org";
112 check_mailq = "$USER1$/check_mailq -s -w 1 -c 2";
113 check_maison_bbc = "$USER2$/check_maison_bbc";
114 check_mysql_replication = "${sudo} -u mysql $USER2$/check_mysql_replication \"$ARG1$\" \"$ARG2$\"";
115 check_postgresql_replication = "${sudo} -u postgres $USER2$/check_postgres_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\"";
116 check_openldap_replication = "${sudo} -u openldap $USER2$/check_openldap_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\" \"$ARG4$\" \"$ARG5$\"";
117 check_redis_replication = "${sudo} -u redis $USER2$/check_redis_replication \"$ARG1$\"";
118 check_smtp = "$USER1$/check_smtp -H $HOSTADDRESS$ -p 25 -S -D 21,15";
119 check_tcp = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -e \"$ARG2$\" -Mcrit";
120 check_tcp_ssl = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -S -D 21,15";
121
122 check_host_alive = "$USER1$/check_ping -H $HOSTADDRESS$ -w 3000.0,80% -c 5000.0,100% -p 5";
123 check_last_file_date = "${sudo} -u \"$ARG3$\" $USER2$/check_last_file_date \"$ARG1$\" \"$ARG2$\"";
124 check_ok = "$USER1$/check_dummy 0 \"Dummy OK\"";
125 check_critical = "$USER1$/check_dummy 2 \"Dummy CRITICAL\"";
126
127 # $OVE is to force naemon to run via shell instead of execve which fails here
128 notify-host-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" HOSTSTATE=\"$HOSTSTATE$\" HOSTOUTPUT=\"$HOSTOUTPUT$\" $USER2$/notify_by_email host \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
129 # $OVE is to force naemon to run via shell instead of execve which fails here
130 notify-service-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_email service \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
131 notify-maison-bbc-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_maison_bbc_by_email service \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
132 notify-by-slack = "HOST=\"$HOSTALIAS$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_slack \"$ARG1$\" \"$ARG2$\"";
133
134 notify-master = "$USER2$/send_nrdp.sh -u \"$USER200$\" -t \"$USER201$\" -H \"$HOSTADDRESS$\" -s \"$SERVICEDESC$\" -S \"$SERVICESTATEID$\" -o \"$SERVICEOUTPUT$\"";
135 };
136 timeperiod = {
137 "24x7" = {
138 alias = "24 Hours A Day, 7 Days A Week";
139 monday = "00:00-24:00";
140 tuesday = "00:00-24:00";
141 wednesday = "00:00-24:00";
142 thursday = "00:00-24:00";
143 friday = "00:00-24:00";
144 saturday = "00:00-24:00";
145 sunday = "00:00-24:00";
146 };
147 };
148 servicegroup = {
149 webstatus-webapps = { alias = "Web applications"; };
150 webstatus-websites = { alias = "Personal websites"; };
151 webstatus-ssl = { alias = "SSL certificates"; };
152 webstatus-dns = { alias = "DNS resolution"; };
153 webstatus-remote-services = { alias = "Other remote services"; };
154 webstatus-local-services = { alias = "Other local services"; };
155 webstatus-email = { alias = "E-mail services"; };
156 webstatus-resources = { alias = "Local resources"; };
157 webstatus-databases = { alias = "Databases resources"; };
158 webstatus-backup = { alias = "Backup resources"; };
159 };
160 hostgroup = {
161 webstatus-hosts = { alias = "Hosts"; };
162 };
163 contactgroup = {
164 admins = { alias = "Naemon Administrators"; };
165 };
166 templates = {
167 service = {
168 generic-service = {
169 active_checks_enabled = "1";
170 check_freshness = "0";
171 check_interval = "10";
172 check_period = "24x7";
173 contact_groups = "admins";
174 event_handler_enabled = "1";
175 flap_detection_enabled = "1";
176 is_volatile = "0";
177 max_check_attempts = "3";
178 notification_interval = "60";
179 notification_options = "w,u,c,r,f,s";
180 notification_period = "24x7";
181 notifications_enabled = if master then "1" else "0";
182 obsess_over_service = "1";
183 passive_checks_enabled = "1";
184 process_perf_data = "1";
185 retain_nonstatus_information = "1";
186 retain_status_information = "1";
187 retry_interval = "2";
188 };
189 local-service = {
190 use = "generic-service";
191 host_name = hostFQDN;
192 check_interval = "5";
193 max_check_attempts = "4";
194 retry_interval = "1";
195 servicegroups = "webstatus-resources";
196 };
197 external-service = {
198 use = "generic-service";
199 check_interval = "5";
200 max_check_attempts = "4";
201 retry_interval = "1";
202 };
203 web-service = {
204 use = "generic-service";
205 check_interval = "20";
206 max_check_attempts = "2";
207 retry_interval = "1";
208 };
209 external-web-service = {
210 use = "generic-service";
211 check_interval = "20";
212 max_check_attempts = "2";
213 retry_interval = "1";
214 };
215 mail-service = {
216 use = "generic-service";
217 check_interval = "15";
218 max_check_attempts = "1";
219 retry_interval = "1";
220 };
221 dns-service = {
222 use = "generic-service";
223 check_interval = "120";
224 notification_interval = "120";
225 max_check_attempts = "5";
226 retry_interval = "5";
227 };
228 };
229 # No contact, we go through master
230 contact = {
231 generic-contact = {
232 host_notification_commands = "notify-host-by-email";
233 host_notification_options = "d,u,r,f,s";
234 host_notification_period = "24x7";
235 service_notification_commands = "notify-service-by-email";
236 service_notification_options = "w,u,c,r,f,s";
237 service_notification_period = "24x7";
238 };
239 };
240 host = {
241 generic-host = {
242 event_handler_enabled = "1";
243 flap_detection_enabled = "1";
244 notification_period = "24x7";
245 notifications_enabled = "1";
246 process_perf_data = "1";
247 retain_nonstatus_information = "1";
248 retain_status_information = "1";
249 };
250 linux-server = {
251 check_command = "check_host_alive";
252 check_interval = "5";
253 check_period = "24x7";
254 contact_groups = "admins";
255 max_check_attempts = "10";
256 notification_interval = "120";
257 notification_options = "d,u,r,f";
258 retry_interval = "1";
259 };
260 };
261 };
262 }