]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_common.nix
Add some monitoring services (eriomem)
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_common.nix
1 { hostFQDN
2 , hostName
3 , processWarn ? "250"
4 , processAlert ? "400"
5 , loadWarn ? "8.0"
6 , loadAlert ? "10.0"
7 , mdadm
8 , sudo
9 , master
10 , lib
11 , ...
12 }:
13 let
14 defaultPassiveInfo = {
15 filter = lib.attrsets.filterAttrs
16 (k: v: builtins.elem k ["service_description"] || builtins.substring 0 1 k == "_");
17 use = "external-passive-service";
18 freshness_threshold = "450";
19 retry_interval = "1";
20 servicegroups = "webstatus-resources";
21 host_name = hostFQDN;
22 };
23 in
24 {
25 host = {
26 "${hostFQDN}" = {
27 alias = hostFQDN;
28 address = hostFQDN;
29 use = "linux-server";
30 hostgroups = "webstatus-hosts";
31 _webstatus_name = hostName;
32 };
33 };
34 service = [
35 {
36 passiveInfo = defaultPassiveInfo;
37 service_description = "Size on root partition";
38 use = "local-service";
39 check_command = ["check_local_disk" "20%" "10%" "/"];
40 }
41 {
42 passiveInfo = defaultPassiveInfo;
43 service_description = "Total number of process";
44 use = "local-service";
45 check_command = [
46 "check_local_procs"
47 processWarn
48 processAlert
49 "RSZDT"
50 ];
51 }
52 {
53 passiveInfo = defaultPassiveInfo;
54 service_description = "Average load";
55 use = "local-service";
56 check_command = [
57 "check_local_load"
58 "${loadWarn},${loadWarn},${loadWarn}"
59 "${loadAlert},${loadAlert},${loadAlert}"
60 ];
61 }
62 {
63 passiveInfo = defaultPassiveInfo;
64 service_description = "Swap usage";
65 use = "local-service";
66 check_command = ["check_local_swap" "20" "10"];
67 }
68 {
69 passiveInfo = defaultPassiveInfo;
70 service_description = "Memory usage";
71 use = "local-service";
72 check_command = ["check_memory" "80" "90"];
73 }
74 {
75 passiveInfo = defaultPassiveInfo;
76 service_description = "NTP is activated and working";
77 use = "local-service";
78 check_command = ["check_ntp"];
79 }
80 {
81 passiveInfo = defaultPassiveInfo;
82 service_description = "No mdadm array is degraded";
83 use = "local-service";
84 check_command = [
85 "check_command_output"
86 "${mdadm}/bin/mdadm --monitor --scan -1"
87 "^$"
88 "-s 0 -r root"
89 ];
90 }
91 ];
92 command = {
93 check_dns = "$USER1$/check_dns -H $ARG1$ -s $HOSTADDRESS$ $ARG2$";
94 check_eriomem = "$USER2$/check_eriomem $USER208$";
95 check_external_dns = "$USER1$/check_dns -H $ARG2$ -s $ARG1$ $ARG3$";
96 check_ftp_database = "$USER2$/check_ftp_database";
97 check_git = "$USER2$/check_git $USER203$";
98 check_http = "$USER1$/check_http --sni -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
99 check_https = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
100 check_https_auth = "$USER1$/check_http --sni --ssl -a \"$USER202$\" -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
101 check_https_certificate = "$USER1$/check_http --sni --ssl -H \"$ARG1$\" -C 21,15";
102 check_https_code = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -e \"$ARG3$\" -r \"$ARG4$\"";
103 check_imap_connection = "$USER2$/check_imap_connection -u \"$USER204$\" -p \"$USER205$\" -H \"imap.immae.eu:143\"";
104 check_local_disk = "$USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$";
105 check_local_procs = "$USER1$/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$";
106 check_local_load = "$USER1$/check_load -w $ARG1$ -c $ARG2$";
107 check_local_swap = "$USER1$/check_swap -n ok -w $ARG1$ -c $ARG2$";
108 check_memory = "$USER2$/check_mem.sh -w $ARG1$ -c $ARG2$";
109 check_command_match = "$USER2$/check_command -c \"$ARG1$\" -C \"$ARG2$\" $ARG3$";
110 check_command_output = "$USER2$/check_command -c \"$ARG1$\" -s 0 -o \"$ARG2$\" $ARG3$";
111 check_command_status = "$USER2$/check_command -c \"$ARG1$\" -s \"$ARG2$\" $ARG3$";
112 check_ntp = "$USER1$/check_ntp_time -t 30 -q -H 0.arch.pool.ntp.org";
113 check_mailq = "$USER1$/check_mailq -s -w 1 -c 2";
114 check_maison_bbc = "$USER2$/check_maison_bbc";
115 check_mysql_replication = "${sudo} -u mysql $USER2$/check_mysql_replication \"$ARG1$\" \"$ARG2$\"";
116 check_postgresql_replication = "${sudo} -u postgres $USER2$/check_postgres_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\"";
117 check_openldap_replication = "${sudo} -u openldap $USER2$/check_openldap_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\" \"$ARG4$\" \"$ARG5$\"";
118 check_redis_replication = "${sudo} -u redis $USER2$/check_redis_replication \"$ARG1$\"";
119 check_smtp = "$USER1$/check_smtp -H $HOSTADDRESS$ -p 25 -S -D 21,15";
120 check_tcp = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -e \"$ARG2$\" -Mcrit";
121 check_tcp_ssl = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -S -D 21,15";
122
123 check_host_alive = "$USER1$/check_ping -H $HOSTADDRESS$ -w 3000.0,80% -c 5000.0,100% -p 5";
124 check_last_file_date = "${sudo} -u \"$ARG3$\" $USER2$/check_last_file_date \"$ARG1$\" \"$ARG2$\"";
125 check_ok = "$USER1$/check_dummy 0 \"Dummy OK\"";
126 check_critical = "$USER1$/check_dummy 2 \"Dummy CRITICAL\"";
127
128 # $OVE is to force naemon to run via shell instead of execve which fails here
129 notify-host-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" HOSTSTATE=\"$HOSTSTATE$\" HOSTOUTPUT=\"$HOSTOUTPUT$\" $USER2$/notify_by_email host \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
130 # $OVE is to force naemon to run via shell instead of execve which fails here
131 notify-service-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_email service \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
132 notify-maison-bbc-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_maison_bbc_by_email service \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
133 notify-by-slack = "HOST=\"$HOSTALIAS$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_slack \"$ARG1$\" \"$ARG2$\"";
134
135 notify-master = "$USER2$/send_nrdp.sh -u \"$USER200$\" -t \"$USER201$\" -H \"$HOSTADDRESS$\" -s \"$SERVICEDESC$\" -S \"$SERVICESTATEID$\" -o \"$SERVICEOUTPUT$\"";
136 };
137 timeperiod = {
138 "24x7" = {
139 alias = "24 Hours A Day, 7 Days A Week";
140 monday = "00:00-24:00";
141 tuesday = "00:00-24:00";
142 wednesday = "00:00-24:00";
143 thursday = "00:00-24:00";
144 friday = "00:00-24:00";
145 saturday = "00:00-24:00";
146 sunday = "00:00-24:00";
147 };
148 };
149 servicegroup = {
150 webstatus-webapps = { alias = "Web applications"; };
151 webstatus-websites = { alias = "Personal websites"; };
152 webstatus-ssl = { alias = "SSL certificates"; };
153 webstatus-dns = { alias = "DNS resolution"; };
154 webstatus-remote-services = { alias = "Other remote services"; };
155 webstatus-local-services = { alias = "Other local services"; };
156 webstatus-email = { alias = "E-mail services"; };
157 webstatus-resources = { alias = "Local resources"; };
158 webstatus-databases = { alias = "Databases resources"; };
159 webstatus-backup = { alias = "Backup resources"; };
160 };
161 hostgroup = {
162 webstatus-hosts = { alias = "Hosts"; };
163 };
164 contactgroup = {
165 admins = { alias = "Naemon Administrators"; };
166 };
167 templates = {
168 service = {
169 generic-service = {
170 active_checks_enabled = "1";
171 check_freshness = "0";
172 check_interval = "10";
173 check_period = "24x7";
174 contact_groups = "admins";
175 event_handler_enabled = "1";
176 flap_detection_enabled = "1";
177 is_volatile = "0";
178 max_check_attempts = "3";
179 notification_interval = "60";
180 notification_options = "w,u,c,r,f,s";
181 notification_period = "24x7";
182 notifications_enabled = if master then "1" else "0";
183 obsess_over_service = "1";
184 passive_checks_enabled = "1";
185 process_perf_data = "1";
186 retain_nonstatus_information = "1";
187 retain_status_information = "1";
188 retry_interval = "2";
189 };
190 local-service = {
191 use = "generic-service";
192 host_name = hostFQDN;
193 check_interval = "5";
194 max_check_attempts = "4";
195 retry_interval = "1";
196 servicegroups = "webstatus-resources";
197 };
198 external-service = {
199 use = "generic-service";
200 check_interval = "5";
201 max_check_attempts = "4";
202 retry_interval = "1";
203 };
204 web-service = {
205 use = "generic-service";
206 check_interval = "20";
207 max_check_attempts = "2";
208 retry_interval = "1";
209 };
210 external-web-service = {
211 use = "generic-service";
212 check_interval = "20";
213 max_check_attempts = "2";
214 retry_interval = "1";
215 };
216 mail-service = {
217 use = "generic-service";
218 check_interval = "15";
219 max_check_attempts = "1";
220 retry_interval = "1";
221 };
222 dns-service = {
223 use = "generic-service";
224 check_interval = "120";
225 notification_interval = "120";
226 max_check_attempts = "5";
227 retry_interval = "5";
228 };
229 };
230 # No contact, we go through master
231 contact = {
232 generic-contact = {
233 host_notification_commands = "notify-host-by-email";
234 host_notification_options = "d,u,r,f,s";
235 host_notification_period = "24x7";
236 service_notification_commands = "notify-service-by-email";
237 service_notification_options = "w,u,c,r,f,s";
238 service_notification_period = "24x7";
239 };
240 };
241 host = {
242 generic-host = {
243 event_handler_enabled = "1";
244 flap_detection_enabled = "1";
245 notification_period = "24x7";
246 notifications_enabled = "1";
247 process_perf_data = "1";
248 retain_nonstatus_information = "1";
249 retain_status_information = "1";
250 };
251 linux-server = {
252 check_command = "check_host_alive";
253 check_interval = "5";
254 check_period = "24x7";
255 contact_groups = "admins";
256 max_check_attempts = "10";
257 notification_interval = "120";
258 notification_options = "d,u,r,f";
259 retry_interval = "1";
260 };
261 };
262 };
263 }