]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_common.nix
Add monitoring for duply backup
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_common.nix
1 { hostFQDN
2 , hostName
3 , processWarn ? "250"
4 , processAlert ? "400"
5 , loadWarn ? "8.0"
6 , loadAlert ? "10.0"
7 , mdadm
8 , sudo
9 , master
10 , lib
11 , ...
12 }:
13 let
14 defaultPassiveInfo = {
15 filter = lib.attrsets.filterAttrs
16 (k: v: builtins.elem k ["service_description"] || builtins.substring 0 1 k == "_");
17 use = "external-passive-service";
18 freshness_threshold = "450";
19 retry_interval = "1";
20 servicegroups = "webstatus-resources";
21 host_name = hostFQDN;
22 };
23 in
24 {
25 host = {
26 "${hostFQDN}" = {
27 alias = hostFQDN;
28 address = hostFQDN;
29 use = "linux-server";
30 hostgroups = "webstatus-hosts";
31 _webstatus_name = hostName;
32 };
33 };
34 service = [
35 {
36 passiveInfo = defaultPassiveInfo;
37 service_description = "Size on root partition";
38 use = "local-service";
39 check_command = ["check_local_disk" "20%" "10%" "/"];
40 }
41 {
42 passiveInfo = defaultPassiveInfo;
43 service_description = "Total number of process";
44 use = "local-service";
45 check_command = [
46 "check_local_procs"
47 processWarn
48 processAlert
49 "RSZDT"
50 ];
51 }
52 {
53 passiveInfo = defaultPassiveInfo;
54 service_description = "Average load";
55 use = "local-service";
56 check_command = [
57 "check_local_load"
58 "${loadWarn},${loadWarn},${loadWarn}"
59 "${loadAlert},${loadAlert},${loadAlert}"
60 ];
61 }
62 {
63 passiveInfo = defaultPassiveInfo;
64 service_description = "Swap usage";
65 use = "local-service";
66 check_command = ["check_local_swap" "20" "10"];
67 }
68 {
69 passiveInfo = defaultPassiveInfo;
70 service_description = "Memory usage";
71 use = "local-service";
72 check_command = ["check_memory" "80" "90"];
73 }
74 {
75 passiveInfo = defaultPassiveInfo;
76 service_description = "NTP is activated and working";
77 use = "local-service";
78 check_command = ["check_ntp"];
79 }
80 {
81 passiveInfo = defaultPassiveInfo;
82 service_description = "No mdadm array is degraded";
83 use = "local-service";
84 check_command = [
85 "check_command_output"
86 "${mdadm}/bin/mdadm --monitor --scan -1"
87 "^$"
88 "-s 0 -r root"
89 ];
90 }
91 ];
92 command = {
93 check_dns = "$USER1$/check_dns -H $ARG1$ -s $HOSTADDRESS$ $ARG2$";
94 check_emails = "$USER2$/check_emails -H $HOSTADDRESS$ -i $USER203$ -l $ARG1$ -p $ARG2$ -s $ARG3$ -f $ARG4$";
95 check_emails_local = "$USER2$/check_emails -H $HOSTADDRESS$ -n $ARG1$ -r $ADMINEMAIL$ -s $ARG2$ -f $ARG3$";
96 check_eriomem = "$USER2$/check_eriomem $USER208$";
97 check_eriomem_age = "$USER2$/check_eriomem_age $ARG1$";
98 check_external_dns = "$USER1$/check_dns -H $ARG2$ -s $ARG1$ $ARG3$";
99 check_ftp_database = "$USER2$/check_ftp_database";
100 check_git = "$USER2$/check_git $USER203$";
101 check_http = "$USER1$/check_http --sni -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
102 check_https = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
103 check_https_auth = "$USER1$/check_http --sni --ssl -a \"$USER202$\" -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
104 check_https_certificate = "$USER1$/check_http --sni --ssl -H \"$ARG1$\" -C 21,15";
105 check_https_code = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -e \"$ARG3$\" -r \"$ARG4$\"";
106 check_imap_connection = "$USER2$/check_imap_connection -u \"$USER204$\" -p \"$USER205$\" -H \"imap.immae.eu:143\"";
107 check_local_disk = "$USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$";
108 check_local_procs = "$USER1$/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$";
109 check_local_load = "$USER1$/check_load -w $ARG1$ -c $ARG2$";
110 check_local_swap = "$USER1$/check_swap -n ok -w $ARG1$ -c $ARG2$";
111 check_memory = "$USER2$/check_mem.sh -w $ARG1$ -c $ARG2$";
112 check_command_match = "$USER2$/check_command -c \"$ARG1$\" -C \"$ARG2$\" $ARG3$";
113 check_command_output = "$USER2$/check_command -c \"$ARG1$\" -s 0 -o \"$ARG2$\" $ARG3$";
114 check_command_status = "$USER2$/check_command -c \"$ARG1$\" -s \"$ARG2$\" $ARG3$";
115 check_ntp = "$USER1$/check_ntp_time -t 30 -q -H 0.arch.pool.ntp.org";
116 check_mailq = "$USER1$/check_mailq -s -w 1 -c 2";
117 check_mysql_replication = "${sudo} -u mysql $USER2$/check_mysql_replication \"$ARG1$\" \"$ARG2$\"";
118 check_postgresql_replication = "${sudo} -u postgres $USER2$/check_postgres_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\"";
119 check_openldap_replication = "${sudo} -u openldap $USER2$/check_openldap_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\" \"$ARG4$\" \"$ARG5$\"";
120 check_ovh_sms = "$USER2$/check_ovh_sms \"$USER209$\"";
121 check_redis_replication = "${sudo} -u redis $USER2$/check_redis_replication \"$ARG1$\"";
122 check_smtp = "$USER1$/check_smtp -H $HOSTADDRESS$ -p 25 -S -D 21,15";
123 check_tcp = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -e \"$ARG2$\" -Mcrit";
124 check_tcp_ssl = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -S -D 21,15";
125
126 check_host_alive = "$USER1$/check_ping -H $HOSTADDRESS$ -w 3000.0,80% -c 5000.0,100% -p 5";
127 check_last_file_date = "${sudo} -u \"$ARG3$\" $USER2$/check_last_file_date \"$ARG1$\" \"$ARG2$\"";
128 check_ok = "$USER1$/check_dummy 0 \"Dummy OK\"";
129 check_critical = "$USER1$/check_dummy 2 \"Dummy CRITICAL\"";
130
131 # $OVE is to force naemon to run via shell instead of execve which fails here
132 notify-host-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" HOSTSTATE=\"$HOSTSTATE$\" HOSTOUTPUT=\"$HOSTOUTPUT$\" $USER2$/notify_by_email host \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
133 # $OVE is to force naemon to run via shell instead of execve which fails here
134 notify-service-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_email service \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
135 notify-by-slack = "HOST=\"$HOSTALIAS$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_slack \"$ARG1$\" \"$ARG2$\"";
136
137 notify-master = "$USER2$/send_nrdp.sh -u \"$USER200$\" -t \"$USER201$\" -H \"$HOSTADDRESS$\" -s \"$SERVICEDESC$\" -S \"$SERVICESTATEID$\" -o \"$SERVICEOUTPUT$ | $SERVICEPERFDATA$\"";
138 };
139 timeperiod = {
140 "24x7" = {
141 alias = "24 Hours A Day, 7 Days A Week";
142 monday = "00:00-24:00";
143 tuesday = "00:00-24:00";
144 wednesday = "00:00-24:00";
145 thursday = "00:00-24:00";
146 friday = "00:00-24:00";
147 saturday = "00:00-24:00";
148 sunday = "00:00-24:00";
149 };
150 };
151 servicegroup = {
152 webstatus-webapps = { alias = "Web applications"; };
153 webstatus-websites = { alias = "Personal websites"; };
154 webstatus-ssl = { alias = "SSL certificates"; };
155 webstatus-dns = { alias = "DNS resolution"; };
156 webstatus-remote-services = { alias = "Other remote services"; };
157 webstatus-local-services = { alias = "Other local services"; };
158 webstatus-email = { alias = "E-mail services"; };
159 webstatus-resources = { alias = "Local resources"; };
160 webstatus-databases = { alias = "Databases resources"; };
161 webstatus-backup = { alias = "Backup resources"; };
162 };
163 hostgroup = {
164 webstatus-hosts = { alias = "Hosts"; };
165 };
166 contactgroup = {
167 admins = { alias = "Naemon Administrators"; };
168 };
169 templates = {
170 service = {
171 generic-service = {
172 active_checks_enabled = "1";
173 check_freshness = "0";
174 check_interval = "10";
175 check_period = "24x7";
176 contact_groups = "admins";
177 event_handler_enabled = "1";
178 flap_detection_enabled = "1";
179 is_volatile = "0";
180 max_check_attempts = "3";
181 notification_interval = "60";
182 notification_options = "w,u,c,r,f,s";
183 notification_period = "24x7";
184 notifications_enabled = if master then "1" else "0";
185 obsess_over_service = "1";
186 passive_checks_enabled = "1";
187 process_perf_data = "1";
188 retain_nonstatus_information = "1";
189 retain_status_information = "1";
190 retry_interval = "2";
191 };
192 local-service = {
193 use = "generic-service";
194 host_name = hostFQDN;
195 check_interval = "5";
196 max_check_attempts = "4";
197 retry_interval = "1";
198 servicegroups = "webstatus-resources";
199 };
200 external-service = {
201 use = "generic-service";
202 check_interval = "5";
203 max_check_attempts = "4";
204 retry_interval = "1";
205 };
206 web-service = {
207 use = "generic-service";
208 check_interval = "20";
209 max_check_attempts = "2";
210 retry_interval = "1";
211 };
212 external-web-service = {
213 use = "generic-service";
214 check_interval = "20";
215 max_check_attempts = "2";
216 retry_interval = "1";
217 };
218 mail-service = {
219 use = "generic-service";
220 check_interval = "15";
221 max_check_attempts = "1";
222 retry_interval = "1";
223 };
224 dns-service = {
225 use = "generic-service";
226 check_interval = "120";
227 notification_interval = "120";
228 max_check_attempts = "5";
229 retry_interval = "5";
230 };
231 };
232 # No contact, we go through master
233 contact = {
234 generic-contact = {
235 host_notification_commands = "notify-host-by-email";
236 host_notification_options = "d,u,r,f,s";
237 host_notification_period = "24x7";
238 service_notification_commands = "notify-service-by-email";
239 service_notification_options = "w,u,c,r,f,s";
240 service_notification_period = "24x7";
241 };
242 };
243 host = {
244 generic-host = {
245 event_handler_enabled = "1";
246 flap_detection_enabled = "1";
247 notification_period = "24x7";
248 notifications_enabled = "1";
249 process_perf_data = "1";
250 retain_nonstatus_information = "1";
251 retain_status_information = "1";
252 };
253 linux-server = {
254 check_command = "check_host_alive";
255 check_interval = "5";
256 check_period = "24x7";
257 contact_groups = "admins";
258 max_check_attempts = "10";
259 notification_interval = "120";
260 notification_options = "d,u,r,f";
261 retry_interval = "1";
262 };
263 };
264 };
265 }