]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/monitoring/objects_common.nix
Add status engine website
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_common.nix
1 { hostFQDN
2 , hostName
3 , processWarn ? "250"
4 , processAlert ? "400"
5 , loadWarn ? "8.0"
6 , loadAlert ? "10.0"
7 , mdadm
8 , sudo
9 , master
10 , lib
11 , ...
12 }:
13 let
14 defaultPassiveInfo = {
15 filter = lib.attrsets.filterAttrs
16 (k: v: builtins.elem k ["service_description"] || builtins.substring 0 1 k == "_");
17 use = "external-passive-service";
18 freshness_threshold = "450";
19 retry_interval = "1";
20 servicegroups = "webstatus-resources";
21 host_name = hostFQDN;
22 };
23 in
24 {
25 host = {
26 "${hostFQDN}" = {
27 alias = hostFQDN;
28 address = hostFQDN;
29 use = "linux-server";
30 hostgroups = "webstatus-hosts";
31 _webstatus_name = hostName;
32 };
33 };
34 service = [
35 {
36 passiveInfo = defaultPassiveInfo;
37 service_description = "Size on root partition";
38 use = "local-service";
39 check_command = ["check_local_disk" "20%" "10%" "/"];
40 }
41 {
42 passiveInfo = defaultPassiveInfo;
43 service_description = "Total number of process";
44 use = "local-service";
45 check_command = [
46 "check_local_procs"
47 processWarn
48 processAlert
49 "RSZDT"
50 ];
51 }
52 {
53 passiveInfo = defaultPassiveInfo;
54 service_description = "Average load";
55 use = "local-service";
56 check_command = [
57 "check_local_load"
58 "${loadWarn},${loadWarn},${loadWarn}"
59 "${loadAlert},${loadAlert},${loadAlert}"
60 ];
61 }
62 {
63 passiveInfo = defaultPassiveInfo;
64 service_description = "Swap usage";
65 use = "local-service";
66 check_command = ["check_local_swap" "20" "10"];
67 }
68 {
69 passiveInfo = defaultPassiveInfo;
70 service_description = "Memory usage";
71 use = "local-service";
72 check_command = ["check_memory" "80" "90"];
73 }
74 {
75 passiveInfo = defaultPassiveInfo;
76 service_description = "NTP is activated and working";
77 use = "local-service";
78 check_command = ["check_ntp"];
79 }
80 {
81 passiveInfo = defaultPassiveInfo;
82 service_description = "No mdadm array is degraded";
83 use = "local-service";
84 check_command = [
85 "check_command_output"
86 "${mdadm}/bin/mdadm --monitor --scan -1"
87 "^$"
88 "-s 0 -r root"
89 ];
90 }
91 ];
92 command = {
93 check_dns = "$USER1$/check_dns -H $ARG1$ -s $HOSTADDRESS$ $ARG2$";
94 check_emails = "$USER2$/check_emails -H $HOSTADDRESS$ -i $USER203$ -l $ARG1$ -p $ARG2$ -s $ARG3$ -f $ARG4$";
95 check_emails_local = "$USER2$/check_emails -H $HOSTADDRESS$ -n $ARG1$ -r $ADMINEMAIL$ -s $ARG2$ -f $ARG3$";
96 check_eriomem = "$USER2$/check_eriomem $USER208$";
97 check_external_dns = "$USER1$/check_dns -H $ARG2$ -s $ARG1$ $ARG3$";
98 check_ftp_database = "$USER2$/check_ftp_database";
99 check_git = "$USER2$/check_git $USER203$";
100 check_http = "$USER1$/check_http --sni -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
101 check_https = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
102 check_https_auth = "$USER1$/check_http --sni --ssl -a \"$USER202$\" -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
103 check_https_certificate = "$USER1$/check_http --sni --ssl -H \"$ARG1$\" -C 21,15";
104 check_https_code = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -e \"$ARG3$\" -r \"$ARG4$\"";
105 check_imap_connection = "$USER2$/check_imap_connection -u \"$USER204$\" -p \"$USER205$\" -H \"imap.immae.eu:143\"";
106 check_local_disk = "$USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$";
107 check_local_procs = "$USER1$/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$";
108 check_local_load = "$USER1$/check_load -w $ARG1$ -c $ARG2$";
109 check_local_swap = "$USER1$/check_swap -n ok -w $ARG1$ -c $ARG2$";
110 check_memory = "$USER2$/check_mem.sh -w $ARG1$ -c $ARG2$";
111 check_command_match = "$USER2$/check_command -c \"$ARG1$\" -C \"$ARG2$\" $ARG3$";
112 check_command_output = "$USER2$/check_command -c \"$ARG1$\" -s 0 -o \"$ARG2$\" $ARG3$";
113 check_command_status = "$USER2$/check_command -c \"$ARG1$\" -s \"$ARG2$\" $ARG3$";
114 check_ntp = "$USER1$/check_ntp_time -t 30 -q -H 0.arch.pool.ntp.org";
115 check_mailq = "$USER1$/check_mailq -s -w 1 -c 2";
116 check_mysql_replication = "${sudo} -u mysql $USER2$/check_mysql_replication \"$ARG1$\" \"$ARG2$\"";
117 check_postgresql_replication = "${sudo} -u postgres $USER2$/check_postgres_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\"";
118 check_openldap_replication = "${sudo} -u openldap $USER2$/check_openldap_replication \"$ARG1$\" \"$ARG2$\" \"$ARG3$\" \"$ARG4$\" \"$ARG5$\"";
119 check_ovh_sms = "$USER2$/check_ovh_sms \"$USER209$\"";
120 check_redis_replication = "${sudo} -u redis $USER2$/check_redis_replication \"$ARG1$\"";
121 check_smtp = "$USER1$/check_smtp -H $HOSTADDRESS$ -p 25 -S -D 21,15";
122 check_tcp = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -e \"$ARG2$\" -Mcrit";
123 check_tcp_ssl = "$USER1$/check_tcp -H $HOSTADDRESS$ -p $ARG1$ -S -D 21,15";
124
125 check_host_alive = "$USER1$/check_ping -H $HOSTADDRESS$ -w 3000.0,80% -c 5000.0,100% -p 5";
126 check_last_file_date = "${sudo} -u \"$ARG3$\" $USER2$/check_last_file_date \"$ARG1$\" \"$ARG2$\"";
127 check_ok = "$USER1$/check_dummy 0 \"Dummy OK\"";
128 check_critical = "$USER1$/check_dummy 2 \"Dummy CRITICAL\"";
129
130 # $OVE is to force naemon to run via shell instead of execve which fails here
131 notify-host-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" HOSTSTATE=\"$HOSTSTATE$\" HOSTOUTPUT=\"$HOSTOUTPUT$\" $USER2$/notify_by_email host \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
132 # $OVE is to force naemon to run via shell instead of execve which fails here
133 notify-service-by-email = "ADMINEMAIL=\"$ADMINEMAIL$\" SERVICENOTIFICATIONID=\"$SERVICENOTIFICATIONID$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_email service \"$NOTIFICATIONTYPE$\" \"$HOSTALIAS$\" \"$LONGDATETIME$\" \"$CONTACTEMAIL$\" $OVE";
134 notify-by-slack = "HOST=\"$HOSTALIAS$\" SERVICESTATE=\"$SERVICESTATE$\" SERVICEDESC=\"$SERVICEDESC$\" SERVICEOUTPUT=\"$SERVICEOUTPUT$\" $USER2$/notify_by_slack \"$ARG1$\" \"$ARG2$\"";
135
136 notify-master = "$USER2$/send_nrdp.sh -u \"$USER200$\" -t \"$USER201$\" -H \"$HOSTADDRESS$\" -s \"$SERVICEDESC$\" -S \"$SERVICESTATEID$\" -o \"$SERVICEOUTPUT$ | $SERVICEPERFDATA$\"";
137 };
138 timeperiod = {
139 "24x7" = {
140 alias = "24 Hours A Day, 7 Days A Week";
141 monday = "00:00-24:00";
142 tuesday = "00:00-24:00";
143 wednesday = "00:00-24:00";
144 thursday = "00:00-24:00";
145 friday = "00:00-24:00";
146 saturday = "00:00-24:00";
147 sunday = "00:00-24:00";
148 };
149 };
150 servicegroup = {
151 webstatus-webapps = { alias = "Web applications"; };
152 webstatus-websites = { alias = "Personal websites"; };
153 webstatus-ssl = { alias = "SSL certificates"; };
154 webstatus-dns = { alias = "DNS resolution"; };
155 webstatus-remote-services = { alias = "Other remote services"; };
156 webstatus-local-services = { alias = "Other local services"; };
157 webstatus-email = { alias = "E-mail services"; };
158 webstatus-resources = { alias = "Local resources"; };
159 webstatus-databases = { alias = "Databases resources"; };
160 webstatus-backup = { alias = "Backup resources"; };
161 };
162 hostgroup = {
163 webstatus-hosts = { alias = "Hosts"; };
164 };
165 contactgroup = {
166 admins = { alias = "Naemon Administrators"; };
167 };
168 templates = {
169 service = {
170 generic-service = {
171 active_checks_enabled = "1";
172 check_freshness = "0";
173 check_interval = "10";
174 check_period = "24x7";
175 contact_groups = "admins";
176 event_handler_enabled = "1";
177 flap_detection_enabled = "1";
178 is_volatile = "0";
179 max_check_attempts = "3";
180 notification_interval = "60";
181 notification_options = "w,u,c,r,f,s";
182 notification_period = "24x7";
183 notifications_enabled = if master then "1" else "0";
184 obsess_over_service = "1";
185 passive_checks_enabled = "1";
186 process_perf_data = "1";
187 retain_nonstatus_information = "1";
188 retain_status_information = "1";
189 retry_interval = "2";
190 };
191 local-service = {
192 use = "generic-service";
193 host_name = hostFQDN;
194 check_interval = "5";
195 max_check_attempts = "4";
196 retry_interval = "1";
197 servicegroups = "webstatus-resources";
198 };
199 external-service = {
200 use = "generic-service";
201 check_interval = "5";
202 max_check_attempts = "4";
203 retry_interval = "1";
204 };
205 web-service = {
206 use = "generic-service";
207 check_interval = "20";
208 max_check_attempts = "2";
209 retry_interval = "1";
210 };
211 external-web-service = {
212 use = "generic-service";
213 check_interval = "20";
214 max_check_attempts = "2";
215 retry_interval = "1";
216 };
217 mail-service = {
218 use = "generic-service";
219 check_interval = "15";
220 max_check_attempts = "1";
221 retry_interval = "1";
222 };
223 dns-service = {
224 use = "generic-service";
225 check_interval = "120";
226 notification_interval = "120";
227 max_check_attempts = "5";
228 retry_interval = "5";
229 };
230 };
231 # No contact, we go through master
232 contact = {
233 generic-contact = {
234 host_notification_commands = "notify-host-by-email";
235 host_notification_options = "d,u,r,f,s";
236 host_notification_period = "24x7";
237 service_notification_commands = "notify-service-by-email";
238 service_notification_options = "w,u,c,r,f,s";
239 service_notification_period = "24x7";
240 };
241 };
242 host = {
243 generic-host = {
244 event_handler_enabled = "1";
245 flap_detection_enabled = "1";
246 notification_period = "24x7";
247 notifications_enabled = "1";
248 process_perf_data = "1";
249 retain_nonstatus_information = "1";
250 retain_status_information = "1";
251 };
252 linux-server = {
253 check_command = "check_host_alive";
254 check_interval = "5";
255 check_period = "24x7";
256 contact_groups = "admins";
257 max_check_attempts = "10";
258 notification_interval = "120";
259 notification_options = "d,u,r,f";
260 retry_interval = "1";
261 };
262 };
263 };
264 }