]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/private/environment-dummy/flake.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / private / environment-dummy / flake.nix
1 {
2 description = ''
3 A dummy flake that contains a compatible structure to the one stored at
4 git+ssh://gitolite@git.immae.eu/perso/Immae/Config/Nix/Nixops/Secrets
5 It is used as default value in "public" configurations
6 '';
7 outputs = { self }: {
8 vars-file = ./vars.yml;
9 ldap-conf = ./ldap.conf;
10 environment-file = ./environment.nix;
11 nixosModule = self.nixosModules.my-environment;
12 nixosModules.my-environment = { ... }: {
13 config.myEnv = import self.environment-file;
14 };
15 nixosModules.users-config-eldiron = { ... }: {};
16 };
17 }
18