]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/opendmarc/default.nix
Refactor flakes using follows
[perso/Immae/Config/Nix.git] / flakes / opendmarc / default.nix
1 { stdenv, lib, libspf2, libbsd, openssl, libmilter, perl, libnsl, fetchurl }:
2 stdenv.mkDerivation rec {
3 pname = "opendmarc";
4 version = "1.3.2";
5
6 src = fetchurl {
7 url = "mirror://sourceforge/opendmarc/files/${pname}-${version}.tar.gz";
8 sha256 = "1yrggj8yq0915y2i34gfz2xpl1w2lgb1vggp67rwspgzm40lng11";
9 };
10
11 configureFlags= [
12 "--with-spf"
13 "--with-spf2-include=${libspf2}/include/spf2"
14 "--with-spf2-lib=${libspf2}/lib/"
15 "--with-milter=${libmilter}"
16 ];
17
18 buildInputs = [ libspf2 libbsd openssl libmilter perl libnsl ];
19
20 meta = {
21 description = "Free open source software implementation of the DMARC specification";
22 homepage = "http://www.trusteddomain.org/opendmarc/";
23 platforms = lib.platforms.unix;
24 };
25 }