]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/mypackages/pkgs/webapps/nextcloud/apps/social.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / webapps / nextcloud / apps / social.nix
1 { buildApp, nextcloudVersion }:
2 let
3 social_0_6_1 = buildApp rec {
4 appName = "social";
5 version = "0.6.1";
6 url = "https://github.com/nextcloud-releases/social/releases/download/v${version}/${appName}-v${version}.tar.gz";
7 sha256 = "sha256-5mww31ibwgnSiTuTaKo5MngbhPIw8lwLt1tkQySmerY=";
8 };
9 versions = {
10 "26" = social_0_6_1;
11 "27" = social_0_6_1;
12 };
13 in
14 versions."${builtins.toString nextcloudVersion}" or (throw "Unsupported version for nextcloud app social")