]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/mypackages/pkgs/riotkit-do/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / riotkit-do / default.nix
1 { python3Packages }:
2 let
3 tabulate = python3Packages.buildPythonPackage rec {
4 version = "0.8.7";
5 pname = "tabulate";
6
7 src = python3Packages.fetchPypi {
8 inherit pname version;
9 sha256 = "sha256-2ycjog0EvNqFIhZcc+6nwwDtp04M6FLZAi4BWdeJUAc=";
10 };
11
12 checkInputs = with python3Packages; [ nose ];
13
14 doCheck = false;
15 };
16
17 python-dotenv = python3Packages.buildPythonPackage rec {
18 pname = "python-dotenv";
19 version = "0.13.0";
20
21 src = python3Packages.fetchPypi {
22 inherit pname version;
23 sha256 = "sha256-O5kJvJaw7cawFYbh7tBecRdO9OBMcdpXhjcM6+pTrXQ=";
24 };
25
26 propagatedBuildInputs = with python3Packages; [ click ];
27
28 checkInputs = with python3Packages; [
29 ipython
30 mock
31 pytestCheckHook
32 sh
33 ];
34
35 disabledTests = [
36 "cli"
37 ];
38
39 pythonImportsCheck = [ "dotenv" ];
40 };
41 in
42 python3Packages.buildPythonApplication rec {
43 pname = "rkd";
44 version = "2.4.0";
45 src = python3Packages.fetchPypi {
46 inherit pname version;
47 sha256 = "sha256-WC0FmUYGkV9PFvRtiFW6w6RtP+9Zf6kizl8jGiRb4HQ=";
48 };
49
50 propagatedBuildInputs = with python3Packages; [
51 pbr
52 jinja2
53 pyyaml
54 tabulate
55 psutil
56 pytest
57 python-dotenv
58 jsonschema
59 ];
60 }