]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/mypackages/pkgs/gearmand/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / gearmand / default.nix
1 { stdenv, fetchurl, boost, gperf, libevent, libmysqlclient, libuuid, sqlite, hiredis, postgresql, openssl }:
2 stdenv.mkDerivation rec {
3 pname = "gearmand";
4 version = "1.1.20";
5 src = fetchurl {
6 url = "https://github.com/gearman/${pname}/releases/download/${version}/${pname}-${version}.tar.gz";
7 sha256 = "sha256-L2D6IH3NcwWV75ap3DyomVZnB8gXYQazxj7PR+3BR6Y=";
8 };
9 buildInputs = [ boost gperf libevent openssl libmysqlclient libuuid sqlite hiredis postgresql ];
10 configureFlags = [
11 "--with-boost=${boost.dev}"
12 "--with-boost-libdir=${boost}/lib"
13 "--with-openssl=${openssl.dev}"
14 "--enable-ssl"
15 ];
16 }