]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/mypackages/pkgs/fluent-bit/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / fluent-bit / default.nix
1 { lib, stdenv, fetchFromGitHub, cmake, flex, bison, pkg-config
2 , systemd, openssl, postgresql }:
3
4 stdenv.mkDerivation rec {
5 pname = "fluent-bit";
6 version = "1.8.3";
7
8 src = fetchFromGitHub {
9 owner = "fluent";
10 repo = "fluent-bit";
11 rev = "v${version}";
12 sha256 = "004x135imja67babmmpkk1jpp5xwhfa8cwg1svaas2asq6cnv77d";
13 };
14
15 nativeBuildInputs = [ cmake flex bison pkg-config postgresql ];
16
17 buildInputs = [ openssl ]
18 ++ lib.optionals stdenv.isLinux [ systemd ];
19
20 cmakeFlags = [ "-DFLB_METRICS=ON" "-DFLB_HTTP_SERVER=ON" "-DFLB_SQLDB=ON" "-DFLB_OUT_PGSQL=ON" "-DFLB_IN_SYSTEMD=ON" ];
21
22 patches = lib.optionals stdenv.isDarwin [ ./fix-luajit-darwin.patch ];
23
24 NIX_CFLAGS_COMPILE = lib.optionals stdenv.cc.isGNU [
25 # _FORTIFY_SOURCE requires compiling with optimization (-O)
26 "-O"
27 # Needed due to bundled mbedtls
28 "-Wno-error=format"
29 "-Wno-error=format-truncation"
30 ];
31
32
33 outputs = [ "out" "dev" ];
34
35 postPatch = ''
36 substituteInPlace src/CMakeLists.txt \
37 --replace /lib/systemd $out/lib/systemd
38 '';
39
40 meta = with lib; {
41 description = "Log forwarder and processor, part of Fluentd ecosystem";
42 homepage = "https://fluentbit.io";
43 maintainers = with maintainers; [ samrose fpletz ];
44 license = licenses.asl20;
45 platforms = platforms.unix;
46 };
47 }