]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/mypackages/lib/flake-parts-lib.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / lib / flake-parts-lib.nix
1 i@{ name, type }:
2 { lib, flake-parts-lib, ... }:
3 flake-parts-lib.mkTransposedPerSystemModule {
4 inherit name;
5 option = lib.mkOption {
6 type = lib.types.lazyAttrsOf lib.types."${type}";
7 default = { };
8 };
9 file = import ./flake-parts-lib.nix i;
10 }