]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/mypackages/flake.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / flake.nix
1 {
2 description = "immae-eu infrastructure";
3 inputs = {
4 flake-parts.url = "github:hercules-ci/flake-parts";
5 # TODO: use nixos-unstable branch at some point and use the lock to keep the actual commit
6 nixpkgs.url = "github:nixos/nixpkgs/062a0c5437b68f950b081bbfc8a699d57a4ee026";
7 webapps-ttrss = {
8 url = "https://git.tt-rss.org/fox/tt-rss.git";
9 ref = "master";
10 rev = "986ca251f995f7754a0470d3e0c44538a545081f";
11 type = "git";
12 flake = false;
13 };
14 };
15 outputs = inputs@{ self, flake-parts, ... }:
16 flake-parts.lib.mkFlake { inherit inputs; } {
17 imports = [
18 (import ./lib/flake-parts-lib.nix { name = "lib"; type = "unspecified"; })
19 ];
20 systems = [ "x86_64-linux" ];
21 perSystem = { config, inputs', pkgs, ... }:
22 let
23 mypkgs = import ./pkgs/default.nix { inherit pkgs; inherit (self) mylibs sources; };
24 in {
25 packages = builtins.removeAttrs mypkgs [ "composerEnv" "webapps-apache-theme" ];
26 lib = {
27 inherit (self) sources;
28 inherit (mypkgs) composerEnv;
29 inherit (self.mylibs) postfixScript;
30 apache-theme = mypkgs.webapps-apache-theme;
31 };
32 };
33 flake = {
34 mylibs = import ./lib/default.nix;
35 sources.tools.ttrss = inputs.webapps-ttrss;
36 # We want overlays to be infected (in contrary to "packages"
37 # above): if someone imports an overlay here, we want his own
38 # overlays to be taken into account in every package, even new
39 # ones.
40 overlays = import ./overlays/default.nix { inherit (self) sources mylibs; };
41 };
42 };
43 }