]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - flakes/copanier/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / copanier / default.nix
1 { src, glibcLocales, poetry2nix, fetchFromGitHub, python37, fetchpatch }:
2 let
3 poetryApp = poetry2nix.mkPoetryApplication rec {
4 inherit src;
5 patches = [ ./fix_reduce.patch ];
6 overrides = poetry2nix.overrides.withDefaults (self: super: {
7 weasyprint = super.weasyprint.overridePythonAttrs (old: {
8 patches = let
9 p0 = (fetchpatch {
10 url = "https://github.com/Kozea/WeasyPrint/commit/47043a1fd7e50a892b9836466f521df85d597c44.patch";
11 sha256 = "18lmz6whjqxdpv4fdmg5vcpk2acdl99kfmp14badpw1jmffw7zl2";
12 postFetch = ''
13 sed -i -e "s/font_filename/filename/" $out
14 '';
15 });
16 p1 = (builtins.elemAt old.patches 1).overrideAttrs(old: {
17 postInstall = ''
18 sed -i -e "s/so.0/so/" $out
19 '';
20 });
21 in [ p0 p1 ];
22 });
23 });
24 pyproject = ./pyproject.toml;
25 poetrylock = ./poetry.lock;
26 python = python37;
27 locales = "${glibcLocales}/lib/locale/locale-archive";
28 };
29 in
30 poetryApp