]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - environments/immae-eu.nix
Add file manager
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
1 { pkgs }: with pkgs;
2 let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 cardano cardano-cli sia monero
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
26 rr valgrind netcat-gnu strace shellcheck
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix
35 bogofilter fetchmail
36 sieve-connect
37
38 # git
39 vcsh gitRepo gitAndTools.stgit tig ripgrep mr
40
41 # graphical tools
42 nextcloud-client firefox
43 dwm dmenu st xorg.xauth tigervnc
44
45 # images
46 feh imagemagick tiv graphicsmagick qrcode
47
48 # internet browsing
49 w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
56 iftop htop iotop iperf bonfire
57 goaccess tcpdump tshark tcpflow mitmproxy
58 # nagnu
59
60 # messaging/forums/news
61 #flrn slrn
62 telegram-cli telegram-history-dump telegramircd
63 weechat profanity
64 newsboat irssi
65
66 # nix
67 yarn2nix-moretea.yarn2nix nix
68 nixops nix-prefetch-scripts nix-generate-from-cpan
69 bundix nodePackages.bower2nix
70 nodePackages.node2nix niv
71 # (nixos {}).nixos-generate-config
72 # (nixos {}).nixos-install
73 # (nixos {}).nixos-enter
74 # (nixos {}).manual.manpages
75
76 # note taking
77 note terminal-velocity jrnl doing
78
79 # office
80 sc-im ranger
81 genius bc
82 ledger
83 tmux
84 rtorrent
85 ldapvi
86 fzf
87 buku
88 vimPlugins.vim-plug
89 (vim_configurable.override { python = python3; })
90 mailcap
91 webapps.surfer
92
93 # password management
94 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
95
96 # pdf
97 pdftk poppler_utils
98
99 # programming
100 pelican emacs26-nox ctags
101 wdiff patch gnumake
102
103 # security
104 keybase gnupg
105
106 # todolist/time management
107 taskwarrior vit timewarrior
108
109 # video/music
110 youtube-dl ncmpc ncmpcpp ffmpeg
111
112 # s6 tools (part of skawarePackages)
113 skalibs execline s6 s6-dns s6-linux-utils s6-networking
114 s6-portable-utils
115
116 # system tools
117 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
118 wget patchelf rename tmux (lib.meta.hiPrio nettools)
119 vlock mosh manpages openssl openssl.doc openssl.man
120
121 # other tools
122 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
123
124 # Terraform + AWS
125 terraform_0_12 awscli
126 (ansible.override { python2 = python3; }) python3Packages.boto
127 openvpn
128
129 zsh-completions
130 ];
131 in
132 buildEnv {
133 name = "immae-eu-packages";
134 inherit paths;
135 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
136 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
137 passthru = { packages = paths; };
138 }