]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - environments/immae-eu.nix
Add missing tools for dilion
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
1 { pkgs }: with pkgs;
2 let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 p7zip xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncer pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 cardano cardano-cli sia monero_0_15_0_0
21 xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
26 rr valgrind netcat-gnu strace shellcheck
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix notmuch
35 bogofilter fetchmail
36 sieve-connect
37
38 # git
39 vcsh gitRepo gitAndTools.stgit tig ripgrep mr
40
41 # graphical tools
42 nextcloud-client firefox
43 dwm dmenu st xorg.xauth tigervnc
44
45 # images
46 feh imagemagick tiv graphicsmagick qrcode
47
48 # internet browsing
49 w3m lynx links elinks browsh weboob urlview urlscan googler urlwatch
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
56 iftop htop iotop iperf bonfire
57 goaccess tcpdump tshark tcpflow mitmproxy
58 # nagnu
59
60 # messaging/forums/news
61 #flrn slrn
62 telegram-cli telegram-history-dump telegramircd
63 weechat profanity
64 newsboat irssi
65
66 # nix
67 mylibs.yarn2nixPackage.yarn2nix nix
68 nixops nix-prefetch-scripts nix-generate-from-cpan
69 nix-zsh-completions bundix nodePackages.bower2nix
70 nodePackages.node2nix
71 # (nixos {}).nixos-generate-config
72 # (nixos {}).nixos-install
73 # (nixos {}).nixos-enter
74 # (nixos {}).manual.manpages
75
76 # note taking
77 note terminal-velocity jrnl doing
78
79 # office
80 sc-im ranger
81 genius bc
82 ledger
83 tmux
84 rtorrent
85 ldapvi
86 fzf
87 buku
88 vimPlugins.vim-plug
89 mailcap
90
91 # password management
92 pass apg pwgen
93
94 # pdf
95 pdftk poppler_utils
96
97 # programming
98 pelican emacs26-nox ctags
99 wdiff patch gnumake
100
101 # security
102 keybase gnupg
103
104 # todolist/time management
105 taskwarrior vit timewarrior
106
107 # video/music
108 youtube-dl ncmpc ncmpcpp ffmpeg
109
110 # s6 tools (part of skawarePackages)
111 skalibs execline s6 s6-dns s6-linux-utils s6-networking
112 s6-portable-utils
113
114 # system tools
115 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
116 wget patchelf rename tmux (lib.meta.hiPrio nettools)
117 vlock mosh
118
119 # other tools
120 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli
121
122 # Terraform + AWS
123 terraform_0_12 awscli
124 (ansible.override { python2 = python3; }) python3Packages.boto
125 openvpn
126 ];
127 in
128 buildEnv {
129 name = "immae-eu-packages";
130 inherit paths;
131 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
132 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
133 passthru = { packages = paths; };
134 }