]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - environments/immae-eu.nix
Upgrade stgit
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
1 { pkgs }: with pkgs;
2 let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 paths = [
6 # archives
7 lzo unzip bzip2 xz
8 # unrar is unfree
9
10 # backups
11 duply
12
13 # calendar/contacts
14 abook khard khal cadaver vdirsyncerStable pal
15
16 # computing
17 boinctui
18
19 # cryptocurrencies
20 monero
21 # failing xmr-stak
22 solc
23 iota-cli-app
24
25 # debugging
26 rr valgrind netcat-gnu strace shellcheck
27
28 # documentations
29 unicodeDoc
30
31 # e-mails
32 muttprint mutt-ics
33 notmuch-python2 notmuch-python3 notmuch-vim
34 neomutt mairix
35 bogofilter fetchmail
36 sieve-connect
37
38 # git
39 vcsh gitRepo stgit tig ripgrep mr
40
41 # graphical tools
42 nextcloud-client firefox
43 dwm dmenu st xorg.xauth tigervnc
44
45 # images
46 feh imagemagick tiv graphicsmagick qrcode
47
48 # internet browsing
49 w3m lynx links elinks browsh woob urlview urlscan googler urlwatch
50
51 # less
52 python3Packages.pygments lesspipe highlight sourceHighlight
53
54 # monitoring
55 cnagios mtop pg_activity nagios-cli mtr
56 iftop htop iotop iperf bonfire
57 goaccess tcpdump tshark tcpflow
58 mitmproxy
59 # nagnu
60
61 # messaging/forums/news
62 flrn slrn
63 signal-cli signaldctl
64 telegram-cli telegram-history-dump telegramircd
65 weechat profanity
66 newsboat irssi
67
68 # nix
69 yarn2nix-moretea.yarn2nix nixUnstable
70 nixops nix-prefetch-scripts nix-generate-from-cpan
71 bundix nodePackages.bower2nix nix-diff
72 nodePackages.node2nix niv
73 # (nixos {}).nixos-generate-config
74 # (nixos {}).nixos-install
75 # (nixos {}).nixos-enter
76 # (nixos {}).manual.manpages
77
78 # note taking
79 note terminal-velocity jrnl doing nb
80
81 # office
82 sc-im ranger
83 genius bc
84 ledger
85 tmux
86 rtorrent
87 ldapvi
88 fzf
89 buku
90 vimPlugins.vim-plug
91 (vim_configurable.override { python = python3; })
92 mailcap
93 webapps.surfer
94
95 # password management
96 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
97
98 # pdf
99 pdftk poppler_utils
100
101 # programming
102 pelican emacs26-nox ctags
103 wdiff patch gnumake
104
105 # security
106 keybase gnupg
107
108 # todolist/time management
109 taskwarrior vit timewarrior taskopen
110 bugwarrior
111
112 # video/music
113 youtube-dl ncmpc ncmpcpp ffmpeg
114
115 # s6 tools (part of skawarePackages)
116 skalibs execline s6 s6-dns s6-linux-utils s6-networking
117 s6-portable-utils
118
119 # system tools
120 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
121 wget patchelf rename tmux (lib.meta.hiPrio nettools)
122 vlock mosh manpages openssl openssl.doc openssl.man
123 sshfs ncdu procps-ng
124
125 # other tools
126 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli bubblewrap
127
128 # Terraform + AWS
129 terraform_0_12 awscli
130 ansible python3Packages.boto
131 openvpn
132
133 zsh-completions
134 ];
135 in
136 buildEnv {
137 name = "immae-eu-packages";
138 inherit paths;
139 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
140 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
141 passthru = { packages = paths; };
142 }