]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - environments/immae-eu.nix
Add config for CI
[perso/Immae/Config/Nix.git] / environments / immae-eu.nix
1 { pkgs }: with pkgs;
2 let
3 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
4 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
5 vlock' = vlock.overrideAttrs(old: {
6 configureFlags = old.configureFlags ++ [ "--enable-root-password=no" ];
7 });
8 paths = [
9 # archives
10 lzo unzip bzip2 xz
11 # unrar is unfree
12
13 # backups
14 duply
15
16 # calendar/contacts
17 abook khard khal cadaver vdirsyncerStable pal
18
19 # computing
20 boinctui
21
22 # cryptocurrencies
23 monero
24 cointop
25 # failing xmr-stak
26 solc
27 iota-cli-app
28
29 # debugging
30 rr valgrind netcat-gnu strace shellcheck
31
32 # documentations
33 unicodeDoc
34
35 # e-mails
36 muttprint mutt-ics
37 notmuch-python2 notmuch-python3 notmuch-vim
38 neomutt mairix
39 bogofilter fetchmail
40 sieve-connect
41
42 # git
43 vcsh gitRepo stgit tig ripgrep mr
44
45 # graphical tools
46 nextcloud-client firefox
47 dwm dmenu st xorg.xauth tigervnc
48
49 # images
50 feh imagemagick tiv graphicsmagick qrcode
51
52 # internet browsing
53 w3m lynx links elinks browsh woob urlview urlscan googler urlwatch
54
55 # less
56 python3Packages.pygments lesspipe highlight sourceHighlight
57
58 # monitoring
59 cnagios mtop pg_activity nagios-cli mtr
60 iftop htop iotop iperf bonfire
61 goaccess tcpdump tshark tcpflow
62 mitmproxy
63 # nagnu
64
65 # messaging/forums/news
66 flrn slrn
67 signal-cli signaldctl
68 telegram-cli telegram-history-dump telegramircd
69 weechat profanity
70 newsboat irssi
71
72 # nix
73 yarn2nix-moretea.yarn2nix nixUnstable
74 nixops nix-prefetch-scripts nix-generate-from-cpan
75 bundix nodePackages.bower2nix nix-diff
76 nodePackages.node2nix niv
77 # (nixos {}).nixos-generate-config
78 # (nixos {}).nixos-install
79 # (nixos {}).nixos-enter
80 # (nixos {}).manual.manpages
81
82 # note taking
83 note terminal-velocity jrnl doing nb
84
85 # office
86 sc-im ranger
87 genius bc
88 ledger
89 tmux
90 rtorrent
91 ldapvi
92 fzf
93 buku
94 vimPlugins.vim-plug
95 (vim_configurable.override { python = python3; })
96 mailcap
97 webapps.surfer
98
99 # password management
100 (pass.withExtensions (exts: [ exts.pass-otp ])) apg pwgen
101
102 # pdf
103 pdftk poppler_utils
104
105 # programming
106 pelican emacs26-nox ctags
107 wdiff patch gnumake
108
109 # security
110 keybase gnupg
111
112 # todolist/time management
113 taskwarrior vit timewarrior taskopen
114 bugwarrior
115
116 # video/music
117 youtube-dl ncmpc ncmpcpp ffmpeg
118
119 # s6 tools (part of skawarePackages)
120 skalibs execline s6 s6-dns s6-linux-utils s6-networking
121 s6-portable-utils
122
123 # system tools
124 telnet bind.dnsutils httpie ngrep nmap p0f socat lsof psmisc
125 wget patchelf rename tmux (lib.meta.hiPrio nettools)
126 vlock' mosh manpages openssl openssl.doc openssl.man
127 sshfs ncdu procps-ng
128
129 # other tools
130 pgloader s3cmd lftp jq cpulimit libxslt gandi-cli bubblewrap
131
132 # Terraform + AWS
133 terraform_0_12 awscli
134 ansible python3Packages.boto
135 openvpn
136
137 zsh-completions
138 ];
139 in
140 buildEnv {
141 name = "immae-eu-packages";
142 inherit paths;
143 pathsToLink = [ "/bin" "/etc" "/include" "/lib" "/libexec" "/share"];
144 extraOutputsToInstall = [ "bin" "man" "doc" "info" ];
145 passthru = { packages = paths; };
146 }