]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - virtual/modules/websites/chloe/default.nix
Refactor a bit the php-fpm module
[perso/Immae/Config/Nix.git] / virtual / modules / websites / chloe / default.nix
CommitLineData
3013caf1
IB
1{ lib, pkgs, config, mylibs, ... }:
2let
091ae734 3 chloe = pkgs.callPackage ./chloe.nix { inherit (mylibs) checkEnv fetchedGitPrivate; };
86f6924f
IB
4 chloe_dev = chloe { environment = "dev"; };
5 chloe_prod = chloe { environment = "prod"; };
6
3013caf1
IB
7 cfg = config.services.myWebsites.Chloe;
8in {
9 options.services.myWebsites.Chloe = {
10 production = {
11 enable = lib.mkEnableOption "enable Chloe's website in production";
12 };
13 integration = {
14 enable = lib.mkEnableOption "enable Chloe's website in integration";
15 };
16 };
17
091ae734
IB
18 imports = [
19 ../commons/stats.nix
20 ];
21
3013caf1
IB
22 config = lib.mkMerge [
23 (lib.mkIf cfg.production.enable {
e4a945cd
IB
24 services.myWebsites.commons.stats.enable = true;
25 services.myWebsites.commons.stats.sites = [
26 {
27 name = "osteopathe-cc.fr";
091ae734 28 conf = ./goaccess.conf;
e4a945cd
IB
29 }
30 ];
31
3013caf1
IB
32 security.acme.certs."chloe" = config.services.myCertificates.certConfig // {
33 domain = "osteopathe-cc.fr";
34 extraDomains = {
35 "www.osteopathe-cc.fr" = null;
36 };
37 };
86f6924f 38
98584540 39 services.myPhpfpm.poolConfigs.chloe_prod = chloe_prod.phpFpm.pool;
86f6924f 40 system.activationScripts.chloe_prod = chloe_prod.activationScript;
f8bde3d6
IB
41 services.myWebsites.production.modules = chloe_prod.apache.modules;
42 services.myWebsites.production.vhostConfs.chloe = {
43 certName = "chloe";
44 hosts = ["osteopathe-cc.fr" "www.osteopathe-cc.fr" ];
45 root = chloe_prod.webRoot;
46 extraConfig = [ chloe_prod.apache.vhostConf ];
47 };
3013caf1
IB
48 })
49 (lib.mkIf cfg.integration.enable {
50 security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null;
98584540 51 services.myPhpfpm.poolConfigs.chloe_dev = chloe_dev.phpFpm.pool;
86f6924f 52 system.activationScripts.chloe_dev = chloe_dev.activationScript;
f8bde3d6
IB
53 services.myWebsites.integration.modules = chloe_dev.apache.modules;
54 services.myWebsites.integration.vhostConfs.chloe = {
55 certName = "eldiron";
56 hosts = ["chloe.immae.eu" ];
57 root = chloe_dev.webRoot;
58 extraConfig = [ chloe_dev.apache.vhostConf ];
59 };
3013caf1
IB
60 })
61 ];
62}