]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - virtual/modules/websites/chloe.nix
Start moving websites to their own modules: certificates
[perso/Immae/Config/Nix.git] / virtual / modules / websites / chloe.nix
CommitLineData
3013caf1
IB
1{ lib, pkgs, config, mylibs, ... }:
2let
3 cfg = config.services.myWebsites.Chloe;
4in {
5 options.services.myWebsites.Chloe = {
6 production = {
7 enable = lib.mkEnableOption "enable Chloe's website in production";
8 };
9 integration = {
10 enable = lib.mkEnableOption "enable Chloe's website in integration";
11 };
12 };
13
14 config = lib.mkMerge [
15 (lib.mkIf cfg.production.enable {
16 security.acme.certs."chloe" = config.services.myCertificates.certConfig // {
17 domain = "osteopathe-cc.fr";
18 extraDomains = {
19 "www.osteopathe-cc.fr" = null;
20 };
21 };
22 })
23 (lib.mkIf cfg.integration.enable {
24 security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null;
25 })
26 ];
27}