]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/modules/websites/tools/mastodon/mastodon.nix
Move mastodon secret to secure location
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
CommitLineData
7f6bd78f 1{ env, ruby_2_6, bundlerEnv, defaultGemConfig, yarn2nixPackage, fetchedGithub, stdenv, writeText, pkgs }:
35a397cd
IB
2let
3 varDir = "/var/lib/mastodon_immae";
4 socketsDir = "/run/mastodon";
2ff7e086
IB
5 gems = bundlerEnv {
6 name = "mastodon-env";
7f6bd78f 7 ruby = ruby_2_6;
2ff7e086
IB
8 gemset = ./gemset.nix;
9 gemdir = (fetchedGithub ./mastodon.json).src;
10 groups = [ "default" "production" "test" "development" ];
11 gemConfig = defaultGemConfig // {
7f6bd78f
IB
12 redis-rack = attrs: {
13 preBuild = ''
14 sed -i 's!s\.files.*!!' redis-rack.gemspec
15 '';
16 };
17 tzinfo = attrs: {
18 preBuild = ''
19 sed -i 's!s\.files.*!!' tzinfo.gemspec
20 '';
21 };
2ff7e086
IB
22 cld3 = attrs: {
23 buildInputs = with pkgs; [ protobuf protobufc pkgconfig ];
24 };
25 idn-ruby = attrs: {
26 buildInputs = with pkgs; [ libidn ];
27 };
28 rpam2 = attrs: {
29 buildInputs = with pkgs; [ pam ];
30 };
31 };
32 };
f27f4c9d
IB
33 yarnModules = let
34 info = fetchedGithub ./mastodon.json;
7f6bd78f
IB
35 packagejson = pkgs.runCommand "package.json" { buildInputs = [ pkgs.jq ]; } ''
36 cat ${info.src}/package.json | jq -r '.version = "${info.version}"' > $out
37 '';
f27f4c9d 38 in
7f6bd78f
IB
39 yarn2nixPackage.mkYarnModules rec {
40 name = "mastodon-yarn";
41 pname = name;
42 version = info.version;
43 packageJSON = packagejson;
f27f4c9d
IB
44 yarnLock = "${info.src}/yarn.lock";
45 yarnNix = ./yarn-packages.nix;
46 pkgConfig = {
47 uws = {
48 postInstall = ''
a4993193 49 npx node-gyp rebuild > build_log.txt 2>&1 || true
f27f4c9d 50 '';
f27f4c9d 51 };
f27f4c9d
IB
52 };
53 };
35a397cd 54 mastodon = stdenv.mkDerivation (fetchedGithub ./mastodon.json // rec {
35a397cd
IB
55 installPhase = ''
56 cp -a . $out
f27f4c9d 57 cp -a ${yarnModules}/node_modules $out
35a397cd 58 '';
7f6bd78f 59 buildInputs = [ yarnModules ];
35a397cd 60 });
50933a04
IB
61 keys.tools-mastodon = {
62 destDir = "/run/keys/webapps";
63 user = "mastodon";
64 group = "mastodon";
65 permissions = "0400";
66 text = ''
67 REDIS_HOST=${env.redis.host}
68 REDIS_PORT=${env.redis.port}
69 REDIS_DB=${env.redis.db}
70 DB_HOST=${env.postgresql.socket}
71 DB_USER=${env.postgresql.user}
72 DB_NAME=${env.postgresql.database}
73 DB_PASS=${env.postgresql.password}
74 DB_PORT=${env.postgresql.port}
35a397cd 75
50933a04
IB
76 LOCAL_DOMAIN=mastodon.immae.eu
77 LOCAL_HTTPS=true
78 ALTERNATE_DOMAINS=immae.eu
35a397cd 79
50933a04
IB
80 PAPERCLIP_SECRET=${env.paperclip_secret}
81 SECRET_KEY_BASE=${env.secret_key_base}
82 OTP_SECRET=${env.otp_secret}
35a397cd 83
50933a04
IB
84 VAPID_PRIVATE_KEY=${env.vapid.private}
85 VAPID_PUBLIC_KEY=${env.vapid.public}
35a397cd 86
50933a04
IB
87 SMTP_DELIVERY_METHOD=sendmail
88 SMTP_FROM_ADDRESS=mastodon@tools.immae.eu
89 SENDMAIL_LOCATION="/run/wrappers/bin/sendmail"
90 PAPERCLIP_ROOT_PATH=${varDir}
35a397cd 91
50933a04 92 STREAMING_CLUSTER_NUM=1
35a397cd 93
50933a04 94 RAILS_LOG_LEVEL=warn
46228a29 95
50933a04
IB
96 # LDAP authentication (optional)
97 LDAP_ENABLED=true
98 LDAP_HOST=ldap.immae.eu
99 LDAP_PORT=636
100 LDAP_METHOD=simple_tls
101 LDAP_BASE="dc=immae,dc=eu"
102 LDAP_BIND_DN="cn=mastodon,ou=services,dc=immae,dc=eu"
103 LDAP_PASSWORD="${env.ldap.password}"
104 LDAP_UID="uid"
105 LDAP_SEARCH_FILTER="(&(%{uid}=%{email})(memberOf=cn=users,cn=mastodon,ou=services,dc=immae,dc=eu))"
35a397cd 106 '';
50933a04 107 };
35a397cd 108
50933a04 109 # FIXME: build machine will contain some passwords in the nix store
35a397cd
IB
110 railsRoot = stdenv.mkDerivation {
111 name = "mastodon_immae";
50933a04 112 inherit mastodon;
35a397cd
IB
113 builder = writeText "build_mastodon_immae" ''
114 source $stdenv/setup
115 set -a
50933a04 116 ${keys.tools-mastodon.text}
35a397cd
IB
117 set +a
118 cp -a $mastodon $out
119 cd $out
f27f4c9d 120 chmod u+rwX . public
591ebd87
IB
121 chmod -R u+rwX config/
122 sed -i -e 's@^end$@ config.action_mailer.sendmail_settings = { location: ENV.fetch("SENDMAIL_LOCATION", "/usr/sbin/sendmail") }\nend@' config/environments/production.rb
2ff7e086
IB
123 RAILS_ENV=production ${gems}/bin/rails assets:precompile
124 rm -rf tmp/cache
3c8d7f87 125 ln -sf ${varDir}/tmp/cache tmp
35a397cd 126 '';
f27f4c9d 127 buildInputs = [ gems gems.ruby pkgs.nodejs pkgs.yarn ];
35a397cd
IB
128 };
129in
130 {
50933a04 131 inherit railsRoot keys varDir socketsDir gems;
35a397cd
IB
132 nodeSocket = "${socketsDir}/live_immae_node.sock";
133 railsSocket = "${socketsDir}/live_immae_puma.sock";
134 }