]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/modules/websites/default.nix
Replace myPhpfpm with correct overrides
[perso/Immae/Config/Nix.git] / nixops / modules / websites / default.nix
CommitLineData
8a964143 1{ lib, pkgs, config, myconfig, ... }:
42429ef0
IB
2let
3 cfg = config.services.myWebsites;
7da3ceec
IB
4 www_root = "/run/current-system/webapps/_www";
5 theme_root = "/run/current-system/webapps/_theme";
daf64e3f
IB
6 apacheConfig = {
7 gzip = {
8 modules = [ "deflate" "filter" ];
e2f5cc37 9 extraConfig = ''
daf64e3f
IB
10 AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript
11 '';
12 };
13 macros = {
14 modules = [ "macro" ];
e2f5cc37 15 };
daf64e3f 16 stats = {
950ca5ee 17 extraConfig = ''
daf64e3f
IB
18 <Macro Stats %{domain}>
19 Alias /webstats ${config.services.webstats.dataDir}/%{domain}
20 <Directory ${config.services.webstats.dataDir}/%{domain}>
21 DirectoryIndex index.html
22 AllowOverride None
23 Require all granted
24 </Directory>
25 <Location /webstats>
26 Use LDAPConnect
27 Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
28 </Location>
29 </Macro>
950ca5ee
IB
30 '';
31 };
daf64e3f
IB
32 ldap = {
33 modules = [ "ldap" "authnz_ldap" ];
34 extraConfig = ''
35 <IfModule ldap_module>
36 LDAPSharedCacheSize 500000
37 LDAPCacheEntries 1024
38 LDAPCacheTTL 600
39 LDAPOpCacheEntries 1024
40 LDAPOpCacheTTL 600
41 </IfModule>
42
43 Include /var/secrets/apache-ldap
44 '';
950ca5ee 45 };
daf64e3f
IB
46 global = {
47 extraConfig = (pkgs.webapps.apache-default.override { inherit www_root;}).apacheConfig;
f8bde3d6 48 };
daf64e3f
IB
49 apaxy = {
50 extraConfig = (pkgs.webapps.apache-theme.override { inherit theme_root; }).apacheConfig;
f8bde3d6 51 };
daf64e3f
IB
52 http2 = {
53 modules = [ "http2" ];
54 extraConfig = ''
55 Protocols h2 http/1.1
56 '';
f8bde3d6 57 };
daf64e3f
IB
58 customLog = {
59 extraConfig = ''
60 LogFormat "%v:%p %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combinedVhost
61 '';
f8bde3d6
IB
62 };
63 };
daf64e3f
IB
64 makeModules = lib.lists.flatten (lib.attrsets.mapAttrsToList (n: v: v.modules or []) apacheConfig);
65 makeExtraConfig = (builtins.filter (x: x != null) (lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) apacheConfig));
42429ef0
IB
66in
67{
68 imports = [
79d2de8b 69 ./tools/db.nix
10889174
IB
70 ./tools/tools
71 ./tools/dav
79d2de8b 72 ./tools/cloud.nix
10889174 73 ./tools/git
79d2de8b
IB
74 ./tools/mastodon.nix
75 ./tools/mediagoblin.nix
76 ./tools/diaspora.nix
bf3b7671 77 ./tools/ether.nix
f3a8fab5 78 ./tools/peertube.nix
42429ef0
IB
79 ];
80
42429ef0 81 config = {
98163486 82 users.users.wwwrun.extraGroups = [ "keys" ];
d68bb46b 83 networking.firewall.allowedTCPPorts = [ 80 443 ];
54307da4 84
2368a4b7 85 nixpkgs.overlays = [ (self: super: rec {
e2ca51b2 86 #openssl = self.openssl_1_1;
98584540 87 php = php72;
2368a4b7
IB
88 php72 = (super.php72.override {
89 mysql.connector-c = self.mariadb;
98584540
IB
90 config.php.mysqlnd = false;
91 config.php.mysqli = false;
92 }).overrideAttrs(old: rec {
93 # Didn't manage to build with mysqli + mysql_config connector
94 configureFlags = old.configureFlags ++ [
912921a7 95 "--with-mysqli=shared,mysqlnd"
98584540
IB
96 ];
97 # preConfigure = (old.preConfigure or "") + ''
98 # export CPPFLAGS="$CPPFLAGS -I${pkgs.mariadb}/include/mysql/server";
99 # sed -i -e 's/#include "mysqli_priv.h"/#include "mysqli_priv.h"\n#include <mysql_version.h>/' \
100 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
101 # '';
102 });
2368a4b7 103 phpPackages = super.php72Packages.override { inherit php; };
2368a4b7 104 }) ];
98584540 105
10889174
IB
106 services.myWebsites.tools.databases.enable = true;
107 services.myWebsites.tools.tools.enable = true;
108 services.myWebsites.tools.dav.enable = true;
109 services.myWebsites.tools.cloud.enable = true;
110 services.myWebsites.tools.git.enable = true;
35a397cd 111 services.myWebsites.tools.mastodon.enable = true;
56eba416 112 services.myWebsites.tools.mediagoblin.enable = true;
a7f7fdae 113 services.myWebsites.tools.diaspora.enable = true;
17146204 114 services.myWebsites.tools.etherpad-lite.enable = true;
0eaac6ba 115 services.myWebsites.tools.peertube.enable = true;
10889174 116
1a718805 117 secrets.keys = [{
8db8e666 118 dest = "apache-ldap";
415bcd27
IB
119 user = "wwwrun";
120 group = "wwwrun";
85f5ed68 121 permissions = "0400";
415bcd27
IB
122 text = ''
123 <Macro LDAPConnect>
124 <IfModule authnz_ldap_module>
125 AuthLDAPURL ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
126 AuthLDAPBindDN cn=httpd,ou=services,dc=immae,dc=eu
127 AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
128 AuthType Basic
129 AuthName "Authentification requise (Acces LDAP)"
130 AuthBasicProvider ldap
131 </IfModule>
132 </Macro>
133 '';
8db8e666 134 }];
415bcd27 135
10889174
IB
136 system.activationScripts = {
137 httpd = ''
9ade8f6e 138 install -d -m 0755 ${config.security.acme.directory}/acme-challenge
10889174
IB
139 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions
140 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/adminer
b7d2d4e3 141 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/tmp/adminer
10889174
IB
142 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/mantisbt
143 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/davical
b7d2d4e3 144 install -d -m 0750 -o wwwrun -g wwwrun /var/lib/php/sessions/phpldapadmin
10889174
IB
145 '';
146 };
147
7da3ceec
IB
148 system.extraSystemBuilderCmds = let
149 adminer = pkgs.callPackage ./commons/adminer.nix {};
150 in ''
151 mkdir -p $out/webapps
8f904d0d 152 ln -s ${pkgs.webapps.apache-default.www} $out/webapps/_www
d7d031b6 153 ln -s ${pkgs.webapps.apache-theme.theme} $out/webapps/_theme
7da3ceec
IB
154 ln -s ${adminer.webRoot} $out/webapps/${adminer.apache.webappName}
155 '';
156
f40f5b23 157 services.phpfpm = {
10889174
IB
158 phpPackage = pkgs.php;
159 phpOptions = ''
160 session.save_path = "/var/lib/php/sessions"
95b20e17 161 post_max_size = 20M
98163486
IB
162 ; 15 days (seconds)
163 session.gc_maxlifetime = 1296000
164 ; 30 days (minutes)
165 session.cache_expire = 43200
10889174
IB
166 '';
167 extraConfig = ''
168 log_level = notice
169 '';
170 };
171
daf64e3f
IB
172 services.websites.production = {
173 enable = true;
174 adminAddr = "httpd@immae.eu";
175 httpdName = "Prod";
176 ips =
177 let ips = myconfig.env.servers.eldiron.ips.production;
178 in [ips.ip4] ++ (ips.ip6 or []);
179 modules = makeModules;
180 extraConfig = makeExtraConfig;
181 fallbackVhost = {
182 certName = "eldiron";
183 hosts = ["eldiron.immae.eu" ];
184 root = www_root;
185 extraConfig = [ "DirectoryIndex index.htm" ];
186 };
187 };
f8bde3d6 188
daf64e3f
IB
189 services.websites.integration = {
190 enable = true;
191 adminAddr = "httpd@immae.eu";
192 httpdName = "Inte";
193 ips =
194 let ips = myconfig.env.servers.eldiron.ips.integration;
195 in [ips.ip4] ++ (ips.ip6 or []);
196 modules = makeModules;
197 extraConfig = makeExtraConfig;
198 fallbackVhost = {
199 certName = "eldiron";
200 hosts = ["eldiron.immae.eu" ];
201 root = www_root;
202 extraConfig = [ "DirectoryIndex index.htm" ];
203 };
204 };
950ca5ee 205
daf64e3f
IB
206 services.websites.tools = {
207 enable = true;
208 adminAddr = "httpd@immae.eu";
209 httpdName = "Tools";
210 ips =
211 let ips = myconfig.env.servers.eldiron.ips.main;
212 in [ips.ip4] ++ (ips.ip6 or []);
213 modules = makeModules;
214 extraConfig = makeExtraConfig ++
215 [ ''
216 RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
217 RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
218 RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
219 RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
220 RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
221 RedirectMatch ^/CGU$ https://www.immae.eu/CGU
222 ''
223 ];
224 nosslVhost = {
225 enable = true;
226 host = "nossl.immae.eu";
227 };
228 fallbackVhost = {
229 certName = "eldiron";
230 hosts = ["eldiron.immae.eu" ];
231 root = www_root;
232 extraConfig = [ "DirectoryIndex index.htm" ];
233 };
234 };
42429ef0
IB
235 };
236}