]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/eldiron.nix
Make pkg an argument of libs.nix
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
CommitLineData
9690acd9 1{ privateFiles ? ./. }:
a1bb33c4
IB
2{
3 network = {
4 description = "Immae's network";
5 enableRollback = true;
6 };
7
f8bde3d6 8 eldiron = { config, pkgs, mylibs, myconfig, ... }:
4d4f13f4 9 with mylibs;
ab5d04b8 10 {
4d4f13f4 11 _module.args = {
596e62a6 12 mylibs = import ../libs.nix { nixpkgs = pkgs; };
7636abc6 13 mypkgs = import ../default.nix;
f8bde3d6 14 myconfig = {
9690acd9
IB
15 inherit privateFiles;
16 env = import "${privateFiles}/environment.nix";
f8bde3d6
IB
17 ips = {
18 main = "176.9.151.89";
19 production = "176.9.151.154";
20 integration = "176.9.151.155";
21 };
22 };
4d4f13f4
IB
23 };
24
25 imports = [
3013caf1 26 ./modules/certificates.nix
10889174
IB
27 ./modules/gitolite
28 ./modules/databases
e229e6f2 29 ./modules/mpd
54307da4 30 ./modules/websites
af421a8f 31 ./modules/mail
439049e5 32 ./modules/ftp
5ccc61bb 33 ./modules/pub
22149d17 34 ./modules/task
4d4f13f4
IB
35 ];
36 services.myGitolite.enable = true;
4d4f13f4 37 services.myDatabases.enable = true;
42429ef0
IB
38 services.myWebsites.production.enable = true;
39 services.myWebsites.integration.enable = true;
10889174 40 services.myWebsites.tools.enable = true;
439049e5 41 services.pure-ftpd.enable = true;
5ccc61bb 42 services.pub.enable = true;
22149d17 43 services.myTasks.enable = true;
4d4f13f4 44
46228a29
IB
45 services.journald.extraConfig = ''
46 MaxLevelStore="warning"
47 MaxRetentionSec="1year"
48 '';
a1bb33c4
IB
49 networking = {
50 firewall = {
51 enable = true;
10889174 52 allowedTCPPorts = [ 22 ];
a1bb33c4
IB
53 };
54 };
55
56 deployment = {
57 targetEnv = "hetzner";
58 hetzner = {
9d90e7e2
IB
59 robotUser = myconfig.env.hetzner.user;
60 robotPass = myconfig.env.hetzner.pass;
f8bde3d6 61 mainIPv4 = myconfig.ips.main;
a1bb33c4
IB
62 partitions = ''
63 clearpart --all --initlabel --drives=sda,sdb
64
65 part swap1 --recommended --label=swap1 --fstype=swap --ondisk=sda
66 part swap2 --recommended --label=swap2 --fstype=swap --ondisk=sdb
67
68 part raid.1 --grow --ondisk=sda
69 part raid.2 --grow --ondisk=sdb
70
71 raid / --level=1 --device=md0 --fstype=ext4 --label=root raid.1 raid.2
72 '';
73 };
74 };
75
10889174 76 environment.systemPackages = [
ce6ee3b8 77 pkgs.telnet
beeed847 78 pkgs.htop
ce6ee3b8
IB
79 pkgs.vim
80 ];
81
5566d26d
IB
82 services.openssh.extraConfig = ''
83 AuthorizedKeysCommand /etc/ssh/ldap_authorized_keys
84 AuthorizedKeysCommandUser nobody
85 '';
86
5566d26d
IB
87 environment.etc."ssh/ldap_authorized_keys" = let
88 ldap_authorized_keys =
5c101474 89 wrap {
5566d26d
IB
90 name = "ldap_authorized_keys";
91 file = ./ldap_authorized_keys.sh;
92 vars = {
9d90e7e2 93 LDAP_PASS = myconfig.env.sshd.ldap.password;
5566d26d
IB
94 GITOLITE_SHELL = "${pkgs.gitolite}/bin/gitolite-shell";
95 ECHO = "${pkgs.coreutils}/bin/echo";
96 };
97 paths = [ pkgs.openldap pkgs.stdenv.shellPackage pkgs.gnugrep pkgs.gnused pkgs.coreutils ];
98 };
99 in {
100 enable = true;
101 mode = "0755";
102 user = "root";
103 source = ldap_authorized_keys;
65fe7543
IB
104 };
105
6533428a
IB
106 services.cron = {
107 enable = true;
108 systemCronJobs = [
109 ''
110 # The star after /var/lib/* avoids deleting all folders in case of problem
9d8d1425 111 0 3,9,15,21 * * * root rsync -e "ssh -i /root/.ssh/id_charon_vpn" -aAXvz --delete --numeric-ids --super --rsync-path="sudo rsync" /var/lib/* immae@immae.eu: > /dev/null
6533428a
IB
112 ''
113 ];
114 };
3de01f9b
IB
115
116 # This value determines the NixOS release with which your system is
117 # to be compatible, in order to avoid breaking some software such as
118 # database servers. You should change this only after NixOS release
119 # notes say you should.
120 system.stateVersion = "18.09"; # Did you read the comment?
a1bb33c4
IB
121 };
122}