]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/eldiron.nix
Add ldap
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
CommitLineData
9690acd9 1{ privateFiles ? ./. }:
a1bb33c4
IB
2{
3 network = {
4 description = "Immae's network";
5 enableRollback = true;
6 };
7
f8bde3d6 8 eldiron = { config, pkgs, mylibs, myconfig, ... }:
4d4f13f4 9 with mylibs;
ab5d04b8 10 {
4d4f13f4
IB
11 _module.args = {
12 mylibs = import ../libs.nix;
7636abc6 13 mypkgs = import ../default.nix;
f8bde3d6 14 myconfig = {
9690acd9
IB
15 inherit privateFiles;
16 env = import "${privateFiles}/environment.nix";
f8bde3d6
IB
17 ips = {
18 main = "176.9.151.89";
19 production = "176.9.151.154";
20 integration = "176.9.151.155";
21 };
22 };
4d4f13f4
IB
23 };
24
25 imports = [
3013caf1 26 ./modules/certificates.nix
10889174
IB
27 ./modules/gitolite
28 ./modules/databases
e229e6f2 29 ./modules/mpd
54307da4 30 ./modules/websites
af421a8f 31 ./modules/mail
439049e5 32 ./modules/ftp
4d4f13f4
IB
33 ];
34 services.myGitolite.enable = true;
4d4f13f4 35 services.myDatabases.enable = true;
42429ef0
IB
36 services.myWebsites.production.enable = true;
37 services.myWebsites.integration.enable = true;
10889174 38 services.myWebsites.tools.enable = true;
439049e5 39 services.pure-ftpd.enable = true;
4d4f13f4 40
46228a29
IB
41 services.journald.extraConfig = ''
42 MaxLevelStore="warning"
43 MaxRetentionSec="1year"
44 '';
a1bb33c4
IB
45 networking = {
46 firewall = {
47 enable = true;
10889174 48 allowedTCPPorts = [ 22 ];
a1bb33c4
IB
49 };
50 };
51
52 deployment = {
53 targetEnv = "hetzner";
54 hetzner = {
9d90e7e2
IB
55 robotUser = myconfig.env.hetzner.user;
56 robotPass = myconfig.env.hetzner.pass;
f8bde3d6 57 mainIPv4 = myconfig.ips.main;
a1bb33c4
IB
58 partitions = ''
59 clearpart --all --initlabel --drives=sda,sdb
60
61 part swap1 --recommended --label=swap1 --fstype=swap --ondisk=sda
62 part swap2 --recommended --label=swap2 --fstype=swap --ondisk=sdb
63
64 part raid.1 --grow --ondisk=sda
65 part raid.2 --grow --ondisk=sdb
66
67 raid / --level=1 --device=md0 --fstype=ext4 --label=root raid.1 raid.2
68 '';
69 };
70 };
71
10889174 72 environment.systemPackages = [
ce6ee3b8 73 pkgs.telnet
beeed847 74 pkgs.htop
ce6ee3b8
IB
75 pkgs.vim
76 ];
77
5566d26d
IB
78 services.openssh.extraConfig = ''
79 AuthorizedKeysCommand /etc/ssh/ldap_authorized_keys
80 AuthorizedKeysCommandUser nobody
81 '';
82
5566d26d
IB
83 environment.etc."ssh/ldap_authorized_keys" = let
84 ldap_authorized_keys =
5c101474 85 wrap {
5566d26d
IB
86 name = "ldap_authorized_keys";
87 file = ./ldap_authorized_keys.sh;
88 vars = {
9d90e7e2 89 LDAP_PASS = myconfig.env.sshd.ldap.password;
5566d26d
IB
90 GITOLITE_SHELL = "${pkgs.gitolite}/bin/gitolite-shell";
91 ECHO = "${pkgs.coreutils}/bin/echo";
92 };
93 paths = [ pkgs.openldap pkgs.stdenv.shellPackage pkgs.gnugrep pkgs.gnused pkgs.coreutils ];
94 };
95 in {
96 enable = true;
97 mode = "0755";
98 user = "root";
99 source = ldap_authorized_keys;
65fe7543
IB
100 };
101
6533428a
IB
102 services.cron = {
103 enable = true;
104 systemCronJobs = [
105 ''
106 # The star after /var/lib/* avoids deleting all folders in case of problem
9d8d1425 107 0 3,9,15,21 * * * root rsync -e "ssh -i /root/.ssh/id_charon_vpn" -aAXvz --delete --numeric-ids --super --rsync-path="sudo rsync" /var/lib/* immae@immae.eu: > /dev/null
6533428a
IB
108 ''
109 ];
110 };
3de01f9b
IB
111
112 # This value determines the NixOS release with which your system is
113 # to be compatible, in order to avoid breaking some software such as
114 # database servers. You should change this only after NixOS release
115 # notes say you should.
116 system.stateVersion = "18.09"; # Did you read the comment?
a1bb33c4
IB
117 };
118}