]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - nixops/eldiron.nix
Add bitlbee server
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
CommitLineData
9690acd9 1{ privateFiles ? ./. }:
a1bb33c4
IB
2{
3 network = {
4 description = "Immae's network";
5 enableRollback = true;
6 };
7
f8bde3d6 8 eldiron = { config, pkgs, mylibs, myconfig, ... }:
4d4f13f4 9 with mylibs;
ab5d04b8 10 {
4d4f13f4 11 _module.args = {
596e62a6 12 mylibs = import ../libs.nix { nixpkgs = pkgs; };
7636abc6 13 mypkgs = import ../default.nix;
f8bde3d6 14 myconfig = {
9690acd9
IB
15 inherit privateFiles;
16 env = import "${privateFiles}/environment.nix";
f8bde3d6
IB
17 ips = {
18 main = "176.9.151.89";
19 production = "176.9.151.154";
20 integration = "176.9.151.155";
21 };
22 };
4d4f13f4
IB
23 };
24
25 imports = [
3013caf1 26 ./modules/certificates.nix
10889174
IB
27 ./modules/gitolite
28 ./modules/databases
e229e6f2 29 ./modules/mpd
54307da4 30 ./modules/websites
af421a8f 31 ./modules/mail
439049e5 32 ./modules/ftp
5ccc61bb 33 ./modules/pub
22149d17 34 ./modules/task
31a38b9f 35 ./modules/irc
4d4f13f4
IB
36 ];
37 services.myGitolite.enable = true;
4d4f13f4 38 services.myDatabases.enable = true;
42429ef0
IB
39 services.myWebsites.production.enable = true;
40 services.myWebsites.integration.enable = true;
10889174 41 services.myWebsites.tools.enable = true;
439049e5 42 services.pure-ftpd.enable = true;
31a38b9f 43 services.irc.enable = true;
5ccc61bb 44 services.pub.enable = true;
22149d17 45 services.myTasks.enable = true;
4d4f13f4 46
46228a29
IB
47 services.journald.extraConfig = ''
48 MaxLevelStore="warning"
49 MaxRetentionSec="1year"
50 '';
a1bb33c4
IB
51 networking = {
52 firewall = {
53 enable = true;
10889174 54 allowedTCPPorts = [ 22 ];
a1bb33c4
IB
55 };
56 };
57
58 deployment = {
59 targetEnv = "hetzner";
60 hetzner = {
9d90e7e2
IB
61 robotUser = myconfig.env.hetzner.user;
62 robotPass = myconfig.env.hetzner.pass;
f8bde3d6 63 mainIPv4 = myconfig.ips.main;
a1bb33c4
IB
64 partitions = ''
65 clearpart --all --initlabel --drives=sda,sdb
66
67 part swap1 --recommended --label=swap1 --fstype=swap --ondisk=sda
68 part swap2 --recommended --label=swap2 --fstype=swap --ondisk=sdb
69
70 part raid.1 --grow --ondisk=sda
71 part raid.2 --grow --ondisk=sdb
72
73 raid / --level=1 --device=md0 --fstype=ext4 --label=root raid.1 raid.2
74 '';
75 };
76 };
77
10889174 78 environment.systemPackages = [
ce6ee3b8 79 pkgs.telnet
beeed847 80 pkgs.htop
ce6ee3b8
IB
81 pkgs.vim
82 ];
83
5566d26d
IB
84 services.openssh.extraConfig = ''
85 AuthorizedKeysCommand /etc/ssh/ldap_authorized_keys
86 AuthorizedKeysCommandUser nobody
87 '';
88
5566d26d
IB
89 environment.etc."ssh/ldap_authorized_keys" = let
90 ldap_authorized_keys =
5c101474 91 wrap {
5566d26d
IB
92 name = "ldap_authorized_keys";
93 file = ./ldap_authorized_keys.sh;
94 vars = {
9d90e7e2 95 LDAP_PASS = myconfig.env.sshd.ldap.password;
5566d26d
IB
96 GITOLITE_SHELL = "${pkgs.gitolite}/bin/gitolite-shell";
97 ECHO = "${pkgs.coreutils}/bin/echo";
98 };
99 paths = [ pkgs.openldap pkgs.stdenv.shellPackage pkgs.gnugrep pkgs.gnused pkgs.coreutils ];
100 };
101 in {
102 enable = true;
103 mode = "0755";
104 user = "root";
105 source = ldap_authorized_keys;
65fe7543
IB
106 };
107
6533428a
IB
108 services.cron = {
109 enable = true;
110 systemCronJobs = [
111 ''
112 # The star after /var/lib/* avoids deleting all folders in case of problem
9d8d1425 113 0 3,9,15,21 * * * root rsync -e "ssh -i /root/.ssh/id_charon_vpn" -aAXvz --delete --numeric-ids --super --rsync-path="sudo rsync" /var/lib/* immae@immae.eu: > /dev/null
6533428a
IB
114 ''
115 ];
116 };
3de01f9b
IB
117
118 # This value determines the NixOS release with which your system is
119 # to be compatible, in order to avoid breaking some software such as
120 # database servers. You should change this only after NixOS release
121 # notes say you should.
122 system.stateVersion = "18.09"; # Did you read the comment?
a1bb33c4
IB
123 };
124}