]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/chloe/integration.nix
Refactor websites options
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / integration.nix
CommitLineData
f8026b6e
IB
1{ lib, pkgs, config, myconfig, ... }:
2let
3 chloe = pkgs.callPackage ./builder.nix {
4 inherit (pkgs.webapps) chloe;
5 config = myconfig.env.websites.chloe.integration;
6 apacheUser = config.services.httpd.Inte.user;
7 apacheGroup = config.services.httpd.Inte.group;
8 };
9
10 cfg = config.myServices.websites.chloe.integration;
11in {
12 options.myServices.websites.chloe.integration.enable = lib.mkEnableOption "enable Chloe's website in integration";
13
14 config = lib.mkIf cfg.enable {
15 secrets.keys = chloe.keys;
f40f5b23
IB
16 systemd.services.phpfpm-chloe_dev.after = lib.mkAfter chloe.phpFpm.serviceDeps;
17 systemd.services.phpfpm-chloe_dev.wants = chloe.phpFpm.serviceDeps;
18 services.phpfpm.pools.chloe_dev = {
19 listen = chloe.phpFpm.socket;
20 extraConfig = chloe.phpFpm.pool;
21 phpOptions = config.services.phpfpm.phpOptions + ''
22 extension=${pkgs.php}/lib/php/extensions/mysqli.so
f8026b6e 23 '';
f40f5b23 24 };
f8026b6e 25 system.activationScripts.chloe_dev = chloe.activationScript;
4288c2f2 26 myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
29f8cb85
IB
27 services.websites.env.integration.modules = chloe.apache.modules;
28 services.websites.env.integration.vhostConfs.chloe = {
f8026b6e
IB
29 certName = "eldiron";
30 addToCerts = true;
31 hosts = ["chloe.immae.eu" ];
32 root = chloe.apache.root;
33 extraConfig = [ chloe.apache.vhostConf ];
34 };
29f8cb85 35 services.websites.env.integration.watchPaths = [
17f6eae9
IB
36 "/var/secrets/webapps/${chloe.app.environment}-chloe"
37 ];
f8026b6e
IB
38 };
39}