]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/monitoring/default.nix
Remove mail from syrwenne
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
CommitLineData
e820134d 1{ config, pkgs, lib, name, nodes, ... }:
3bc32d9e 2let
e820134d 3 cfg = config.myServices.monitoring;
71a2425e
IB
4 send_mails = pkgs.runCommand "send_mails" {
5 buildInputs = [ pkgs.makeWrapper ];
6 } ''
7 mkdir -p $out/bin
8 cp ${./send_mails} $out/bin/send_mails
9 patchShebangs $out
10 wrapProgram $out/bin/send_mails --prefix PATH : ${lib.makeBinPath [
11 pkgs.mailutils
12 ]}
13 '';
9f16e659
IB
14 postgresqlBinary = if config.myServices.databasesReplication.postgresql.enable
15 then config.myServices.databasesReplication.postgresql.mainPackage
16 else if config.myServices.databases.enable
17 then config.myServices.databases.postgresql.package
18 else pkgs.postgresql;
3bc32d9e
IB
19 myplugins = pkgs.runCommand "buildplugins" {
20 buildInputs = [ pkgs.makeWrapper pkgs.perl ];
21 } ''
22 mkdir $out
23 cp ${./plugins}/* $out/
24 patchShebangs $out
25 wrapProgram $out/check_command --prefix PATH : ${config.security.wrapperDir}
26 wrapProgram $out/send_nrdp.sh --prefix PATH : ${lib.makeBinPath [
b11f0e17 27 pkgs.curl pkgs.jq
3bc32d9e
IB
28 ]}
29 wrapProgram $out/check_mem.sh --prefix PATH : ${lib.makeBinPath [
30 pkgs.gnugrep pkgs.gawk pkgs.procps-ng
31 ]}
9f202523 32 wrapProgram $out/check_postgres_replication --prefix PATH : ${lib.makeBinPath [
9f16e659 33 postgresqlBinary
9f202523 34 ]}
6015a3b5
IB
35 wrapProgram $out/check_redis_replication --prefix PATH : ${lib.makeBinPath [
36 pkgs.gnugrep pkgs.coreutils pkgs.redis
37 ]}
38 wrapProgram $out/check_mysql_replication --prefix PATH : ${lib.makeBinPath [
39 pkgs.gnugrep pkgs.gnused pkgs.coreutils pkgs.mariadb
40 ]}
16b80abd
IB
41 wrapProgram $out/check_openldap_replication --prefix PATH : ${lib.makeBinPath [
42 pkgs.gnugrep pkgs.gnused pkgs.coreutils pkgs.openldap
43 ]}
71a2425e
IB
44 wrapProgram $out/check_emails --prefix PATH : ${lib.makeBinPath [
45 pkgs.openssh send_mails
46 ]} --prefix PERL5LIB : ${pkgs.perlPackages.makePerlPath [
47 pkgs.perlPackages.TimeDate
48 ]}
e820134d
IB
49 wrapProgram $out/check_ftp_database --prefix PATH : ${lib.makeBinPath [
50 pkgs.lftp
51 ]}
52 wrapProgram $out/check_git --prefix PATH : ${lib.makeBinPath [
53 pkgs.git pkgs.openssh
54 ]}
55 wrapProgram $out/check_imap_connection --prefix PATH : ${lib.makeBinPath [
56 pkgs.openssl
57 ]}
25844101
IB
58 wrapProgram $out/check_eriomem --prefix PATH : ${lib.makeBinPath [
59 pkgs.s3cmd pkgs.python3
60 ]}
171d8e1a
IB
61 wrapProgram $out/check_eriomem_age --prefix PATH : ${lib.makeBinPath [
62 pkgs.duplicity
63 ]} --set SECRETS_PATH ${lib.optionalString cfg.master config.secrets.fullPaths."eriomem_access_key"}
e820134d
IB
64 wrapProgram $out/notify_by_email --prefix PATH : ${lib.makeBinPath [
65 pkgs.mailutils
66 ]}
67 wrapProgram $out/notify_by_slack --prefix PATH : ${lib.makeBinPath [
68 pkgs.curl pkgs.jq
69 ]}
6191bdeb
IB
70 wrapProgram $out/check_ovh_sms --prefix PATH : ${lib.makeBinPath [
71 (pkgs.python3.withPackages (ps: [ps.ovh]))
72 ]}
2d7caffb
IB
73 wrapProgram $out/check_bandwidth --prefix PATH : ${lib.makeBinPath [
74 pkgs.iproute pkgs.bc
75 ]}
3bc32d9e 76 '';
eb071dd4
IB
77 toObjects = pkgs.callPackage ./to_objects.nix {};
78 commonConfig = {
79 eldiron = {
80 processWarn = "250"; processAlert = "400";
81 loadWarn = "8.0"; loadAlert = "10.0";
2d7caffb 82 interface = "eth0";
eb071dd4
IB
83 };
84 backup-2 = {
25844101 85 processWarn = "60"; processAlert = "70";
eb071dd4 86 loadWarn = "1.0"; loadAlert = "2.0";
2d7caffb 87 interface = "ens3";
eb071dd4 88 };
e820134d
IB
89 monitoring-1 = {
90 processWarn = "50"; processAlert = "60";
91 loadWarn = "1.0"; loadAlert = "2.0";
2d7caffb 92 interface = "ens3";
e820134d 93 };
eb071dd4 94 };
46a61a1b
IB
95 externalObjects = lib.genAttrs [ "tiboqorl-fr" ]
96 (n: pkgs.callPackage (./. + "/objects_" + n + ".nix") { inherit emailCheck; });
e820134d 97 masterPassiveObjects = let
e820134d
IB
98 passiveNodes = lib.attrsets.filterAttrs (n: _: builtins.elem n ["backup-2" "eldiron"]) nodes;
99 toPassiveServices = map (s: s.passiveInfo.filter s // s.passiveInfo);
100 passiveServices = lib.flatten (lib.attrsets.mapAttrsToList
101 (_: n: toPassiveServices n.config.myServices.monitoring.services)
102 passiveNodes
46a61a1b
IB
103 ) ++ lib.flatten (lib.attrsets.mapAttrsToList
104 (_: n: toPassiveServices n.service)
105 externalObjects);
e820134d 106 in {
71a2425e 107 service = passiveServices;
e820134d
IB
108 host = lib.lists.foldr
109 (a: b: a//b)
110 {}
46a61a1b
IB
111 (lib.attrsets.mapAttrsToList (_: h: h.config.myServices.monitoring.hosts) passiveNodes
112 ++ lib.attrsets.mapAttrsToList (_: n: n.host) externalObjects);
e820134d 113 };
71a2425e
IB
114 emailCheck = host: hostFQDN: let
115 allCfg = config.myEnv.monitoring.email_check;
116 cfg = allCfg."${host}";
117 reverseTargets = builtins.attrNames (lib.attrsets.filterAttrs (k: v: builtins.elem host v.targets) allCfg);
118 to_email = cfg': host':
119 let sep = if lib.strings.hasInfix "+" cfg'.mail_address then "_" else "+";
120 in "${cfg'.mail_address}${sep}${host'}@${cfg'.mail_domain}";
121 mails_to_send = builtins.concatStringsSep "," (map (n: to_email allCfg."${n}" host) cfg.targets);
122 mails_to_receive = builtins.concatStringsSep "," (map (n: "${to_email cfg n}:${n}") reverseTargets);
123 command = if cfg.local
124 then
125 [ "check_emails_local" "/var/lib/naemon/checks/email" mails_to_send mails_to_receive ]
126 else
127 [ "check_emails" cfg.login cfg.port mails_to_send mails_to_receive ];
128 in
129 {
130 service_description = "${hostFQDN} email service is active";
131 use = "mail-service";
132 host_name = hostFQDN;
133 servicegroups = "webstatus-email";
134 check_command = command;
135 };
136 otherObjects = map
137 (n: (pkgs.callPackage (./. + "/objects_" + n + ".nix") { inherit emailCheck; }))
46a61a1b 138 [ "caldance-1" "ulminfo-fr" "phare" ];
e820134d 139 masterObjects = pkgs.callPackage ./objects_master.nix { inherit config; };
eb071dd4 140 commonObjects = pkgs.callPackage ./objects_common.nix ({
e820134d 141 master = cfg.master;
619e4f46 142 hostFQDN = config.hostEnv.fqdn;
e820134d 143 hostName = name;
eb071dd4
IB
144 sudo = "/run/wrappers/bin/sudo";
145 } // builtins.getAttr name commonConfig);
146 hostObjects =
147 let
148 specific_file = ./. + "/objects_" + name + ".nix";
9f202523 149 in
e820134d
IB
150 lib.attrsets.optionalAttrs
151 (builtins.pathExists specific_file)
152 (pkgs.callPackage specific_file {
171d8e1a 153 inherit config nodes emailCheck;
619e4f46 154 hostFQDN = config.hostEnv.fqdn;
e820134d
IB
155 hostName = name;
156 });
46a61a1b
IB
157 objectsFiles = lib.mapAttrs' (name: value: lib.nameValuePair
158 "=/${name}/objects.conf" { alias = pkgs.writeText "objects.conf" (toObjects value); }
159 ) externalObjects;
3bc32d9e
IB
160in
161{
162 options = {
9f202523
IB
163 myServices.monitoring = {
164 enable = lib.mkOption {
165 type = lib.types.bool;
166 default = false;
167 description = ''
168 Whether to enable monitoring.
169 '';
170 };
e820134d
IB
171 master = lib.mkOption {
172 type = lib.types.bool;
173 default = false;
174 description = ''
175 This instance is the master instance
176 '';
177 };
178 hosts = lib.mkOption {
179 readOnly = true;
180 description = "Hosts list for this host";
181 default = (commonObjects.host or {}) // (hostObjects.host or {});
182 };
183 services = lib.mkOption {
184 readOnly = true;
185 description = "Services list for this host";
186 default = commonObjects.service ++ hostObjects.service;
187 };
3bc32d9e
IB
188 };
189 };
190
e820134d 191 config = lib.mkIf cfg.enable {
46a61a1b
IB
192 services.nginx = lib.mkIf config.myServices.status.enable {
193 virtualHosts."status.immae.eu".locations = objectsFiles;
194 };
195
d2e703c5 196 services.duplyBackup.profiles.monitoring = {
6a8252b1
IB
197 rootDir = config.services.naemon.varDir;
198 };
3bc32d9e
IB
199 security.sudo.extraRules = [
200 {
201 commands = [
202 { command = "${pkgs.mdadm}/bin/mdadm --monitor --scan -1"; options = [ "NOPASSWD" ]; }
203 { command = "${pkgs.postfix}/bin/mailq"; options = [ "NOPASSWD" ]; }
204 ];
205 users = [ "naemon" ];
206 runAs = "root";
207 }
9f202523
IB
208 {
209 commands = [
9f202523
IB
210 { command = "${myplugins}/check_last_file_date /backup2/*"; options = [ "NOPASSWD" ]; }
211 ];
212 users = [ "naemon" ];
16b80abd
IB
213 runAs = "ALL";
214 }
215 {
216 commands = [
217 { command = "${myplugins}/check_postgres_replication *"; options = [ "NOPASSWD" ]; }
218 ];
219 users = [ "naemon" ];
9f202523
IB
220 runAs = "postgres";
221 }
222 {
223 commands = [
6015a3b5 224 { command = "${myplugins}/check_mysql_replication *"; options = [ "NOPASSWD" ]; }
9f6a7862
IB
225 ];
226 users = [ "naemon" ];
227 runAs = "mysql";
228 }
6015a3b5
IB
229 {
230 commands = [
16b80abd 231 { command = "${myplugins}/check_openldap_replication *"; options = [ "NOPASSWD" ]; }
6015a3b5
IB
232 ];
233 users = [ "naemon" ];
16b80abd 234 runAs = "openldap";
6015a3b5 235 }
9f6a7862
IB
236 {
237 commands = [
16b80abd 238 { command = "${myplugins}/check_redis_replication *"; options = [ "NOPASSWD" ]; }
9f202523
IB
239 ];
240 users = [ "naemon" ];
16b80abd 241 runAs = "redis";
9f202523 242 }
3bc32d9e
IB
243 ];
244 environment.etc."mdadm.conf" = {
245 enable = true;
246 mode = "0644";
247 user = "root";
ab8f306d 248 text = "MAILADDR ${config.myEnv.monitoring.email}";
3bc32d9e
IB
249 };
250
e820134d
IB
251 secrets.keys = [
252 {
253 dest = "naemon/id_rsa";
254 user = "naemon";
255 group = "naemon";
171d8e1a 256 permissions = "0400";
e820134d
IB
257 text = config.myEnv.monitoring.ssh_secret_key;
258 }
171d8e1a
IB
259 ] ++ lib.optional cfg.master (
260 {
261 dest = "eriomem_access_key";
262 user = "naemon";
263 group = "naemon";
264 permissions = "0400";
265 text = ''
266 export AWS_ACCESS_KEY_ID="${config.myEnv.backup.accessKeyId}"
267 export AWS_SECRET_ACCESS_KEY="${config.myEnv.backup.secretAccessKey}"
268 export BASE_URL="${config.myEnv.backup.remote}"
269 '';
270 }
271 );
3bc32d9e
IB
272 # needed since extraResource is not in the closure
273 systemd.services.naemon.path = [ myplugins ];
274 services.naemon = {
275 enable = true;
276 extraConfig = ''
3bc32d9e
IB
277 use_syslog=1
278 log_initial_states=1
279 date_format=iso8601
ab8f306d 280 admin_email=${config.myEnv.monitoring.email}
e820134d 281 '' + lib.optionalString (!cfg.master) ''
3bc32d9e
IB
282 obsess_over_services=1
283 ocsp_command=notify-master
a97118c4
IB
284 '' + lib.optionalString (cfg.master) ''
285 broker_module=${pkgs.naemon-livestatus}/lib/naemon-livestatus/livestatus.so ${config.services.naemon.runDir}/live
286 broker_module=${pkgs.status_engine.module}/lib/status-engine/naemon/statusengine-${pkgs.naemon.status_engine_version}.o use_service_perfdata=1 use_process_data=0 use_system_command_data=0 use_external_command_data=0 use_flapping_data=0 use_program_status_data=0 use_notification_data=0 use_contact_status_data=0 use_contact_notification_data=0 use_event_handler_data=0 use_object_data=0
3bc32d9e
IB
287 '';
288 extraResource = ''
289 $USER2$=${myplugins}
ab8f306d
IB
290 $USER200$=${config.myEnv.monitoring.status_url}
291 $USER201$=${config.myEnv.monitoring.status_token}
e820134d
IB
292 $USER202$=${config.myEnv.monitoring.http_user_password}
293 $USER203$=${config.secrets.fullPaths."naemon/id_rsa"}
294 $USER204$=${config.myEnv.monitoring.imap_login}
295 $USER205$=${config.myEnv.monitoring.imap_password}
296 $USER206$=${config.myEnv.monitoring.slack_channel}
297 $USER207$=${config.myEnv.monitoring.slack_url}
25844101 298 $USER208$=${builtins.concatStringsSep "," (map (builtins.concatStringsSep ":") config.myEnv.monitoring.eriomem_keys)}
6191bdeb
IB
299 $USER209$=${builtins.concatStringsSep "," [
300 config.myEnv.monitoring.ovh_sms.endpoint
301 config.myEnv.monitoring.ovh_sms.application_key
302 config.myEnv.monitoring.ovh_sms.application_secret
303 config.myEnv.monitoring.ovh_sms.consumer_key
304 config.myEnv.monitoring.ovh_sms.account
305 ]}
3bc32d9e 306 '';
e820134d
IB
307 objectDefs = toObjects commonObjects
308 + toObjects hostObjects
309 + lib.optionalString cfg.master (toObjects masterObjects)
71a2425e
IB
310 + lib.optionalString cfg.master (toObjects masterPassiveObjects)
311 + lib.optionalString cfg.master (builtins.concatStringsSep "\n" (map toObjects otherObjects));
3bc32d9e
IB
312 };
313 };
314}