]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/monitoring/default.nix
Add CSP reports
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
CommitLineData
e820134d 1{ config, pkgs, lib, name, nodes, ... }:
3bc32d9e 2let
e820134d 3 cfg = config.myServices.monitoring;
71a2425e
IB
4 send_mails = pkgs.runCommand "send_mails" {
5 buildInputs = [ pkgs.makeWrapper ];
6 } ''
7 mkdir -p $out/bin
8 cp ${./send_mails} $out/bin/send_mails
9 patchShebangs $out
10 wrapProgram $out/bin/send_mails --prefix PATH : ${lib.makeBinPath [
11 pkgs.mailutils
12 ]}
13 '';
9f16e659
IB
14 postgresqlBinary = if config.myServices.databasesReplication.postgresql.enable
15 then config.myServices.databasesReplication.postgresql.mainPackage
16 else if config.myServices.databases.enable
17 then config.myServices.databases.postgresql.package
18 else pkgs.postgresql;
3bc32d9e
IB
19 myplugins = pkgs.runCommand "buildplugins" {
20 buildInputs = [ pkgs.makeWrapper pkgs.perl ];
21 } ''
22 mkdir $out
23 cp ${./plugins}/* $out/
24 patchShebangs $out
25 wrapProgram $out/check_command --prefix PATH : ${config.security.wrapperDir}
26 wrapProgram $out/send_nrdp.sh --prefix PATH : ${lib.makeBinPath [
b11f0e17 27 pkgs.curl pkgs.jq
3bc32d9e
IB
28 ]}
29 wrapProgram $out/check_mem.sh --prefix PATH : ${lib.makeBinPath [
30 pkgs.gnugrep pkgs.gawk pkgs.procps-ng
31 ]}
9f202523 32 wrapProgram $out/check_postgres_replication --prefix PATH : ${lib.makeBinPath [
9f16e659 33 postgresqlBinary
9f202523 34 ]}
6015a3b5
IB
35 wrapProgram $out/check_redis_replication --prefix PATH : ${lib.makeBinPath [
36 pkgs.gnugrep pkgs.coreutils pkgs.redis
37 ]}
38 wrapProgram $out/check_mysql_replication --prefix PATH : ${lib.makeBinPath [
39 pkgs.gnugrep pkgs.gnused pkgs.coreutils pkgs.mariadb
40 ]}
16b80abd
IB
41 wrapProgram $out/check_openldap_replication --prefix PATH : ${lib.makeBinPath [
42 pkgs.gnugrep pkgs.gnused pkgs.coreutils pkgs.openldap
43 ]}
71a2425e
IB
44 wrapProgram $out/check_emails --prefix PATH : ${lib.makeBinPath [
45 pkgs.openssh send_mails
46 ]} --prefix PERL5LIB : ${pkgs.perlPackages.makePerlPath [
47 pkgs.perlPackages.TimeDate
48 ]}
e820134d
IB
49 wrapProgram $out/check_ftp_database --prefix PATH : ${lib.makeBinPath [
50 pkgs.lftp
51 ]}
52 wrapProgram $out/check_git --prefix PATH : ${lib.makeBinPath [
53 pkgs.git pkgs.openssh
54 ]}
55 wrapProgram $out/check_imap_connection --prefix PATH : ${lib.makeBinPath [
56 pkgs.openssl
57 ]}
25844101
IB
58 wrapProgram $out/check_eriomem --prefix PATH : ${lib.makeBinPath [
59 pkgs.s3cmd pkgs.python3
60 ]}
171d8e1a
IB
61 wrapProgram $out/check_eriomem_age --prefix PATH : ${lib.makeBinPath [
62 pkgs.duplicity
63 ]} --set SECRETS_PATH ${lib.optionalString cfg.master config.secrets.fullPaths."eriomem_access_key"}
e820134d
IB
64 wrapProgram $out/notify_by_email --prefix PATH : ${lib.makeBinPath [
65 pkgs.mailutils
66 ]}
67 wrapProgram $out/notify_by_slack --prefix PATH : ${lib.makeBinPath [
68 pkgs.curl pkgs.jq
69 ]}
6191bdeb
IB
70 wrapProgram $out/check_ovh_sms --prefix PATH : ${lib.makeBinPath [
71 (pkgs.python3.withPackages (ps: [ps.ovh]))
72 ]}
2d7caffb
IB
73 wrapProgram $out/check_bandwidth --prefix PATH : ${lib.makeBinPath [
74 pkgs.iproute pkgs.bc
75 ]}
3bc32d9e 76 '';
eb071dd4
IB
77 toObjects = pkgs.callPackage ./to_objects.nix {};
78 commonConfig = {
79 eldiron = {
80 processWarn = "250"; processAlert = "400";
81 loadWarn = "8.0"; loadAlert = "10.0";
2d7caffb 82 interface = "eth0";
eb071dd4
IB
83 };
84 backup-2 = {
25844101 85 processWarn = "60"; processAlert = "70";
eb071dd4 86 loadWarn = "1.0"; loadAlert = "2.0";
2d7caffb 87 interface = "ens3";
eb071dd4 88 };
e820134d
IB
89 monitoring-1 = {
90 processWarn = "50"; processAlert = "60";
91 loadWarn = "1.0"; loadAlert = "2.0";
2d7caffb 92 interface = "ens3";
e820134d 93 };
eb071dd4 94 };
e820134d 95 masterPassiveObjects = let
e820134d
IB
96 passiveNodes = lib.attrsets.filterAttrs (n: _: builtins.elem n ["backup-2" "eldiron"]) nodes;
97 toPassiveServices = map (s: s.passiveInfo.filter s // s.passiveInfo);
98 passiveServices = lib.flatten (lib.attrsets.mapAttrsToList
99 (_: n: toPassiveServices n.config.myServices.monitoring.services)
100 passiveNodes
101 );
102 in {
71a2425e 103 service = passiveServices;
e820134d
IB
104 host = lib.lists.foldr
105 (a: b: a//b)
106 {}
71a2425e 107 (lib.attrsets.mapAttrsToList (_: h: h.config.myServices.monitoring.hosts) passiveNodes);
e820134d 108 };
71a2425e
IB
109 emailCheck = host: hostFQDN: let
110 allCfg = config.myEnv.monitoring.email_check;
111 cfg = allCfg."${host}";
112 reverseTargets = builtins.attrNames (lib.attrsets.filterAttrs (k: v: builtins.elem host v.targets) allCfg);
113 to_email = cfg': host':
114 let sep = if lib.strings.hasInfix "+" cfg'.mail_address then "_" else "+";
115 in "${cfg'.mail_address}${sep}${host'}@${cfg'.mail_domain}";
116 mails_to_send = builtins.concatStringsSep "," (map (n: to_email allCfg."${n}" host) cfg.targets);
117 mails_to_receive = builtins.concatStringsSep "," (map (n: "${to_email cfg n}:${n}") reverseTargets);
118 command = if cfg.local
119 then
120 [ "check_emails_local" "/var/lib/naemon/checks/email" mails_to_send mails_to_receive ]
121 else
122 [ "check_emails" cfg.login cfg.port mails_to_send mails_to_receive ];
123 in
124 {
125 service_description = "${hostFQDN} email service is active";
126 use = "mail-service";
127 host_name = hostFQDN;
128 servicegroups = "webstatus-email";
129 check_command = command;
130 };
131 otherObjects = map
132 (n: (pkgs.callPackage (./. + "/objects_" + n + ".nix") { inherit emailCheck; }))
a1a4a72e 133 [ "caldance-1" "ulminfo-fr" "phare" "tiboqorl-fr" ];
e820134d 134 masterObjects = pkgs.callPackage ./objects_master.nix { inherit config; };
eb071dd4 135 commonObjects = pkgs.callPackage ./objects_common.nix ({
e820134d 136 master = cfg.master;
619e4f46 137 hostFQDN = config.hostEnv.fqdn;
e820134d 138 hostName = name;
eb071dd4
IB
139 sudo = "/run/wrappers/bin/sudo";
140 } // builtins.getAttr name commonConfig);
141 hostObjects =
142 let
143 specific_file = ./. + "/objects_" + name + ".nix";
9f202523 144 in
e820134d
IB
145 lib.attrsets.optionalAttrs
146 (builtins.pathExists specific_file)
147 (pkgs.callPackage specific_file {
171d8e1a 148 inherit config nodes emailCheck;
619e4f46 149 hostFQDN = config.hostEnv.fqdn;
e820134d
IB
150 hostName = name;
151 });
3bc32d9e
IB
152in
153{
154 options = {
9f202523
IB
155 myServices.monitoring = {
156 enable = lib.mkOption {
157 type = lib.types.bool;
158 default = false;
159 description = ''
160 Whether to enable monitoring.
161 '';
162 };
e820134d
IB
163 master = lib.mkOption {
164 type = lib.types.bool;
165 default = false;
166 description = ''
167 This instance is the master instance
168 '';
169 };
170 hosts = lib.mkOption {
171 readOnly = true;
172 description = "Hosts list for this host";
173 default = (commonObjects.host or {}) // (hostObjects.host or {});
174 };
175 services = lib.mkOption {
176 readOnly = true;
177 description = "Services list for this host";
178 default = commonObjects.service ++ hostObjects.service;
179 };
3bc32d9e
IB
180 };
181 };
182
e820134d 183 config = lib.mkIf cfg.enable {
d2e703c5 184 services.duplyBackup.profiles.monitoring = {
6a8252b1
IB
185 rootDir = config.services.naemon.varDir;
186 };
3bc32d9e
IB
187 security.sudo.extraRules = [
188 {
189 commands = [
190 { command = "${pkgs.mdadm}/bin/mdadm --monitor --scan -1"; options = [ "NOPASSWD" ]; }
191 { command = "${pkgs.postfix}/bin/mailq"; options = [ "NOPASSWD" ]; }
192 ];
193 users = [ "naemon" ];
194 runAs = "root";
195 }
9f202523
IB
196 {
197 commands = [
9f202523
IB
198 { command = "${myplugins}/check_last_file_date /backup2/*"; options = [ "NOPASSWD" ]; }
199 ];
200 users = [ "naemon" ];
16b80abd
IB
201 runAs = "ALL";
202 }
203 {
204 commands = [
205 { command = "${myplugins}/check_postgres_replication *"; options = [ "NOPASSWD" ]; }
206 ];
207 users = [ "naemon" ];
9f202523
IB
208 runAs = "postgres";
209 }
210 {
211 commands = [
6015a3b5 212 { command = "${myplugins}/check_mysql_replication *"; options = [ "NOPASSWD" ]; }
9f6a7862
IB
213 ];
214 users = [ "naemon" ];
215 runAs = "mysql";
216 }
6015a3b5
IB
217 {
218 commands = [
16b80abd 219 { command = "${myplugins}/check_openldap_replication *"; options = [ "NOPASSWD" ]; }
6015a3b5
IB
220 ];
221 users = [ "naemon" ];
16b80abd 222 runAs = "openldap";
6015a3b5 223 }
9f6a7862
IB
224 {
225 commands = [
16b80abd 226 { command = "${myplugins}/check_redis_replication *"; options = [ "NOPASSWD" ]; }
9f202523
IB
227 ];
228 users = [ "naemon" ];
16b80abd 229 runAs = "redis";
9f202523 230 }
3bc32d9e
IB
231 ];
232 environment.etc."mdadm.conf" = {
233 enable = true;
234 mode = "0644";
235 user = "root";
ab8f306d 236 text = "MAILADDR ${config.myEnv.monitoring.email}";
3bc32d9e
IB
237 };
238
e820134d
IB
239 secrets.keys = [
240 {
241 dest = "naemon/id_rsa";
242 user = "naemon";
243 group = "naemon";
171d8e1a 244 permissions = "0400";
e820134d
IB
245 text = config.myEnv.monitoring.ssh_secret_key;
246 }
171d8e1a
IB
247 ] ++ lib.optional cfg.master (
248 {
249 dest = "eriomem_access_key";
250 user = "naemon";
251 group = "naemon";
252 permissions = "0400";
253 text = ''
254 export AWS_ACCESS_KEY_ID="${config.myEnv.backup.accessKeyId}"
255 export AWS_SECRET_ACCESS_KEY="${config.myEnv.backup.secretAccessKey}"
256 export BASE_URL="${config.myEnv.backup.remote}"
257 '';
258 }
259 );
3bc32d9e
IB
260 # needed since extraResource is not in the closure
261 systemd.services.naemon.path = [ myplugins ];
262 services.naemon = {
263 enable = true;
264 extraConfig = ''
3bc32d9e
IB
265 use_syslog=1
266 log_initial_states=1
267 date_format=iso8601
ab8f306d 268 admin_email=${config.myEnv.monitoring.email}
e820134d 269 '' + lib.optionalString (!cfg.master) ''
3bc32d9e
IB
270 obsess_over_services=1
271 ocsp_command=notify-master
a97118c4
IB
272 '' + lib.optionalString (cfg.master) ''
273 broker_module=${pkgs.naemon-livestatus}/lib/naemon-livestatus/livestatus.so ${config.services.naemon.runDir}/live
274 broker_module=${pkgs.status_engine.module}/lib/status-engine/naemon/statusengine-${pkgs.naemon.status_engine_version}.o use_service_perfdata=1 use_process_data=0 use_system_command_data=0 use_external_command_data=0 use_flapping_data=0 use_program_status_data=0 use_notification_data=0 use_contact_status_data=0 use_contact_notification_data=0 use_event_handler_data=0 use_object_data=0
3bc32d9e
IB
275 '';
276 extraResource = ''
277 $USER2$=${myplugins}
ab8f306d
IB
278 $USER200$=${config.myEnv.monitoring.status_url}
279 $USER201$=${config.myEnv.monitoring.status_token}
e820134d
IB
280 $USER202$=${config.myEnv.monitoring.http_user_password}
281 $USER203$=${config.secrets.fullPaths."naemon/id_rsa"}
282 $USER204$=${config.myEnv.monitoring.imap_login}
283 $USER205$=${config.myEnv.monitoring.imap_password}
284 $USER206$=${config.myEnv.monitoring.slack_channel}
285 $USER207$=${config.myEnv.monitoring.slack_url}
25844101 286 $USER208$=${builtins.concatStringsSep "," (map (builtins.concatStringsSep ":") config.myEnv.monitoring.eriomem_keys)}
6191bdeb
IB
287 $USER209$=${builtins.concatStringsSep "," [
288 config.myEnv.monitoring.ovh_sms.endpoint
289 config.myEnv.monitoring.ovh_sms.application_key
290 config.myEnv.monitoring.ovh_sms.application_secret
291 config.myEnv.monitoring.ovh_sms.consumer_key
292 config.myEnv.monitoring.ovh_sms.account
293 ]}
3bc32d9e 294 '';
e820134d
IB
295 objectDefs = toObjects commonObjects
296 + toObjects hostObjects
297 + lib.optionalString cfg.master (toObjects masterObjects)
71a2425e
IB
298 + lib.optionalString cfg.master (toObjects masterPassiveObjects)
299 + lib.optionalString cfg.master (builtins.concatStringsSep "\n" (map toObjects otherObjects));
3bc32d9e
IB
300 };
301 };
302}