]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/environment.nix
Add cip-ca mail website
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
CommitLineData
619e4f46 1{ config, lib, name, ... }:
ab8f306d
IB
2with lib;
3with types;
4with lists;
5let
6 ldapOptions = {
7 base = mkOption { description = "Base of the LDAP tree"; type = str; };
8 host = mkOption { description = "Host to access LDAP"; type = str; };
9 root_dn = mkOption { description = "DN of the root user"; type = str; };
10 root_pw = mkOption { description = "Hashed password of the root user"; type = str; };
11 replication_dn = mkOption { description = "DN of the user allowed to replicate the LDAP directory"; type = str; };
12 replication_pw = mkOption { description = "Password of the user allowed to replicate the LDAP directory"; type = str; };
13 };
14 mkLdapOptions = name: more: mkOption {
15 description = "${name} LDAP configuration";
16 type = submodule {
17 options = ldapOptions // {
18 dn = mkOption { description = "DN of the ${name} user"; type = str; };
19 password = mkOption { description = "password of the ${name} user"; type = str; };
20 filter = mkOption { description = "Filter for ${name} users"; type = str; default = ""; };
21 } // more;
22 };
23 };
24 mysqlOptions = {
25 host = mkOption { description = "Host to access Mysql"; type = str; };
619e4f46 26 remoteHost = mkOption { description = "Host to access Mysql from outside"; type = str; };
ab8f306d
IB
27 port = mkOption { description = "Port to access Mysql"; type = str; };
28 socket = mkOption { description = "Socket to access Mysql"; type = path; };
29 systemUsers = mkOption {
30 description = "Attrs of user-passwords allowed to access mysql";
31 type = attrsOf str;
32 };
33 pam = mkOption {
34 description = "PAM configuration for mysql";
35 type = submodule {
36 options = {
37 dn = mkOption { description = "DN to connect as to check users"; type = str; };
38 password = mkOption { description = "DN password to connect as to check users"; type = str; };
39 filter = mkOption { description = "filter to match users"; type = str; };
40 };
41 };
42 };
43 };
87a8bffd 44 mkMysqlOptions = name: more: mkOption {
ab8f306d
IB
45 description = "${name} mysql configuration";
46 type = submodule {
47 options = mysqlOptions // {
48 database = mkOption { description = "${name} database"; type = str; };
49 user = mkOption { description = "${name} user"; type = str; };
50 password = mkOption { description = "mysql password of the ${name} user"; type = str; };
87a8bffd 51 } // more;
ab8f306d
IB
52 };
53 };
54 psqlOptions = {
55 host = mkOption { description = "Host to access Postgresql"; type = str; };
56 port = mkOption { description = "Port to access Postgresql"; type = str; };
57 socket = mkOption { description = "Socket to access Postgresql"; type = path; };
58 pam = mkOption {
59 description = "PAM configuration for psql";
60 type = submodule {
61 options = {
62 dn = mkOption { description = "DN to connect as to check users"; type = str; };
63 password = mkOption { description = "DN password to connect as to check users"; type = str; };
64 filter = mkOption { description = "filter to match users"; type = str; };
65 };
66 };
67 };
68 };
69 mkPsqlOptions = name: mkOption {
70 description = "${name} psql configuration";
71 type = submodule {
72 options = psqlOptions // {
73 database = mkOption { description = "${name} database"; type = str; };
74 schema = mkOption { description = "${name} schema"; type = nullOr str; default = null; };
75 user = mkOption { description = "${name} user"; type = str; };
76 password = mkOption { description = "psql password of the ${name} user"; type = str; };
77 };
78 };
79 };
80 redisOptions = {
81 host = mkOption { description = "Host to access Redis"; type = str; };
82 port = mkOption { description = "Port to access Redis"; type = str; };
83 socket = mkOption { description = "Socket to access Redis"; type = path; };
84 dbs = mkOption {
85 description = "Attrs of db number. Each number should be unique to avoid collision!";
86 type = attrsOf str;
87 };
88 spiped_key = mkOption {
89 type = str;
90 description = ''
91 Key to use with spiped to make a secure channel to replication
92 '';
93 };
94 predixy = mkOption {
95 description = "Predixy configuration. Unused yet";
96 type = submodule {
97 options = {
98 read = mkOption { type = str; description = "Read password"; };
99 };
100 };
101 };
102 };
103 mkRedisOptions = name: mkOption {
104 description = "${name} redis configuration";
105 type = submodule {
106 options = redisOptions // {
107 db = mkOption { description = "${name} database"; type = str; };
108 };
109 };
110 };
619e4f46
IB
111 hostEnv = submodule {
112 options = {
113 fqdn = mkOption {
114 description = "Host FQDN";
115 type = str;
116 };
8a304ef4
IB
117 users = mkOption {
118 type = unspecified;
119 default = pkgs: [];
120 description = ''
121 Sublist of users from realUsers. Function that takes pkgs as
122 argument and gives an array as a result
123 '';
124 };
619e4f46
IB
125 emails = mkOption {
126 default = [];
127 description = "List of e-mails that the server can be a sender of";
128 type = listOf str;
129 };
130 ldap = mkOption {
131 description = ''
132 LDAP credentials for the host
133 '';
134 type = submodule {
135 options = {
5400b9b6
IB
136 password = mkOption { type = str; description = "Password for the LDAP connection"; };
137 dn = mkOption { type = str; description = "DN for the LDAP connection"; };
619e4f46
IB
138 };
139 };
140 };
141 mx = mkOption {
142 description = "subdomain and priority for MX server";
143 default = { enable = false; };
144 type = submodule {
145 options = {
146 enable = mkEnableOption "Enable MX";
147 subdomain = mkOption { type = nullOr str; description = "Subdomain name (mx-*)"; };
148 priority = mkOption { type = nullOr str; description = "Priority"; };
149 };
150 };
151 };
152 ips = mkOption {
153 description = ''
154 attrs of ip4/ip6 grouped by section
155 '';
156 type = attrsOf (submodule {
157 options = {
158 ip4 = mkOption {
5400b9b6 159 type = str;
619e4f46
IB
160 description = ''
161 ip4 address of the host
162 '';
163 };
164 ip6 = mkOption {
5400b9b6 165 type = listOf str;
619e4f46
IB
166 default = [];
167 description = ''
168 ip6 addresses of the host
169 '';
170 };
171 };
172 });
173 };
174 };
175 };
ab8f306d
IB
176in
177{
178 options.myEnv = {
179 servers = mkOption {
180 description = ''
181 Attrs of servers information in the cluster (not necessarily handled by nixops)
182 '';
183 default = {};
619e4f46 184 type = attrsOf hostEnv;
ab8f306d
IB
185 };
186 hetznerCloud = mkOption {
187 description = ''
188 Hetzner Cloud credential information
189 '';
190 type = submodule {
191 options = {
192 authToken = mkOption {
193 type = str;
194 description = ''
195 The API auth token.
196 '';
197 };
198 };
199 };
200 };
201 hetzner = mkOption {
202 description = ''
203 Hetzner credential information
204 '';
205 type = submodule {
206 options = {
207 user = mkOption { type = str; description = "User"; };
208 pass = mkOption { type = str; description = "Password"; };
209 };
210 };
211 };
212 sshd = mkOption {
213 description = ''
214 sshd service credential information
215 '';
216 type = submodule {
217 options = {
218 ldap = mkOption {
219 description = ''
220 LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
221 '';
222 type = submodule {
223 options = {
224 password = mkOption { description = "Password"; type = str; };
225 };
226 };
227 };
228 };
229 };
230 };
231 ports = mkOption {
232 description = ''
233 non-standard reserved ports. Must be unique!
234 '';
235 type = attrsOf port;
236 default = {};
237 apply = let
238 noDupl = x: builtins.length (builtins.attrValues x) == builtins.length (unique (builtins.attrValues x));
239 in
240 x: if isAttrs x && noDupl x then x else throw "Non unique values for ports";
241 };
242 httpd = mkOption {
243 description = ''
244 httpd service credential information
245 '';
246 type = submodule {
247 options = {
248 ldap = mkOption {
249 description = ''
250 LDAP credentials for cn=httpd,ou=services,dc=immae,dc=eu dn
251 '';
252 type = submodule {
253 options = {
254 password = mkOption { description = "Password"; type = str; };
255 };
256 };
257 };
258 };
259 };
260 };
261 ldap = mkOption {
262 description = ''
263 LDAP server configuration
264 '';
265 type = submodule {
266 options = ldapOptions;
267 };
268 };
269 databases = mkOption {
270 description = "Databases configuration";
271 type = submodule {
272 options = {
273 mysql = mkOption {
274 type = submodule { options = mysqlOptions; };
275 description = "Mysql configuration";
276 };
277 redis = mkOption {
278 type = submodule { options = redisOptions; };
279 description = "Redis configuration";
280 };
281 postgresql = mkOption {
282 type = submodule { options = psqlOptions; };
283 description = "Postgresql configuration";
284 };
285 };
286 };
287 };
288 jabber = mkOption {
289 description = "Jabber configuration";
290 type = submodule {
291 options = {
5b53d86f 292 postfix_user_filter = mkOption { type = str; description = "Postfix filter to get xmpp users"; };
ab8f306d
IB
293 ldap = mkLdapOptions "Jabber" {};
294 postgresql = mkPsqlOptions "Jabber";
295 };
296 };
297 };
8a304ef4
IB
298 realUsers = mkOption {
299 description = ''
300 Attrset of function taking pkgs as argument.
301 Real users settings, should provide a subattr of users.users.<name>
302 with at least: name, (hashed)Password, shell
303 '';
304 type = attrsOf unspecified;
305 };
ab8f306d
IB
306 users = mkOption {
307 description = "System and regular users uid/gid";
308 type = attrsOf (submodule {
309 options = {
310 uid = mkOption {
311 description = "user uid";
312 type = int;
313 };
314 gid = mkOption {
315 description = "user gid";
316 type = int;
317 };
318 };
319 });
320 };
321 dns = mkOption {
322 description = "DNS configuration";
323 type = submodule {
324 options = {
325 soa = mkOption {
326 description = "SOA information";
327 type = submodule {
328 options = {
329 serial = mkOption {
330 description = "Serial number. Should be incremented at each change and unique";
331 type = str;
332 };
333 refresh = mkOption {
334 description = "Refresh time";
335 type = str;
336 };
337 retry = mkOption {
338 description = "Retry time";
339 type = str;
340 };
341 expire = mkOption {
342 description = "Expire time";
343 type = str;
344 };
345 ttl = mkOption {
346 description = "Default TTL time";
347 type = str;
348 };
349 email = mkOption {
350 description = "hostmaster e-mail";
351 type = str;
352 };
353 primary = mkOption {
354 description = "Primary NS";
355 type = str;
356 };
357 };
358 };
359 };
360 ns = mkOption {
361 description = "Attrs of NS servers group";
362 example = {
363 foo = {
364 "ns1.foo.com" = [ "198.51.100.10" "2001:db8:abcd::1" ];
365 "ns2.foo.com" = [ "198.51.100.15" "2001:db8:1234::1" ];
366 };
367 };
368 type = attrsOf (attrsOf (listOf str));
369 };
370 slaveZones = mkOption {
371 description = "List of slave zones";
372 type = listOf (submodule {
373 options = {
374 name = mkOption { type = str; description = "zone name"; };
375 masters = mkOption {
376 description = "NS master groups of this zone";
377 type = listOf str;
378 };
379 };
380 });
381 };
382 masterZones = mkOption {
383 description = "List of master zones";
384 type = listOf (submodule {
385 options = {
386 name = mkOption { type = str; description = "zone name"; };
387 slaves = mkOption {
388 description = "NS slave groups of this zone";
389 type = listOf str;
390 };
391 ns = mkOption {
392 description = "groups names that should have their NS entries listed here";
393 type = listOf str;
394 };
395 extra = mkOption {
396 description = "Extra zone configuration for bind";
397 example = ''
398 notify yes;
399 '';
400 type = lines;
401 };
402 entries = mkOption { type = lines; description = "Regular entries of the NS zone"; };
403 withEmail = mkOption {
404 description = "List of domains that should have mail entries (MX, dkim, SPF, ...)";
405 default = [];
406 type = listOf (submodule {
407 options = {
408 domain = mkOption { type = str; description = "Which subdomain is concerned"; };
409 send = mkOption { type = bool; description = "Whether there can be e-mails originating from the subdomain"; };
410 receive = mkOption { type = bool; description = "Whether there can be e-mails arriving to the subdomain"; };
411 };
412 });
413 };
414 };
415 });
416 };
417 };
418 };
419 };
420 backup = mkOption {
421 description = ''
422 Remote backup with duplicity
423 '';
424 type = submodule {
425 options = {
426 password = mkOption { type = str; description = "Password for encrypting files"; };
427 remote = mkOption { type = str; description = "Remote url access"; };
428 accessKeyId = mkOption { type = str; description = "Remote access-key"; };
429 secretAccessKey = mkOption { type = str; description = "Remote access secret"; };
430 };
431 };
432 };
433 rsync_backup = mkOption {
434 description =''
435 Rsync backup configuration from controlled host
436 '';
437 type = submodule {
438 options = {
ab8f306d
IB
439 ssh_key = mkOption {
440 description = "SSH key information";
441 type = submodule {
442 options = {
443 public = mkOption { type = str; description = "Public part of the key"; };
444 private = mkOption { type = lines; description = "Private part of the key"; };
445 };
446 };
447 };
448 profiles = mkOption {
449 description = "Attrs of profiles to backup";
450 type = attrsOf (submodule {
451 options = {
452 keep = mkOption { type = int; description = "Number of backups to keep"; };
46b7e627 453 check_command = mkOption { type = str; description = "command to check if backup needs to be done"; default = "backup"; };
ab8f306d
IB
454 login = mkOption { type = str; description = "Login to connect to host"; };
455 port = mkOption { type = str; default = "22"; description = "Port to connect to host"; };
456 host = mkOption { type = str; description = "Host to connect to"; };
457 host_key = mkOption { type = str; description = "Host key"; };
458 host_key_type = mkOption { type = str; description = "Host key type"; };
459 parts = mkOption {
460 description = "Parts to backup for this host";
461 type = attrsOf (submodule {
462 options = {
463 remote_folder = mkOption { type = path; description = "Remote folder to backup";};
464 exclude_from = mkOption {
465 type = listOf path;
466 default = [];
467 description = "List of folders/files to exclude from the backup";
468 };
469 files_from = mkOption {
470 type = listOf path;
471 default = [];
472 description = "List of folders/files to backup in the base folder";
473 };
474 args = mkOption {
475 type = nullOr str;
476 default = null;
477 description = "Extra arguments to pass to rsync";
478 };
479 };
480 });
481 };
482 };
483 });
484 };
485 };
486 };
487 };
488 monitoring = mkOption {
489 description = "Monitoring configuration";
490 type = submodule {
491 options = {
492 status_url = mkOption { type = str; description = "URL to push status to"; };
493 status_token = mkOption { type = str; description = "Token for the status url"; };
e820134d 494 http_user_password = mkOption { type = str; description = "HTTP credentials to check services behind wall"; };
ab8f306d 495 email = mkOption { type = str; description = "Admin E-mail"; };
e820134d
IB
496 ssh_public_key = mkOption { type = str; description = "SSH public key"; };
497 ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
498 imap_login = mkOption { type = str; description = "IMAP login"; };
499 imap_password = mkOption { type = str; description = "IMAP password"; };
25844101 500 eriomem_keys = mkOption { type = listOf (listOf str); description = "Eriomem keys"; default = []; };
6191bdeb
IB
501 ovh_sms = mkOption {
502 description = "OVH credentials for sms script";
503 type = submodule {
504 options = {
505 endpoint = mkOption { type = str; default = "ovh-eu"; description = "OVH endpoint"; };
506 application_key = mkOption { type = str; description = "Application key"; };
507 application_secret = mkOption { type = str; description = "Application secret"; };
508 consumer_key = mkOption { type = str; description = "Consumer key"; };
509 account = mkOption { type = str; description = "Account"; };
510 };
511 };
512 };
e820134d
IB
513 nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
514 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
515 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
516 contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
71a2425e
IB
517 email_check = mkOption {
518 description = "Emails services to check";
519 type = attrsOf (submodule {
520 options = {
521 local = mkOption { type = bool; default = false; description = "Use local configuration"; };
522 port = mkOption { type = nullOr str; default = null; description = "Port to connect to ssh"; };
523 login = mkOption { type = nullOr str; default = null; description = "Login to connect to ssh"; };
524 targets = mkOption { type = listOf str; description = "Hosts to send E-mails to"; };
ef0a9217
IB
525 mail_address = mkOption { type = nullOr str; default = null; description = "E-mail recipient part to send e-mail to"; };
526 mail_domain = mkOption { type = nullOr str; default = null; description = "E-mail domain part to send e-mail to"; };
71a2425e
IB
527 };
528 });
529 };
ab8f306d
IB
530 };
531 };
532 };
533 mpd = mkOption {
534 description = "MPD configuration";
535 type = submodule {
536 options = {
537 folder = mkOption { type = str; description = "Folder to serve from the MPD instance"; };
538 password = mkOption { type = str; description = "Password to connect to the MPD instance"; };
539 host = mkOption { type = str; description = "Host to connect to the MPD instance"; };
540 port = mkOption { type = str; description = "Port to connect to the MPD instance"; };
541 };
542 };
543 };
544 ftp = mkOption {
545 description = "FTP configuration";
546 type = submodule {
547 options = {
548 ldap = mkLdapOptions "FTP" {};
549 };
550 };
551 };
ea9c6fe8
IB
552 vpn = mkOption {
553 description = "VPN configuration";
554 type = attrsOf (submodule {
555 options = {
556 prefix = mkOption { type = str; description = "ipv6 prefix for the vpn subnet"; };
557 privateKey = mkOption { type = str; description = "Private key for the host"; };
558 publicKey = mkOption { type = str; description = "Public key for the host"; };
559 };
560 });
561 };
ab8f306d
IB
562 mail = mkOption {
563 description = "Mail configuration";
564 type = submodule {
565 options = {
566 dmarc = mkOption {
567 description = "DMARC configuration";
568 type = submodule {
569 options = {
570 ignore_hosts = mkOption {
571 type = lines;
572 description = ''
573 Hosts to ignore when checking for dmarc
574 '';
575 };
576 };
577 };
578 };
579 dkim = mkOption {
580 description = "DKIM configuration";
581 type = attrsOf (submodule {
582 options = {
583 public = mkOption {
584 type = str;
585 example = ''
586 ( "v=DKIM1; k=rsa; "
587 "p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC3w1a2aMxWw9+hdcmbqX4UevcVqr204y0K73Wdc7MPZiOOlUJQYsMNSYR1Y/SC7jmPKeitpcJCpQgn/cveJZbuikjjPLsDReHyFEYmC278ZLRTELHx6f1IXM8WE08JIRT69CfZiMi1rVcOh9qRT4F93PyjCauU8Y5hJjtg9ThsWwIDAQAB" )
588 '';
589 description = "Public entry to put in DNS TXT field";
590 };
591 private = mkOption { type = str; description = "Private key"; };
592 };
593 });
594 };
595 postfix = mkOption {
596 description = "Postfix configuration";
597 type = submodule {
598 options = {
599 additional_mailbox_domains = mkOption {
600 description = ''
601 List of domains that are used as mailbox final destination, in addition to those defined in the DNS records
602 '';
603 type = listOf str;
604 };
87a8bffd
IB
605 mysql = mkMysqlOptions "Postfix" {
606 password_encrypt = mkOption { type = str; description = "Key to encrypt relay password in database"; };
607 };
ab8f306d
IB
608 backup_domains = mkOption {
609 description = ''
610 Domains that are accepted for relay as backup domain
611 '';
612 type = attrsOf (submodule {
613 options = {
614 domains = mkOption { type = listOf str; description = "Domains list"; };
615 relay_restrictions = mkOption {
616 type = lines;
617 description = ''
618 Restrictions for relaying the e-mails from the domains
619 '';
620 };
621 recipient_maps = mkOption {
622 description = ''
623 Recipient map to accept relay for.
624 Must be specified for domain, the rules apply to everyone!
625 '';
626 type = listOf (submodule {
627 options = {
628 type = mkOption {
629 type = enum [ "hash" ];
630 description = "Map type";
631 };
632 content = mkOption {
633 type = str;
634 description = "Map content";
635 };
636 };
637 });
638 };
639 };
640 });
641 };
642 };
643 };
644 };
645 dovecot = mkOption {
646 description = "Dovecot configuration";
647 type = submodule {
648 options = {
649 ldap = mkLdapOptions "Dovecot" {
650 pass_attrs = mkOption { type = str; description = "Password attribute in LDAP"; };
651 user_attrs = mkOption { type = str; description = "User attribute mapping in LDAP"; };
652 iterate_attrs = mkOption { type = str; description = "User attribute mapping for listing in LDAP"; };
653 iterate_filter = mkOption { type = str; description = "User attribute filter for listing in LDAP"; };
22b4bd78 654 postfix_mailbox_filter = mkOption { type = str; description = "Postfix filter to get mailboxes"; };
ab8f306d
IB
655 };
656 };
657 };
658 };
659 rspamd = mkOption {
660 description = "rspamd configuration";
661 type = submodule {
662 options = {
663 redis = mkRedisOptions "Redis";
664 read_password_hashed = mkOption { type = str; description = "Hashed read password for rspamd"; };
665 write_password_hashed = mkOption { type = str; description = "Hashed write password for rspamd"; };
666 read_password = mkOption {
667 type = str;
668 description = "Read password for rspamd. Unused";
669 apply = x: "";
670 };
671 write_password = mkOption {
672 type = str;
673 description = "Write password for rspamd. Unused";
674 apply = x: "";
675 };
676 };
677 };
678 };
679 scripts = mkOption {
680 description = "Mail script recipients";
681 type = attrsOf (submodule {
682 options = {
5b53d86f 683 external = mkEnableOption "Create a script_<name>@mail.immae.eu external address";
ab8f306d
IB
684 src = mkOption {
685 description = ''
686 git source to fetch the script from.
687 It must have a default.nix file as its root accepting a scriptEnv parameter
688 '';
689 type = submodule {
690 options = {
691 url = mkOption { type = str; description = "git url to fetch"; };
692 rev = mkOption { type = str; description = "git reference to fetch"; };
693 };
694 };
695 };
696 env = mkOption {
697 description = "Variables to pass to the script";
698 type = unspecified;
699 };
700 };
701 });
702 };
418a4ed7
IB
703 sympa = mkOption {
704 description = "Sympa configuration";
705 type = submodule {
706 options = {
707 listmasters = mkOption {
708 type = listOf str;
709 description = "Listmasters";
710 };
711 postgresql = mkPsqlOptions "Sympa";
712 data_sources = mkOption {
713 type = attrsOf str;
714 default = {};
715 description = "Data sources to make available to sympa";
716 };
717 scenari = mkOption {
718 type = attrsOf str;
719 default = {};
720 description = "Scenari to make available to sympa";
721 };
722 };
723 };
724 };
ab8f306d
IB
725 };
726 };
727 };
728 buildbot = mkOption {
729 description = "Buildbot configuration";
730 type = submodule {
731 options = {
732 user = mkOption {
733 description = "Buildbot user";
734 type = submodule {
735 options = {
736 uid = mkOption {
737 description = "user uid";
738 type = int;
739 };
740 gid = mkOption {
741 description = "user gid";
742 type = int;
743 };
744 };
745 };
746 };
747 ldap = mkOption {
748 description = "Ldap configuration for buildbot";
749 type = submodule {
750 options = {
751 password = mkOption { type = str; description = "Buildbot password"; };
752 };
753 };
754 };
755 projects = mkOption {
756 description = "Projects to make a buildbot for";
757 type = attrsOf (submodule {
758 options = {
759 name = mkOption { type = str; description = "Project name"; };
760 packages = mkOption {
761 type = unspecified;
762 example = literalExample ''
763 pkgs: [ pkgs.bash pkgs.git pkgs.gzip pkgs.openssh ];
764 '';
765 description = ''
766 Function.
767 Builds packages list to make available to buildbot project.
768 Takes pkgs as argument.
769 '';
770 };
771 pythonPackages = mkOption {
772 type = unspecified;
773 example = literalExample ''
774 p: pkgs: [ pkgs.python3Packages.pip ];
775 '';
776 description = ''
777 Function.
778 Builds python packages list to make available to buildbot project.
779 Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
780 '';
781 };
782 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
783 secrets = mkOption {
784 type = attrsOf str;
785 description = "Secrets for the project to dump as files";
786 };
787 environment = mkOption {
788 type = attrsOf str;
789 description = ''
790 Environment variables for the project.
791 BUILDBOT_ is prefixed to the variable names
792 '';
793 };
794 activationScript = mkOption {
795 type = lines;
796 description = ''
797 Activation script to run during deployment
798 '';
799 };
800 builderPaths = mkOption {
801 type = attrsOf unspecified;
802 default = {};
803 description = ''
804 Attrs of functions to make accessible specifically per builder.
805 Takes pkgs as argument and should return a single path containing binaries.
806 This path will be accessible as BUILDBOT_PATH_<attrskey>
807 '';
808 };
809 webhookTokens = mkOption {
810 type = nullOr (listOf str);
811 default = null;
812 description = ''
813 List of tokens allowed to push to project’s change_hook/base endpoint
814 '';
815 };
816 };
817 });
818 };
819 };
820 };
821 };
822 tools = mkOption {
823 description = "Tools configurations";
824 type = submodule {
825 options = {
251c0a13 826 contact = mkOption { type = str; description = "Contact e-mail address"; };
ab8f306d
IB
827 davical = mkOption {
828 description = "Davical configuration";
829 type = submodule {
830 options = {
831 postgresql = mkPsqlOptions "Davical";
832 ldap = mkLdapOptions "Davical" {};
833 };
834 };
835 };
836 diaspora = mkOption {
837 description = "Diaspora configuration";
838 type = submodule {
839 options = {
840 postgresql = mkPsqlOptions "Diaspora";
841 redis = mkRedisOptions "Diaspora";
842 ldap = mkLdapOptions "Diaspora" {};
843 secret_token = mkOption { type = str; description = "Secret token"; };
844 };
845 };
846 };
7df5e532
IB
847 dmarc_reports = mkOption {
848 description = "DMARC reports configuration";
849 type = submodule {
850 options = {
851 mysql = mkMysqlOptions "DMARC" {};
9c08c3bc 852 anonymous_key = mkOption { type = str; description = "Anonymous hashing key"; };
7df5e532
IB
853 };
854 };
855 };
ab8f306d
IB
856 etherpad-lite = mkOption {
857 description = "Etherpad configuration";
858 type = submodule {
859 options = {
860 postgresql = mkPsqlOptions "Etherpad";
861 ldap = mkLdapOptions "Etherpad" {
862 group_filter = mkOption { type = str; description = "Filter for groups"; };
863 };
f0d942ac 864 adminPassword = mkOption { type = str; description = "Admin password for mypads / admin"; };
ab8f306d
IB
865 session_key = mkOption { type = str; description = "Session key"; };
866 api_key = mkOption { type = str; description = "API key"; };
867 redirects = mkOption { type = str; description = "Redirects for apache"; };
868 };
869 };
870 };
871 gitolite = mkOption {
872 description = "Gitolite configuration";
873 type = submodule {
874 options = {
875 ldap = mkLdapOptions "Gitolite" {};
876 };
877 };
878 };
879 kanboard = mkOption {
880 description = "Kanboard configuration";
881 type = submodule {
882 options = {
883 postgresql = mkPsqlOptions "Kanboard";
884 ldap = mkLdapOptions "Kanboard" {
885 admin_dn = mkOption { type = str; description = "Admin DN"; };
886 };
887 };
888 };
889 };
890 mantisbt = mkOption {
891 description = "Mantisbt configuration";
892 type = submodule {
893 options = {
894 postgresql = mkPsqlOptions "Mantisbt";
895 ldap = mkLdapOptions "Mantisbt" {};
896 master_salt = mkOption { type = str; description = "Master salt for password hash"; };
897 };
898 };
899 };
900 mastodon = mkOption {
901 description = "Mastodon configuration";
902 type = submodule {
903 options = {
904 postgresql = mkPsqlOptions "Mastodon";
905 redis = mkRedisOptions "Mastodon";
906 ldap = mkLdapOptions "Mastodon" {};
907 paperclip_secret = mkOption { type = str; description = "Paperclip secret"; };
908 otp_secret = mkOption { type = str; description = "OTP secret"; };
909 secret_key_base = mkOption { type = str; description = "Secret key base"; };
910 vapid = mkOption {
911 description = "vapid key";
912 type = submodule {
913 options = {
914 private = mkOption { type = str; description = "Private key"; };
915 public = mkOption { type = str; description = "Public key"; };
916 };
917 };
918 };
919 };
920 };
921 };
922 mediagoblin = mkOption {
923 description = "Mediagoblin configuration";
924 type = submodule {
925 options = {
926 postgresql = mkPsqlOptions "Mediagoblin";
927 redis = mkRedisOptions "Mediagoblin";
928 ldap = mkLdapOptions "Mediagoblin" {};
929 };
930 };
931 };
932 nextcloud = mkOption {
933 description = "Nextcloud configuration";
934 type = submodule {
935 options = {
936 postgresql = mkPsqlOptions "Peertube";
937 redis = mkRedisOptions "Peertube";
938 password_salt = mkOption { type = str; description = "Password salt"; };
939 instance_id = mkOption { type = str; description = "Instance ID"; };
940 secret = mkOption { type = str; description = "App secret"; };
941 };
942 };
943 };
944 peertube = mkOption {
945 description = "Peertube configuration";
946 type = submodule {
947 options = {
948 listenPort = mkOption { type = port; description = "Port to listen to"; };
949 postgresql = mkPsqlOptions "Peertube";
950 redis = mkRedisOptions "Peertube";
951 ldap = mkLdapOptions "Peertube" {};
952 };
953 };
954 };
8a05c7fb
IB
955 syden_peertube = mkOption {
956 description = "Peertube Syden configuration";
957 type = submodule {
958 options = {
959 listenPort = mkOption { type = port; description = "Port to listen to"; };
960 postgresql = mkPsqlOptions "Peertube";
961 redis = mkRedisOptions "Peertube";
962 };
963 };
964 };
ab8f306d
IB
965 phpldapadmin = mkOption {
966 description = "phpLdapAdmin configuration";
967 type = submodule {
968 options = {
969 ldap = mkLdapOptions "phpldapadmin" {};
970 };
971 };
972 };
973 rompr = mkOption {
974 description = "Rompr configuration";
975 type = submodule {
976 options = {
977 mpd = mkOption {
978 description = "MPD configuration";
979 type = submodule {
980 options = {
981 host = mkOption { type = str; description = "Host for MPD"; };
982 port = mkOption { type = port; description = "Port to access MPD host"; };
983 };
984 };
985 };
986 };
987 };
988 };
989 roundcubemail = mkOption {
990 description = "Roundcubemail configuration";
991 type = submodule {
992 options = {
993 postgresql = mkPsqlOptions "TT-RSS";
994 secret = mkOption { type = str; description = "Secret"; };
995 };
996 };
997 };
998 shaarli = mkOption {
999 description = "Shaarli configuration";
1000 type = submodule {
1001 options = {
1002 ldap = mkLdapOptions "Shaarli" {};
1003 };
1004 };
1005 };
1006 task = mkOption {
1007 description = "Taskwarrior configuration";
1008 type = submodule {
1009 options = {
1010 ldap = mkLdapOptions "Taskwarrior" {};
1011 taskwarrior-web = mkOption {
1012 description = "taskwarrior-web profiles";
1013 type = attrsOf (submodule {
1014 options = {
1015 uid = mkOption {
1016 type = listOf str;
1017 description = "List of ldap uids having access to this profile";
1018 };
1019 org = mkOption { type = str; description = "Taskd organisation"; };
1020 key = mkOption { type = str; description = "Taskd key"; };
1021 date = mkOption { type = str; description = "Preferred date format"; };
1022 };
1023 });
1024 };
1025 };
1026 };
1027 };
1028 ttrss = mkOption {
1029 description = "TT-RSS configuration";
1030 type = submodule {
1031 options = {
1032 postgresql = mkPsqlOptions "TT-RSS";
1033 ldap = mkLdapOptions "TT-RSS" {};
1034 };
1035 };
1036 };
1037 wallabag = mkOption {
1038 description = "Wallabag configuration";
1039 type = submodule {
1040 options = {
1041 postgresql = mkPsqlOptions "Wallabag";
1042 ldap = mkLdapOptions "Wallabag" {
1043 admin_filter = mkOption { type = str; description = "Admin users filter"; };
1044 };
1045 redis = mkRedisOptions "Wallabag";
1046 secret = mkOption { type = str; description = "App secret"; };
1047 };
1048 };
1049 };
251c0a13
IB
1050 webhooks = mkOption {
1051 type = attrsOf str;
1052 description = "Mapping 'name'.php => script for webhooks";
1053 };
ab8f306d
IB
1054 ympd = mkOption {
1055 description = "Ympd configuration";
1056 type = submodule {
1057 options = {
1058 listenPort = mkOption { type = port; description = "Port to listen to"; };
1059 mpd = mkOption {
1060 description = "MPD configuration";
1061 type = submodule {
1062 options = {
1063 password = mkOption { type = str; description = "Password to access MPD host"; };
1064 host = mkOption { type = str; description = "Host for MPD"; };
1065 port = mkOption { type = port; description = "Port to access MPD host"; };
1066 };
1067 };
1068 };
1069 };
1070 };
1071 };
1072 yourls = mkOption {
1073 description = "Yourls configuration";
1074 type = submodule {
1075 options = {
87a8bffd 1076 mysql = mkMysqlOptions "Yourls" {};
ab8f306d
IB
1077 ldap = mkLdapOptions "Yourls" {};
1078 cookieKey = mkOption { type = str; description = "Cookie key"; };
1079 };
1080 };
1081 };
1082 };
1083 };
1084 };
1085 websites = mkOption {
1086 description = "Websites configurations";
1087 type = submodule {
1088 options = {
91b3d06b
IB
1089 immae = mkOption {
1090 description = "Immae configuration by environment";
1091 type = submodule {
1092 options = {
1093 temp = mkOption {
1094 description = "Temp configuration";
1095 type = submodule {
1096 options = {
1097 ldap = mkLdapOptions "Immae temp" {
1098 filter = mkOption { type = str; description = "Filter for user access"; };
1099 };
1100 };
1101 };
1102 };
1103 };
1104 };
1105 };
829ef7f1
IB
1106 isabelle = mkOption {
1107 description = "Isabelle configurations by environment";
ab8f306d
IB
1108 type =
1109 let
1110 atenSubmodule = mkOption {
1111 description = "environment configuration";
1112 type = submodule {
1113 options = {
1114 environment = mkOption { type = str; description = "Symfony environment"; };
1115 secret = mkOption { type = str; description = "Symfony App secret"; };
1116 postgresql = mkPsqlOptions "Aten";
1117 };
1118 };
1119 };
1120 in
1121 submodule {
1122 options = {
829ef7f1
IB
1123 aten_production = atenSubmodule;
1124 aten_integration = atenSubmodule;
423c3f1c
IB
1125 iridologie = mkOption {
1126 description = "environment configuration";
1127 type = submodule {
1128 options = {
1129 environment = mkOption { type = str; description = "SPIP environment"; };
1130 mysql = mkMysqlOptions "Iridologie" {};
1131 ldap = mkLdapOptions "Iridologie" {};
1132 };
1133 };
1134 };
ab8f306d
IB
1135 };
1136 };
1137 };
1138 chloe = mkOption {
1139 description = "Chloe configurations by environment";
1140 type =
1141 let
1142 chloeSubmodule = mkOption {
1143 description = "environment configuration";
1144 type = submodule {
1145 options = {
423c3f1c 1146 environment = mkOption { type = str; description = "SPIP environment"; };
87a8bffd 1147 mysql = mkMysqlOptions "Chloe" {};
ab8f306d
IB
1148 ldap = mkLdapOptions "Chloe" {};
1149 };
1150 };
1151 };
1152 in
1153 submodule {
1154 options = {
1155 production = chloeSubmodule;
1156 integration = chloeSubmodule;
1157 };
1158 };
1159 };
1160 connexionswing = mkOption {
1161 description = "Connexionswing configurations by environment";
1162 type =
1163 let
1164 csSubmodule = mkOption {
1165 description = "environment configuration";
1166 type = submodule {
1167 options = {
1168 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1169 mysql = mkMysqlOptions "Connexionswing" {};
ab8f306d
IB
1170 secret = mkOption { type = str; description = "Symfony App secret"; };
1171 email = mkOption { type = str; description = "Symfony email notification"; };
1172 };
1173 };
1174 };
1175 in
1176 submodule {
1177 options = {
1178 production = csSubmodule;
1179 integration = csSubmodule;
1180 };
1181 };
1182 };
1183 jerome = mkOption {
1184 description = "Naturaloutil configuration";
1185 type = submodule {
1186 options = {
87a8bffd 1187 mysql = mkMysqlOptions "Naturaloutil" {};
ab8f306d
IB
1188 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1189 };
1190 };
1191 };
d3452fc5 1192 telio_tortay = mkOption {
ab8f306d
IB
1193 description = "Telio Tortay configuration";
1194 type = submodule {
1195 options = {
1196 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1197 };
1198 };
1199 };
d3452fc5 1200 ludivine = mkOption {
ab8f306d
IB
1201 description = "Ludivinecassal configurations by environment";
1202 type =
1203 let
1204 lcSubmodule = mkOption {
1205 description = "environment configuration";
1206 type = submodule {
1207 options = {
1208 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1209 mysql = mkMysqlOptions "LudivineCassal" {};
ab8f306d
IB
1210 ldap = mkLdapOptions "LudivineCassal" {};
1211 secret = mkOption { type = str; description = "Symfony App secret"; };
1212 };
1213 };
1214 };
1215 in
1216 submodule {
1217 options = {
1218 production = lcSubmodule;
1219 integration = lcSubmodule;
1220 };
1221 };
1222 };
1223 emilia = mkOption {
1224 description = "Emilia configuration";
1225 type = submodule {
1226 options = {
1227 postgresql = mkPsqlOptions "Emilia";
1228 };
1229 };
1230 };
1231 florian = mkOption {
1232 description = "Florian configuration";
1233 type = submodule {
1234 options = {
1235 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1236 };
1237 };
1238 };
1239 nassime = mkOption {
1240 description = "Nassime configuration";
1241 type = submodule {
1242 options = {
1243 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1244 };
1245 };
1246 };
1247 piedsjaloux = mkOption {
1248 description = "Piedsjaloux configurations by environment";
1249 type =
1250 let
1251 pjSubmodule = mkOption {
1252 description = "environment configuration";
1253 type = submodule {
1254 options = {
1255 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1256 mysql = mkMysqlOptions "Piedsjaloux" {};
ab8f306d
IB
1257 secret = mkOption { type = str; description = "Symfony App secret"; };
1258 };
1259 };
1260 };
1261 in
1262 submodule {
1263 options = {
1264 production = pjSubmodule;
1265 integration = pjSubmodule;
1266 };
1267 };
1268 };
91b75ffe
IB
1269 richie = mkOption {
1270 description = "Europe Richie configurations by environment";
1271 type = submodule {
1272 options = {
87a8bffd 1273 mysql = mkMysqlOptions "Richie" {};
91b75ffe
IB
1274 smtp_mailer = mkOption {
1275 description = "SMTP mailer configuration";
1276 type = submodule {
1277 options = {
1278 user = mkOption { type = str; description = "Username"; };
1279 password = mkOption { type = str; description = "Password"; };
1280 };
1281 };
1282 };
1283 };
1284 };
1285 };
ab8f306d
IB
1286 tellesflorian = mkOption {
1287 description = "Tellesflorian configurations by environment";
1288 type =
1289 let
1290 tfSubmodule = mkOption {
1291 description = "environment configuration";
1292 type = submodule {
1293 options = {
1294 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1295 mysql = mkMysqlOptions "Tellesflorian" {};
ab8f306d
IB
1296 secret = mkOption { type = str; description = "Symfony App secret"; };
1297 invite_passwords = mkOption { type = str; description = "Password basic auth"; };
1298 };
1299 };
1300 };
1301 in
1302 submodule {
1303 options = {
1304 integration = tfSubmodule;
1305 };
1306 };
1307 };
1308 };
1309 };
1310 };
1311
1312 privateFiles = mkOption {
1313 type = path;
1314 description = ''
1315 Path to secret files to make available during build
1316 '';
1317 };
1318 };
619e4f46
IB
1319 options.hostEnv = mkOption {
1320 readOnly = true;
1321 type = hostEnv;
1322 default = config.myEnv.servers."${name}";
1323 description = "Host environment";
ab8f306d
IB
1324 };
1325}