]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/environment.nix
Add backup MX
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
CommitLineData
619e4f46 1{ config, lib, name, ... }:
ab8f306d
IB
2with lib;
3with types;
4with lists;
5let
6 ldapOptions = {
7 base = mkOption { description = "Base of the LDAP tree"; type = str; };
8 host = mkOption { description = "Host to access LDAP"; type = str; };
9 root_dn = mkOption { description = "DN of the root user"; type = str; };
10 root_pw = mkOption { description = "Hashed password of the root user"; type = str; };
11 replication_dn = mkOption { description = "DN of the user allowed to replicate the LDAP directory"; type = str; };
12 replication_pw = mkOption { description = "Password of the user allowed to replicate the LDAP directory"; type = str; };
13 };
14 mkLdapOptions = name: more: mkOption {
15 description = "${name} LDAP configuration";
16 type = submodule {
17 options = ldapOptions // {
18 dn = mkOption { description = "DN of the ${name} user"; type = str; };
19 password = mkOption { description = "password of the ${name} user"; type = str; };
20 filter = mkOption { description = "Filter for ${name} users"; type = str; default = ""; };
21 } // more;
22 };
23 };
24 mysqlOptions = {
25 host = mkOption { description = "Host to access Mysql"; type = str; };
619e4f46 26 remoteHost = mkOption { description = "Host to access Mysql from outside"; type = str; };
ab8f306d
IB
27 port = mkOption { description = "Port to access Mysql"; type = str; };
28 socket = mkOption { description = "Socket to access Mysql"; type = path; };
29 systemUsers = mkOption {
30 description = "Attrs of user-passwords allowed to access mysql";
31 type = attrsOf str;
32 };
33 pam = mkOption {
34 description = "PAM configuration for mysql";
35 type = submodule {
36 options = {
37 dn = mkOption { description = "DN to connect as to check users"; type = str; };
38 password = mkOption { description = "DN password to connect as to check users"; type = str; };
39 filter = mkOption { description = "filter to match users"; type = str; };
40 };
41 };
42 };
43 };
87a8bffd 44 mkMysqlOptions = name: more: mkOption {
ab8f306d
IB
45 description = "${name} mysql configuration";
46 type = submodule {
47 options = mysqlOptions // {
48 database = mkOption { description = "${name} database"; type = str; };
49 user = mkOption { description = "${name} user"; type = str; };
50 password = mkOption { description = "mysql password of the ${name} user"; type = str; };
87a8bffd 51 } // more;
ab8f306d
IB
52 };
53 };
54 psqlOptions = {
55 host = mkOption { description = "Host to access Postgresql"; type = str; };
56 port = mkOption { description = "Port to access Postgresql"; type = str; };
57 socket = mkOption { description = "Socket to access Postgresql"; type = path; };
58 pam = mkOption {
59 description = "PAM configuration for psql";
60 type = submodule {
61 options = {
62 dn = mkOption { description = "DN to connect as to check users"; type = str; };
63 password = mkOption { description = "DN password to connect as to check users"; type = str; };
64 filter = mkOption { description = "filter to match users"; type = str; };
65 };
66 };
67 };
68 };
69 mkPsqlOptions = name: mkOption {
70 description = "${name} psql configuration";
71 type = submodule {
72 options = psqlOptions // {
73 database = mkOption { description = "${name} database"; type = str; };
74 schema = mkOption { description = "${name} schema"; type = nullOr str; default = null; };
75 user = mkOption { description = "${name} user"; type = str; };
76 password = mkOption { description = "psql password of the ${name} user"; type = str; };
77 };
78 };
79 };
80 redisOptions = {
81 host = mkOption { description = "Host to access Redis"; type = str; };
82 port = mkOption { description = "Port to access Redis"; type = str; };
83 socket = mkOption { description = "Socket to access Redis"; type = path; };
84 dbs = mkOption {
85 description = "Attrs of db number. Each number should be unique to avoid collision!";
86 type = attrsOf str;
87 };
88 spiped_key = mkOption {
89 type = str;
90 description = ''
91 Key to use with spiped to make a secure channel to replication
92 '';
93 };
94 predixy = mkOption {
95 description = "Predixy configuration. Unused yet";
96 type = submodule {
97 options = {
98 read = mkOption { type = str; description = "Read password"; };
99 };
100 };
101 };
102 };
103 mkRedisOptions = name: mkOption {
104 description = "${name} redis configuration";
105 type = submodule {
106 options = redisOptions // {
107 db = mkOption { description = "${name} database"; type = str; };
108 };
109 };
110 };
619e4f46
IB
111 hostEnv = submodule {
112 options = {
113 fqdn = mkOption {
114 description = "Host FQDN";
115 type = str;
116 };
117 emails = mkOption {
118 default = [];
119 description = "List of e-mails that the server can be a sender of";
120 type = listOf str;
121 };
122 ldap = mkOption {
123 description = ''
124 LDAP credentials for the host
125 '';
126 type = submodule {
127 options = {
128 password = mkOption { type = string; description = "Password for the LDAP connection"; };
129 dn = mkOption { type = string; description = "DN for the LDAP connection"; };
130 };
131 };
132 };
133 mx = mkOption {
134 description = "subdomain and priority for MX server";
135 default = { enable = false; };
136 type = submodule {
137 options = {
138 enable = mkEnableOption "Enable MX";
139 subdomain = mkOption { type = nullOr str; description = "Subdomain name (mx-*)"; };
140 priority = mkOption { type = nullOr str; description = "Priority"; };
141 };
142 };
143 };
144 ips = mkOption {
145 description = ''
146 attrs of ip4/ip6 grouped by section
147 '';
148 type = attrsOf (submodule {
149 options = {
150 ip4 = mkOption {
151 type = string;
152 description = ''
153 ip4 address of the host
154 '';
155 };
156 ip6 = mkOption {
157 type = listOf string;
158 default = [];
159 description = ''
160 ip6 addresses of the host
161 '';
162 };
163 };
164 });
165 };
166 };
167 };
ab8f306d
IB
168in
169{
170 options.myEnv = {
171 servers = mkOption {
172 description = ''
173 Attrs of servers information in the cluster (not necessarily handled by nixops)
174 '';
175 default = {};
619e4f46 176 type = attrsOf hostEnv;
ab8f306d
IB
177 };
178 hetznerCloud = mkOption {
179 description = ''
180 Hetzner Cloud credential information
181 '';
182 type = submodule {
183 options = {
184 authToken = mkOption {
185 type = str;
186 description = ''
187 The API auth token.
188 '';
189 };
190 };
191 };
192 };
193 hetzner = mkOption {
194 description = ''
195 Hetzner credential information
196 '';
197 type = submodule {
198 options = {
199 user = mkOption { type = str; description = "User"; };
200 pass = mkOption { type = str; description = "Password"; };
201 };
202 };
203 };
204 sshd = mkOption {
205 description = ''
206 sshd service credential information
207 '';
208 type = submodule {
209 options = {
210 ldap = mkOption {
211 description = ''
212 LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
213 '';
214 type = submodule {
215 options = {
216 password = mkOption { description = "Password"; type = str; };
217 };
218 };
219 };
220 };
221 };
222 };
223 ports = mkOption {
224 description = ''
225 non-standard reserved ports. Must be unique!
226 '';
227 type = attrsOf port;
228 default = {};
229 apply = let
230 noDupl = x: builtins.length (builtins.attrValues x) == builtins.length (unique (builtins.attrValues x));
231 in
232 x: if isAttrs x && noDupl x then x else throw "Non unique values for ports";
233 };
234 httpd = mkOption {
235 description = ''
236 httpd service credential information
237 '';
238 type = submodule {
239 options = {
240 ldap = mkOption {
241 description = ''
242 LDAP credentials for cn=httpd,ou=services,dc=immae,dc=eu dn
243 '';
244 type = submodule {
245 options = {
246 password = mkOption { description = "Password"; type = str; };
247 };
248 };
249 };
250 };
251 };
252 };
253 ldap = mkOption {
254 description = ''
255 LDAP server configuration
256 '';
257 type = submodule {
258 options = ldapOptions;
259 };
260 };
261 databases = mkOption {
262 description = "Databases configuration";
263 type = submodule {
264 options = {
265 mysql = mkOption {
266 type = submodule { options = mysqlOptions; };
267 description = "Mysql configuration";
268 };
269 redis = mkOption {
270 type = submodule { options = redisOptions; };
271 description = "Redis configuration";
272 };
273 postgresql = mkOption {
274 type = submodule { options = psqlOptions; };
275 description = "Postgresql configuration";
276 };
277 };
278 };
279 };
280 jabber = mkOption {
281 description = "Jabber configuration";
282 type = submodule {
283 options = {
5b53d86f 284 postfix_user_filter = mkOption { type = str; description = "Postfix filter to get xmpp users"; };
ab8f306d
IB
285 ldap = mkLdapOptions "Jabber" {};
286 postgresql = mkPsqlOptions "Jabber";
287 };
288 };
289 };
290 users = mkOption {
291 description = "System and regular users uid/gid";
292 type = attrsOf (submodule {
293 options = {
294 uid = mkOption {
295 description = "user uid";
296 type = int;
297 };
298 gid = mkOption {
299 description = "user gid";
300 type = int;
301 };
302 };
303 });
304 };
305 dns = mkOption {
306 description = "DNS configuration";
307 type = submodule {
308 options = {
309 soa = mkOption {
310 description = "SOA information";
311 type = submodule {
312 options = {
313 serial = mkOption {
314 description = "Serial number. Should be incremented at each change and unique";
315 type = str;
316 };
317 refresh = mkOption {
318 description = "Refresh time";
319 type = str;
320 };
321 retry = mkOption {
322 description = "Retry time";
323 type = str;
324 };
325 expire = mkOption {
326 description = "Expire time";
327 type = str;
328 };
329 ttl = mkOption {
330 description = "Default TTL time";
331 type = str;
332 };
333 email = mkOption {
334 description = "hostmaster e-mail";
335 type = str;
336 };
337 primary = mkOption {
338 description = "Primary NS";
339 type = str;
340 };
341 };
342 };
343 };
344 ns = mkOption {
345 description = "Attrs of NS servers group";
346 example = {
347 foo = {
348 "ns1.foo.com" = [ "198.51.100.10" "2001:db8:abcd::1" ];
349 "ns2.foo.com" = [ "198.51.100.15" "2001:db8:1234::1" ];
350 };
351 };
352 type = attrsOf (attrsOf (listOf str));
353 };
354 slaveZones = mkOption {
355 description = "List of slave zones";
356 type = listOf (submodule {
357 options = {
358 name = mkOption { type = str; description = "zone name"; };
359 masters = mkOption {
360 description = "NS master groups of this zone";
361 type = listOf str;
362 };
363 };
364 });
365 };
366 masterZones = mkOption {
367 description = "List of master zones";
368 type = listOf (submodule {
369 options = {
370 name = mkOption { type = str; description = "zone name"; };
371 slaves = mkOption {
372 description = "NS slave groups of this zone";
373 type = listOf str;
374 };
375 ns = mkOption {
376 description = "groups names that should have their NS entries listed here";
377 type = listOf str;
378 };
379 extra = mkOption {
380 description = "Extra zone configuration for bind";
381 example = ''
382 notify yes;
383 '';
384 type = lines;
385 };
386 entries = mkOption { type = lines; description = "Regular entries of the NS zone"; };
387 withEmail = mkOption {
388 description = "List of domains that should have mail entries (MX, dkim, SPF, ...)";
389 default = [];
390 type = listOf (submodule {
391 options = {
392 domain = mkOption { type = str; description = "Which subdomain is concerned"; };
393 send = mkOption { type = bool; description = "Whether there can be e-mails originating from the subdomain"; };
394 receive = mkOption { type = bool; description = "Whether there can be e-mails arriving to the subdomain"; };
395 };
396 });
397 };
398 };
399 });
400 };
401 };
402 };
403 };
404 backup = mkOption {
405 description = ''
406 Remote backup with duplicity
407 '';
408 type = submodule {
409 options = {
410 password = mkOption { type = str; description = "Password for encrypting files"; };
411 remote = mkOption { type = str; description = "Remote url access"; };
412 accessKeyId = mkOption { type = str; description = "Remote access-key"; };
413 secretAccessKey = mkOption { type = str; description = "Remote access secret"; };
414 };
415 };
416 };
417 rsync_backup = mkOption {
418 description =''
419 Rsync backup configuration from controlled host
420 '';
421 type = submodule {
422 options = {
423 mailto = mkOption { type = str; description = "Where to e-mail on error"; };
424 ssh_key = mkOption {
425 description = "SSH key information";
426 type = submodule {
427 options = {
428 public = mkOption { type = str; description = "Public part of the key"; };
429 private = mkOption { type = lines; description = "Private part of the key"; };
430 };
431 };
432 };
433 profiles = mkOption {
434 description = "Attrs of profiles to backup";
435 type = attrsOf (submodule {
436 options = {
437 keep = mkOption { type = int; description = "Number of backups to keep"; };
438 login = mkOption { type = str; description = "Login to connect to host"; };
439 port = mkOption { type = str; default = "22"; description = "Port to connect to host"; };
440 host = mkOption { type = str; description = "Host to connect to"; };
441 host_key = mkOption { type = str; description = "Host key"; };
442 host_key_type = mkOption { type = str; description = "Host key type"; };
443 parts = mkOption {
444 description = "Parts to backup for this host";
445 type = attrsOf (submodule {
446 options = {
447 remote_folder = mkOption { type = path; description = "Remote folder to backup";};
448 exclude_from = mkOption {
449 type = listOf path;
450 default = [];
451 description = "List of folders/files to exclude from the backup";
452 };
453 files_from = mkOption {
454 type = listOf path;
455 default = [];
456 description = "List of folders/files to backup in the base folder";
457 };
458 args = mkOption {
459 type = nullOr str;
460 default = null;
461 description = "Extra arguments to pass to rsync";
462 };
463 };
464 });
465 };
466 };
467 });
468 };
469 };
470 };
471 };
472 monitoring = mkOption {
473 description = "Monitoring configuration";
474 type = submodule {
475 options = {
476 status_url = mkOption { type = str; description = "URL to push status to"; };
477 status_token = mkOption { type = str; description = "Token for the status url"; };
e820134d 478 http_user_password = mkOption { type = str; description = "HTTP credentials to check services behind wall"; };
ab8f306d 479 email = mkOption { type = str; description = "Admin E-mail"; };
e820134d
IB
480 ssh_public_key = mkOption { type = str; description = "SSH public key"; };
481 ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
482 imap_login = mkOption { type = str; description = "IMAP login"; };
483 imap_password = mkOption { type = str; description = "IMAP password"; };
484 nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
485 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
486 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
487 contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
ab8f306d
IB
488 };
489 };
490 };
491 mpd = mkOption {
492 description = "MPD configuration";
493 type = submodule {
494 options = {
495 folder = mkOption { type = str; description = "Folder to serve from the MPD instance"; };
496 password = mkOption { type = str; description = "Password to connect to the MPD instance"; };
497 host = mkOption { type = str; description = "Host to connect to the MPD instance"; };
498 port = mkOption { type = str; description = "Port to connect to the MPD instance"; };
499 };
500 };
501 };
502 ftp = mkOption {
503 description = "FTP configuration";
504 type = submodule {
505 options = {
506 ldap = mkLdapOptions "FTP" {};
507 };
508 };
509 };
510 mail = mkOption {
511 description = "Mail configuration";
512 type = submodule {
513 options = {
514 dmarc = mkOption {
515 description = "DMARC configuration";
516 type = submodule {
517 options = {
518 ignore_hosts = mkOption {
519 type = lines;
520 description = ''
521 Hosts to ignore when checking for dmarc
522 '';
523 };
524 };
525 };
526 };
527 dkim = mkOption {
528 description = "DKIM configuration";
529 type = attrsOf (submodule {
530 options = {
531 public = mkOption {
532 type = str;
533 example = ''
534 ( "v=DKIM1; k=rsa; "
535 "p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC3w1a2aMxWw9+hdcmbqX4UevcVqr204y0K73Wdc7MPZiOOlUJQYsMNSYR1Y/SC7jmPKeitpcJCpQgn/cveJZbuikjjPLsDReHyFEYmC278ZLRTELHx6f1IXM8WE08JIRT69CfZiMi1rVcOh9qRT4F93PyjCauU8Y5hJjtg9ThsWwIDAQAB" )
536 '';
537 description = "Public entry to put in DNS TXT field";
538 };
539 private = mkOption { type = str; description = "Private key"; };
540 };
541 });
542 };
543 postfix = mkOption {
544 description = "Postfix configuration";
545 type = submodule {
546 options = {
547 additional_mailbox_domains = mkOption {
548 description = ''
549 List of domains that are used as mailbox final destination, in addition to those defined in the DNS records
550 '';
551 type = listOf str;
552 };
87a8bffd
IB
553 mysql = mkMysqlOptions "Postfix" {
554 password_encrypt = mkOption { type = str; description = "Key to encrypt relay password in database"; };
555 };
ab8f306d
IB
556 backup_domains = mkOption {
557 description = ''
558 Domains that are accepted for relay as backup domain
559 '';
560 type = attrsOf (submodule {
561 options = {
562 domains = mkOption { type = listOf str; description = "Domains list"; };
563 relay_restrictions = mkOption {
564 type = lines;
565 description = ''
566 Restrictions for relaying the e-mails from the domains
567 '';
568 };
569 recipient_maps = mkOption {
570 description = ''
571 Recipient map to accept relay for.
572 Must be specified for domain, the rules apply to everyone!
573 '';
574 type = listOf (submodule {
575 options = {
576 type = mkOption {
577 type = enum [ "hash" ];
578 description = "Map type";
579 };
580 content = mkOption {
581 type = str;
582 description = "Map content";
583 };
584 };
585 });
586 };
587 };
588 });
589 };
590 };
591 };
592 };
593 dovecot = mkOption {
594 description = "Dovecot configuration";
595 type = submodule {
596 options = {
597 ldap = mkLdapOptions "Dovecot" {
598 pass_attrs = mkOption { type = str; description = "Password attribute in LDAP"; };
599 user_attrs = mkOption { type = str; description = "User attribute mapping in LDAP"; };
600 iterate_attrs = mkOption { type = str; description = "User attribute mapping for listing in LDAP"; };
601 iterate_filter = mkOption { type = str; description = "User attribute filter for listing in LDAP"; };
602 };
603 };
604 };
605 };
606 rspamd = mkOption {
607 description = "rspamd configuration";
608 type = submodule {
609 options = {
610 redis = mkRedisOptions "Redis";
611 read_password_hashed = mkOption { type = str; description = "Hashed read password for rspamd"; };
612 write_password_hashed = mkOption { type = str; description = "Hashed write password for rspamd"; };
613 read_password = mkOption {
614 type = str;
615 description = "Read password for rspamd. Unused";
616 apply = x: "";
617 };
618 write_password = mkOption {
619 type = str;
620 description = "Write password for rspamd. Unused";
621 apply = x: "";
622 };
623 };
624 };
625 };
626 scripts = mkOption {
627 description = "Mail script recipients";
628 type = attrsOf (submodule {
629 options = {
5b53d86f 630 external = mkEnableOption "Create a script_<name>@mail.immae.eu external address";
ab8f306d
IB
631 src = mkOption {
632 description = ''
633 git source to fetch the script from.
634 It must have a default.nix file as its root accepting a scriptEnv parameter
635 '';
636 type = submodule {
637 options = {
638 url = mkOption { type = str; description = "git url to fetch"; };
639 rev = mkOption { type = str; description = "git reference to fetch"; };
640 };
641 };
642 };
643 env = mkOption {
644 description = "Variables to pass to the script";
645 type = unspecified;
646 };
647 };
648 });
649 };
650 };
651 };
652 };
653 buildbot = mkOption {
654 description = "Buildbot configuration";
655 type = submodule {
656 options = {
657 user = mkOption {
658 description = "Buildbot user";
659 type = submodule {
660 options = {
661 uid = mkOption {
662 description = "user uid";
663 type = int;
664 };
665 gid = mkOption {
666 description = "user gid";
667 type = int;
668 };
669 };
670 };
671 };
672 ldap = mkOption {
673 description = "Ldap configuration for buildbot";
674 type = submodule {
675 options = {
676 password = mkOption { type = str; description = "Buildbot password"; };
677 };
678 };
679 };
680 projects = mkOption {
681 description = "Projects to make a buildbot for";
682 type = attrsOf (submodule {
683 options = {
684 name = mkOption { type = str; description = "Project name"; };
685 packages = mkOption {
686 type = unspecified;
687 example = literalExample ''
688 pkgs: [ pkgs.bash pkgs.git pkgs.gzip pkgs.openssh ];
689 '';
690 description = ''
691 Function.
692 Builds packages list to make available to buildbot project.
693 Takes pkgs as argument.
694 '';
695 };
696 pythonPackages = mkOption {
697 type = unspecified;
698 example = literalExample ''
699 p: pkgs: [ pkgs.python3Packages.pip ];
700 '';
701 description = ''
702 Function.
703 Builds python packages list to make available to buildbot project.
704 Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
705 '';
706 };
707 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
708 secrets = mkOption {
709 type = attrsOf str;
710 description = "Secrets for the project to dump as files";
711 };
712 environment = mkOption {
713 type = attrsOf str;
714 description = ''
715 Environment variables for the project.
716 BUILDBOT_ is prefixed to the variable names
717 '';
718 };
719 activationScript = mkOption {
720 type = lines;
721 description = ''
722 Activation script to run during deployment
723 '';
724 };
725 builderPaths = mkOption {
726 type = attrsOf unspecified;
727 default = {};
728 description = ''
729 Attrs of functions to make accessible specifically per builder.
730 Takes pkgs as argument and should return a single path containing binaries.
731 This path will be accessible as BUILDBOT_PATH_<attrskey>
732 '';
733 };
734 webhookTokens = mkOption {
735 type = nullOr (listOf str);
736 default = null;
737 description = ''
738 List of tokens allowed to push to project’s change_hook/base endpoint
739 '';
740 };
741 };
742 });
743 };
744 };
745 };
746 };
747 tools = mkOption {
748 description = "Tools configurations";
749 type = submodule {
750 options = {
751 davical = mkOption {
752 description = "Davical configuration";
753 type = submodule {
754 options = {
755 postgresql = mkPsqlOptions "Davical";
756 ldap = mkLdapOptions "Davical" {};
757 };
758 };
759 };
760 diaspora = mkOption {
761 description = "Diaspora configuration";
762 type = submodule {
763 options = {
764 postgresql = mkPsqlOptions "Diaspora";
765 redis = mkRedisOptions "Diaspora";
766 ldap = mkLdapOptions "Diaspora" {};
767 secret_token = mkOption { type = str; description = "Secret token"; };
768 };
769 };
770 };
771 etherpad-lite = mkOption {
772 description = "Etherpad configuration";
773 type = submodule {
774 options = {
775 postgresql = mkPsqlOptions "Etherpad";
776 ldap = mkLdapOptions "Etherpad" {
777 group_filter = mkOption { type = str; description = "Filter for groups"; };
778 };
779 session_key = mkOption { type = str; description = "Session key"; };
780 api_key = mkOption { type = str; description = "API key"; };
781 redirects = mkOption { type = str; description = "Redirects for apache"; };
782 };
783 };
784 };
785 gitolite = mkOption {
786 description = "Gitolite configuration";
787 type = submodule {
788 options = {
789 ldap = mkLdapOptions "Gitolite" {};
790 };
791 };
792 };
793 kanboard = mkOption {
794 description = "Kanboard configuration";
795 type = submodule {
796 options = {
797 postgresql = mkPsqlOptions "Kanboard";
798 ldap = mkLdapOptions "Kanboard" {
799 admin_dn = mkOption { type = str; description = "Admin DN"; };
800 };
801 };
802 };
803 };
804 mantisbt = mkOption {
805 description = "Mantisbt configuration";
806 type = submodule {
807 options = {
808 postgresql = mkPsqlOptions "Mantisbt";
809 ldap = mkLdapOptions "Mantisbt" {};
810 master_salt = mkOption { type = str; description = "Master salt for password hash"; };
811 };
812 };
813 };
814 mastodon = mkOption {
815 description = "Mastodon configuration";
816 type = submodule {
817 options = {
818 postgresql = mkPsqlOptions "Mastodon";
819 redis = mkRedisOptions "Mastodon";
820 ldap = mkLdapOptions "Mastodon" {};
821 paperclip_secret = mkOption { type = str; description = "Paperclip secret"; };
822 otp_secret = mkOption { type = str; description = "OTP secret"; };
823 secret_key_base = mkOption { type = str; description = "Secret key base"; };
824 vapid = mkOption {
825 description = "vapid key";
826 type = submodule {
827 options = {
828 private = mkOption { type = str; description = "Private key"; };
829 public = mkOption { type = str; description = "Public key"; };
830 };
831 };
832 };
833 };
834 };
835 };
836 mediagoblin = mkOption {
837 description = "Mediagoblin configuration";
838 type = submodule {
839 options = {
840 postgresql = mkPsqlOptions "Mediagoblin";
841 redis = mkRedisOptions "Mediagoblin";
842 ldap = mkLdapOptions "Mediagoblin" {};
843 };
844 };
845 };
846 nextcloud = mkOption {
847 description = "Nextcloud configuration";
848 type = submodule {
849 options = {
850 postgresql = mkPsqlOptions "Peertube";
851 redis = mkRedisOptions "Peertube";
852 password_salt = mkOption { type = str; description = "Password salt"; };
853 instance_id = mkOption { type = str; description = "Instance ID"; };
854 secret = mkOption { type = str; description = "App secret"; };
855 };
856 };
857 };
858 peertube = mkOption {
859 description = "Peertube configuration";
860 type = submodule {
861 options = {
862 listenPort = mkOption { type = port; description = "Port to listen to"; };
863 postgresql = mkPsqlOptions "Peertube";
864 redis = mkRedisOptions "Peertube";
865 ldap = mkLdapOptions "Peertube" {};
866 };
867 };
868 };
869 phpldapadmin = mkOption {
870 description = "phpLdapAdmin configuration";
871 type = submodule {
872 options = {
873 ldap = mkLdapOptions "phpldapadmin" {};
874 };
875 };
876 };
877 rompr = mkOption {
878 description = "Rompr configuration";
879 type = submodule {
880 options = {
881 mpd = mkOption {
882 description = "MPD configuration";
883 type = submodule {
884 options = {
885 host = mkOption { type = str; description = "Host for MPD"; };
886 port = mkOption { type = port; description = "Port to access MPD host"; };
887 };
888 };
889 };
890 };
891 };
892 };
893 roundcubemail = mkOption {
894 description = "Roundcubemail configuration";
895 type = submodule {
896 options = {
897 postgresql = mkPsqlOptions "TT-RSS";
898 secret = mkOption { type = str; description = "Secret"; };
899 };
900 };
901 };
902 shaarli = mkOption {
903 description = "Shaarli configuration";
904 type = submodule {
905 options = {
906 ldap = mkLdapOptions "Shaarli" {};
907 };
908 };
909 };
910 task = mkOption {
911 description = "Taskwarrior configuration";
912 type = submodule {
913 options = {
914 ldap = mkLdapOptions "Taskwarrior" {};
915 taskwarrior-web = mkOption {
916 description = "taskwarrior-web profiles";
917 type = attrsOf (submodule {
918 options = {
919 uid = mkOption {
920 type = listOf str;
921 description = "List of ldap uids having access to this profile";
922 };
923 org = mkOption { type = str; description = "Taskd organisation"; };
924 key = mkOption { type = str; description = "Taskd key"; };
925 date = mkOption { type = str; description = "Preferred date format"; };
926 };
927 });
928 };
929 };
930 };
931 };
932 ttrss = mkOption {
933 description = "TT-RSS configuration";
934 type = submodule {
935 options = {
936 postgresql = mkPsqlOptions "TT-RSS";
937 ldap = mkLdapOptions "TT-RSS" {};
938 };
939 };
940 };
941 wallabag = mkOption {
942 description = "Wallabag configuration";
943 type = submodule {
944 options = {
945 postgresql = mkPsqlOptions "Wallabag";
946 ldap = mkLdapOptions "Wallabag" {
947 admin_filter = mkOption { type = str; description = "Admin users filter"; };
948 };
949 redis = mkRedisOptions "Wallabag";
950 secret = mkOption { type = str; description = "App secret"; };
951 };
952 };
953 };
954 ympd = mkOption {
955 description = "Ympd configuration";
956 type = submodule {
957 options = {
958 listenPort = mkOption { type = port; description = "Port to listen to"; };
959 mpd = mkOption {
960 description = "MPD configuration";
961 type = submodule {
962 options = {
963 password = mkOption { type = str; description = "Password to access MPD host"; };
964 host = mkOption { type = str; description = "Host for MPD"; };
965 port = mkOption { type = port; description = "Port to access MPD host"; };
966 };
967 };
968 };
969 };
970 };
971 };
972 yourls = mkOption {
973 description = "Yourls configuration";
974 type = submodule {
975 options = {
87a8bffd 976 mysql = mkMysqlOptions "Yourls" {};
ab8f306d
IB
977 ldap = mkLdapOptions "Yourls" {};
978 cookieKey = mkOption { type = str; description = "Cookie key"; };
979 };
980 };
981 };
982 };
983 };
984 };
985 websites = mkOption {
986 description = "Websites configurations";
987 type = submodule {
988 options = {
829ef7f1
IB
989 isabelle = mkOption {
990 description = "Isabelle configurations by environment";
ab8f306d
IB
991 type =
992 let
993 atenSubmodule = mkOption {
994 description = "environment configuration";
995 type = submodule {
996 options = {
997 environment = mkOption { type = str; description = "Symfony environment"; };
998 secret = mkOption { type = str; description = "Symfony App secret"; };
999 postgresql = mkPsqlOptions "Aten";
1000 };
1001 };
1002 };
1003 in
1004 submodule {
1005 options = {
829ef7f1
IB
1006 aten_production = atenSubmodule;
1007 aten_integration = atenSubmodule;
ab8f306d
IB
1008 };
1009 };
1010 };
1011 chloe = mkOption {
1012 description = "Chloe configurations by environment";
1013 type =
1014 let
1015 chloeSubmodule = mkOption {
1016 description = "environment configuration";
1017 type = submodule {
1018 options = {
1019 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1020 mysql = mkMysqlOptions "Chloe" {};
ab8f306d
IB
1021 ldap = mkLdapOptions "Chloe" {};
1022 };
1023 };
1024 };
1025 in
1026 submodule {
1027 options = {
1028 production = chloeSubmodule;
1029 integration = chloeSubmodule;
1030 };
1031 };
1032 };
1033 connexionswing = mkOption {
1034 description = "Connexionswing configurations by environment";
1035 type =
1036 let
1037 csSubmodule = mkOption {
1038 description = "environment configuration";
1039 type = submodule {
1040 options = {
1041 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1042 mysql = mkMysqlOptions "Connexionswing" {};
ab8f306d
IB
1043 secret = mkOption { type = str; description = "Symfony App secret"; };
1044 email = mkOption { type = str; description = "Symfony email notification"; };
1045 };
1046 };
1047 };
1048 in
1049 submodule {
1050 options = {
1051 production = csSubmodule;
1052 integration = csSubmodule;
1053 };
1054 };
1055 };
1056 jerome = mkOption {
1057 description = "Naturaloutil configuration";
1058 type = submodule {
1059 options = {
87a8bffd 1060 mysql = mkMysqlOptions "Naturaloutil" {};
ab8f306d
IB
1061 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1062 };
1063 };
1064 };
1065 telioTortay = mkOption {
1066 description = "Telio Tortay configuration";
1067 type = submodule {
1068 options = {
1069 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1070 };
1071 };
1072 };
1073 ludivinecassal = mkOption {
1074 description = "Ludivinecassal configurations by environment";
1075 type =
1076 let
1077 lcSubmodule = mkOption {
1078 description = "environment configuration";
1079 type = submodule {
1080 options = {
1081 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1082 mysql = mkMysqlOptions "LudivineCassal" {};
ab8f306d
IB
1083 ldap = mkLdapOptions "LudivineCassal" {};
1084 secret = mkOption { type = str; description = "Symfony App secret"; };
1085 };
1086 };
1087 };
1088 in
1089 submodule {
1090 options = {
1091 production = lcSubmodule;
1092 integration = lcSubmodule;
1093 };
1094 };
1095 };
1096 emilia = mkOption {
1097 description = "Emilia configuration";
1098 type = submodule {
1099 options = {
1100 postgresql = mkPsqlOptions "Emilia";
1101 };
1102 };
1103 };
1104 florian = mkOption {
1105 description = "Florian configuration";
1106 type = submodule {
1107 options = {
1108 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1109 };
1110 };
1111 };
1112 nassime = mkOption {
1113 description = "Nassime configuration";
1114 type = submodule {
1115 options = {
1116 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1117 };
1118 };
1119 };
1120 piedsjaloux = mkOption {
1121 description = "Piedsjaloux configurations by environment";
1122 type =
1123 let
1124 pjSubmodule = mkOption {
1125 description = "environment configuration";
1126 type = submodule {
1127 options = {
1128 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1129 mysql = mkMysqlOptions "Piedsjaloux" {};
ab8f306d
IB
1130 secret = mkOption { type = str; description = "Symfony App secret"; };
1131 };
1132 };
1133 };
1134 in
1135 submodule {
1136 options = {
1137 production = pjSubmodule;
1138 integration = pjSubmodule;
1139 };
1140 };
1141 };
91b75ffe
IB
1142 richie = mkOption {
1143 description = "Europe Richie configurations by environment";
1144 type = submodule {
1145 options = {
87a8bffd 1146 mysql = mkMysqlOptions "Richie" {};
91b75ffe
IB
1147 smtp_mailer = mkOption {
1148 description = "SMTP mailer configuration";
1149 type = submodule {
1150 options = {
1151 user = mkOption { type = str; description = "Username"; };
1152 password = mkOption { type = str; description = "Password"; };
1153 };
1154 };
1155 };
1156 };
1157 };
1158 };
ab8f306d
IB
1159 tellesflorian = mkOption {
1160 description = "Tellesflorian configurations by environment";
1161 type =
1162 let
1163 tfSubmodule = mkOption {
1164 description = "environment configuration";
1165 type = submodule {
1166 options = {
1167 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1168 mysql = mkMysqlOptions "Tellesflorian" {};
ab8f306d
IB
1169 secret = mkOption { type = str; description = "Symfony App secret"; };
1170 invite_passwords = mkOption { type = str; description = "Password basic auth"; };
1171 };
1172 };
1173 };
1174 in
1175 submodule {
1176 options = {
1177 integration = tfSubmodule;
1178 };
1179 };
1180 };
1181 };
1182 };
1183 };
1184
1185 privateFiles = mkOption {
1186 type = path;
1187 description = ''
1188 Path to secret files to make available during build
1189 '';
1190 };
1191 };
619e4f46
IB
1192 options.hostEnv = mkOption {
1193 readOnly = true;
1194 type = hostEnv;
1195 default = config.myEnv.servers."${name}";
1196 description = "Host environment";
ab8f306d
IB
1197 };
1198}