]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/environment.nix
Update Chloé’s website
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
CommitLineData
619e4f46 1{ config, lib, name, ... }:
ab8f306d
IB
2with lib;
3with types;
4with lists;
5let
6 ldapOptions = {
7 base = mkOption { description = "Base of the LDAP tree"; type = str; };
8 host = mkOption { description = "Host to access LDAP"; type = str; };
9 root_dn = mkOption { description = "DN of the root user"; type = str; };
10 root_pw = mkOption { description = "Hashed password of the root user"; type = str; };
11 replication_dn = mkOption { description = "DN of the user allowed to replicate the LDAP directory"; type = str; };
12 replication_pw = mkOption { description = "Password of the user allowed to replicate the LDAP directory"; type = str; };
13 };
14 mkLdapOptions = name: more: mkOption {
15 description = "${name} LDAP configuration";
16 type = submodule {
17 options = ldapOptions // {
18 dn = mkOption { description = "DN of the ${name} user"; type = str; };
19 password = mkOption { description = "password of the ${name} user"; type = str; };
20 filter = mkOption { description = "Filter for ${name} users"; type = str; default = ""; };
21 } // more;
22 };
23 };
24 mysqlOptions = {
25 host = mkOption { description = "Host to access Mysql"; type = str; };
619e4f46 26 remoteHost = mkOption { description = "Host to access Mysql from outside"; type = str; };
ab8f306d
IB
27 port = mkOption { description = "Port to access Mysql"; type = str; };
28 socket = mkOption { description = "Socket to access Mysql"; type = path; };
29 systemUsers = mkOption {
30 description = "Attrs of user-passwords allowed to access mysql";
31 type = attrsOf str;
32 };
33 pam = mkOption {
34 description = "PAM configuration for mysql";
35 type = submodule {
36 options = {
37 dn = mkOption { description = "DN to connect as to check users"; type = str; };
38 password = mkOption { description = "DN password to connect as to check users"; type = str; };
39 filter = mkOption { description = "filter to match users"; type = str; };
40 };
41 };
42 };
43 };
87a8bffd 44 mkMysqlOptions = name: more: mkOption {
ab8f306d
IB
45 description = "${name} mysql configuration";
46 type = submodule {
47 options = mysqlOptions // {
48 database = mkOption { description = "${name} database"; type = str; };
49 user = mkOption { description = "${name} user"; type = str; };
50 password = mkOption { description = "mysql password of the ${name} user"; type = str; };
87a8bffd 51 } // more;
ab8f306d
IB
52 };
53 };
54 psqlOptions = {
55 host = mkOption { description = "Host to access Postgresql"; type = str; };
56 port = mkOption { description = "Port to access Postgresql"; type = str; };
57 socket = mkOption { description = "Socket to access Postgresql"; type = path; };
58 pam = mkOption {
59 description = "PAM configuration for psql";
60 type = submodule {
61 options = {
62 dn = mkOption { description = "DN to connect as to check users"; type = str; };
63 password = mkOption { description = "DN password to connect as to check users"; type = str; };
64 filter = mkOption { description = "filter to match users"; type = str; };
65 };
66 };
67 };
68 };
69 mkPsqlOptions = name: mkOption {
70 description = "${name} psql configuration";
71 type = submodule {
72 options = psqlOptions // {
73 database = mkOption { description = "${name} database"; type = str; };
74 schema = mkOption { description = "${name} schema"; type = nullOr str; default = null; };
75 user = mkOption { description = "${name} user"; type = str; };
76 password = mkOption { description = "psql password of the ${name} user"; type = str; };
77 };
78 };
79 };
80 redisOptions = {
81 host = mkOption { description = "Host to access Redis"; type = str; };
82 port = mkOption { description = "Port to access Redis"; type = str; };
83 socket = mkOption { description = "Socket to access Redis"; type = path; };
84 dbs = mkOption {
85 description = "Attrs of db number. Each number should be unique to avoid collision!";
86 type = attrsOf str;
87 };
88 spiped_key = mkOption {
89 type = str;
90 description = ''
91 Key to use with spiped to make a secure channel to replication
92 '';
93 };
94 predixy = mkOption {
95 description = "Predixy configuration. Unused yet";
96 type = submodule {
97 options = {
98 read = mkOption { type = str; description = "Read password"; };
99 };
100 };
101 };
102 };
103 mkRedisOptions = name: mkOption {
104 description = "${name} redis configuration";
105 type = submodule {
106 options = redisOptions // {
107 db = mkOption { description = "${name} database"; type = str; };
108 };
109 };
110 };
619e4f46
IB
111 hostEnv = submodule {
112 options = {
113 fqdn = mkOption {
114 description = "Host FQDN";
115 type = str;
116 };
8a304ef4
IB
117 users = mkOption {
118 type = unspecified;
119 default = pkgs: [];
120 description = ''
121 Sublist of users from realUsers. Function that takes pkgs as
122 argument and gives an array as a result
123 '';
124 };
619e4f46
IB
125 emails = mkOption {
126 default = [];
127 description = "List of e-mails that the server can be a sender of";
128 type = listOf str;
129 };
130 ldap = mkOption {
131 description = ''
132 LDAP credentials for the host
133 '';
134 type = submodule {
135 options = {
5400b9b6
IB
136 password = mkOption { type = str; description = "Password for the LDAP connection"; };
137 dn = mkOption { type = str; description = "DN for the LDAP connection"; };
619e4f46
IB
138 };
139 };
140 };
141 mx = mkOption {
142 description = "subdomain and priority for MX server";
143 default = { enable = false; };
144 type = submodule {
145 options = {
146 enable = mkEnableOption "Enable MX";
147 subdomain = mkOption { type = nullOr str; description = "Subdomain name (mx-*)"; };
148 priority = mkOption { type = nullOr str; description = "Priority"; };
149 };
150 };
151 };
152 ips = mkOption {
153 description = ''
154 attrs of ip4/ip6 grouped by section
155 '';
156 type = attrsOf (submodule {
157 options = {
158 ip4 = mkOption {
5400b9b6 159 type = str;
619e4f46
IB
160 description = ''
161 ip4 address of the host
162 '';
163 };
164 ip6 = mkOption {
5400b9b6 165 type = listOf str;
619e4f46
IB
166 default = [];
167 description = ''
168 ip6 addresses of the host
169 '';
170 };
171 };
172 });
173 };
174 };
175 };
ab8f306d
IB
176in
177{
178 options.myEnv = {
179 servers = mkOption {
180 description = ''
181 Attrs of servers information in the cluster (not necessarily handled by nixops)
182 '';
183 default = {};
619e4f46 184 type = attrsOf hostEnv;
ab8f306d
IB
185 };
186 hetznerCloud = mkOption {
187 description = ''
188 Hetzner Cloud credential information
189 '';
190 type = submodule {
191 options = {
192 authToken = mkOption {
193 type = str;
194 description = ''
195 The API auth token.
196 '';
197 };
198 };
199 };
200 };
201 hetzner = mkOption {
202 description = ''
203 Hetzner credential information
204 '';
205 type = submodule {
206 options = {
207 user = mkOption { type = str; description = "User"; };
208 pass = mkOption { type = str; description = "Password"; };
209 };
210 };
211 };
212 sshd = mkOption {
213 description = ''
214 sshd service credential information
215 '';
216 type = submodule {
217 options = {
218 ldap = mkOption {
219 description = ''
220 LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
221 '';
222 type = submodule {
223 options = {
224 password = mkOption { description = "Password"; type = str; };
225 };
226 };
227 };
228 };
229 };
230 };
231 ports = mkOption {
232 description = ''
233 non-standard reserved ports. Must be unique!
234 '';
235 type = attrsOf port;
236 default = {};
237 apply = let
238 noDupl = x: builtins.length (builtins.attrValues x) == builtins.length (unique (builtins.attrValues x));
239 in
240 x: if isAttrs x && noDupl x then x else throw "Non unique values for ports";
241 };
242 httpd = mkOption {
243 description = ''
244 httpd service credential information
245 '';
246 type = submodule {
247 options = {
248 ldap = mkOption {
249 description = ''
250 LDAP credentials for cn=httpd,ou=services,dc=immae,dc=eu dn
251 '';
252 type = submodule {
253 options = {
254 password = mkOption { description = "Password"; type = str; };
255 };
256 };
257 };
258 };
259 };
260 };
261 ldap = mkOption {
262 description = ''
263 LDAP server configuration
264 '';
265 type = submodule {
266 options = ldapOptions;
267 };
268 };
269 databases = mkOption {
270 description = "Databases configuration";
271 type = submodule {
272 options = {
273 mysql = mkOption {
274 type = submodule { options = mysqlOptions; };
275 description = "Mysql configuration";
276 };
277 redis = mkOption {
278 type = submodule { options = redisOptions; };
279 description = "Redis configuration";
280 };
281 postgresql = mkOption {
282 type = submodule { options = psqlOptions; };
283 description = "Postgresql configuration";
284 };
285 };
286 };
287 };
288 jabber = mkOption {
289 description = "Jabber configuration";
290 type = submodule {
291 options = {
5b53d86f 292 postfix_user_filter = mkOption { type = str; description = "Postfix filter to get xmpp users"; };
ab8f306d
IB
293 ldap = mkLdapOptions "Jabber" {};
294 postgresql = mkPsqlOptions "Jabber";
295 };
296 };
297 };
8a304ef4
IB
298 realUsers = mkOption {
299 description = ''
300 Attrset of function taking pkgs as argument.
301 Real users settings, should provide a subattr of users.users.<name>
302 with at least: name, (hashed)Password, shell
303 '';
304 type = attrsOf unspecified;
305 };
ab8f306d
IB
306 users = mkOption {
307 description = "System and regular users uid/gid";
308 type = attrsOf (submodule {
309 options = {
310 uid = mkOption {
311 description = "user uid";
312 type = int;
313 };
314 gid = mkOption {
315 description = "user gid";
316 type = int;
317 };
318 };
319 });
320 };
321 dns = mkOption {
322 description = "DNS configuration";
323 type = submodule {
324 options = {
325 soa = mkOption {
326 description = "SOA information";
327 type = submodule {
328 options = {
329 serial = mkOption {
330 description = "Serial number. Should be incremented at each change and unique";
331 type = str;
332 };
333 refresh = mkOption {
334 description = "Refresh time";
335 type = str;
336 };
337 retry = mkOption {
338 description = "Retry time";
339 type = str;
340 };
341 expire = mkOption {
342 description = "Expire time";
343 type = str;
344 };
345 ttl = mkOption {
346 description = "Default TTL time";
347 type = str;
348 };
349 email = mkOption {
350 description = "hostmaster e-mail";
351 type = str;
352 };
353 primary = mkOption {
354 description = "Primary NS";
355 type = str;
356 };
357 };
358 };
359 };
360 ns = mkOption {
361 description = "Attrs of NS servers group";
362 example = {
363 foo = {
364 "ns1.foo.com" = [ "198.51.100.10" "2001:db8:abcd::1" ];
365 "ns2.foo.com" = [ "198.51.100.15" "2001:db8:1234::1" ];
366 };
367 };
368 type = attrsOf (attrsOf (listOf str));
369 };
370 slaveZones = mkOption {
371 description = "List of slave zones";
372 type = listOf (submodule {
373 options = {
374 name = mkOption { type = str; description = "zone name"; };
375 masters = mkOption {
376 description = "NS master groups of this zone";
377 type = listOf str;
378 };
379 };
380 });
381 };
382 masterZones = mkOption {
383 description = "List of master zones";
384 type = listOf (submodule {
385 options = {
386 name = mkOption { type = str; description = "zone name"; };
387 slaves = mkOption {
388 description = "NS slave groups of this zone";
389 type = listOf str;
390 };
391 ns = mkOption {
392 description = "groups names that should have their NS entries listed here";
393 type = listOf str;
394 };
395 extra = mkOption {
396 description = "Extra zone configuration for bind";
397 example = ''
398 notify yes;
399 '';
400 type = lines;
401 };
402 entries = mkOption { type = lines; description = "Regular entries of the NS zone"; };
403 withEmail = mkOption {
404 description = "List of domains that should have mail entries (MX, dkim, SPF, ...)";
405 default = [];
406 type = listOf (submodule {
407 options = {
408 domain = mkOption { type = str; description = "Which subdomain is concerned"; };
409 send = mkOption { type = bool; description = "Whether there can be e-mails originating from the subdomain"; };
410 receive = mkOption { type = bool; description = "Whether there can be e-mails arriving to the subdomain"; };
411 };
412 });
413 };
414 };
415 });
416 };
417 };
418 };
419 };
420 backup = mkOption {
421 description = ''
422 Remote backup with duplicity
423 '';
424 type = submodule {
425 options = {
426 password = mkOption { type = str; description = "Password for encrypting files"; };
427 remote = mkOption { type = str; description = "Remote url access"; };
428 accessKeyId = mkOption { type = str; description = "Remote access-key"; };
429 secretAccessKey = mkOption { type = str; description = "Remote access secret"; };
430 };
431 };
432 };
433 rsync_backup = mkOption {
434 description =''
435 Rsync backup configuration from controlled host
436 '';
437 type = submodule {
438 options = {
ab8f306d
IB
439 ssh_key = mkOption {
440 description = "SSH key information";
441 type = submodule {
442 options = {
443 public = mkOption { type = str; description = "Public part of the key"; };
444 private = mkOption { type = lines; description = "Private part of the key"; };
445 };
446 };
447 };
448 profiles = mkOption {
449 description = "Attrs of profiles to backup";
450 type = attrsOf (submodule {
451 options = {
452 keep = mkOption { type = int; description = "Number of backups to keep"; };
453 login = mkOption { type = str; description = "Login to connect to host"; };
454 port = mkOption { type = str; default = "22"; description = "Port to connect to host"; };
455 host = mkOption { type = str; description = "Host to connect to"; };
456 host_key = mkOption { type = str; description = "Host key"; };
457 host_key_type = mkOption { type = str; description = "Host key type"; };
458 parts = mkOption {
459 description = "Parts to backup for this host";
460 type = attrsOf (submodule {
461 options = {
462 remote_folder = mkOption { type = path; description = "Remote folder to backup";};
463 exclude_from = mkOption {
464 type = listOf path;
465 default = [];
466 description = "List of folders/files to exclude from the backup";
467 };
468 files_from = mkOption {
469 type = listOf path;
470 default = [];
471 description = "List of folders/files to backup in the base folder";
472 };
473 args = mkOption {
474 type = nullOr str;
475 default = null;
476 description = "Extra arguments to pass to rsync";
477 };
478 };
479 });
480 };
481 };
482 });
483 };
484 };
485 };
486 };
487 monitoring = mkOption {
488 description = "Monitoring configuration";
489 type = submodule {
490 options = {
491 status_url = mkOption { type = str; description = "URL to push status to"; };
492 status_token = mkOption { type = str; description = "Token for the status url"; };
e820134d 493 http_user_password = mkOption { type = str; description = "HTTP credentials to check services behind wall"; };
ab8f306d 494 email = mkOption { type = str; description = "Admin E-mail"; };
e820134d
IB
495 ssh_public_key = mkOption { type = str; description = "SSH public key"; };
496 ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
497 imap_login = mkOption { type = str; description = "IMAP login"; };
498 imap_password = mkOption { type = str; description = "IMAP password"; };
25844101 499 eriomem_keys = mkOption { type = listOf (listOf str); description = "Eriomem keys"; default = []; };
6191bdeb
IB
500 ovh_sms = mkOption {
501 description = "OVH credentials for sms script";
502 type = submodule {
503 options = {
504 endpoint = mkOption { type = str; default = "ovh-eu"; description = "OVH endpoint"; };
505 application_key = mkOption { type = str; description = "Application key"; };
506 application_secret = mkOption { type = str; description = "Application secret"; };
507 consumer_key = mkOption { type = str; description = "Consumer key"; };
508 account = mkOption { type = str; description = "Account"; };
509 };
510 };
511 };
e820134d
IB
512 nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
513 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
514 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
515 contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
71a2425e
IB
516 email_check = mkOption {
517 description = "Emails services to check";
518 type = attrsOf (submodule {
519 options = {
520 local = mkOption { type = bool; default = false; description = "Use local configuration"; };
521 port = mkOption { type = nullOr str; default = null; description = "Port to connect to ssh"; };
522 login = mkOption { type = nullOr str; default = null; description = "Login to connect to ssh"; };
523 targets = mkOption { type = listOf str; description = "Hosts to send E-mails to"; };
ef0a9217
IB
524 mail_address = mkOption { type = nullOr str; default = null; description = "E-mail recipient part to send e-mail to"; };
525 mail_domain = mkOption { type = nullOr str; default = null; description = "E-mail domain part to send e-mail to"; };
71a2425e
IB
526 };
527 });
528 };
ab8f306d
IB
529 };
530 };
531 };
532 mpd = mkOption {
533 description = "MPD configuration";
534 type = submodule {
535 options = {
536 folder = mkOption { type = str; description = "Folder to serve from the MPD instance"; };
537 password = mkOption { type = str; description = "Password to connect to the MPD instance"; };
538 host = mkOption { type = str; description = "Host to connect to the MPD instance"; };
539 port = mkOption { type = str; description = "Port to connect to the MPD instance"; };
540 };
541 };
542 };
543 ftp = mkOption {
544 description = "FTP configuration";
545 type = submodule {
546 options = {
547 ldap = mkLdapOptions "FTP" {};
548 };
549 };
550 };
ea9c6fe8
IB
551 vpn = mkOption {
552 description = "VPN configuration";
553 type = attrsOf (submodule {
554 options = {
555 prefix = mkOption { type = str; description = "ipv6 prefix for the vpn subnet"; };
556 privateKey = mkOption { type = str; description = "Private key for the host"; };
557 publicKey = mkOption { type = str; description = "Public key for the host"; };
558 };
559 });
560 };
ab8f306d
IB
561 mail = mkOption {
562 description = "Mail configuration";
563 type = submodule {
564 options = {
565 dmarc = mkOption {
566 description = "DMARC configuration";
567 type = submodule {
568 options = {
569 ignore_hosts = mkOption {
570 type = lines;
571 description = ''
572 Hosts to ignore when checking for dmarc
573 '';
574 };
575 };
576 };
577 };
578 dkim = mkOption {
579 description = "DKIM configuration";
580 type = attrsOf (submodule {
581 options = {
582 public = mkOption {
583 type = str;
584 example = ''
585 ( "v=DKIM1; k=rsa; "
586 "p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC3w1a2aMxWw9+hdcmbqX4UevcVqr204y0K73Wdc7MPZiOOlUJQYsMNSYR1Y/SC7jmPKeitpcJCpQgn/cveJZbuikjjPLsDReHyFEYmC278ZLRTELHx6f1IXM8WE08JIRT69CfZiMi1rVcOh9qRT4F93PyjCauU8Y5hJjtg9ThsWwIDAQAB" )
587 '';
588 description = "Public entry to put in DNS TXT field";
589 };
590 private = mkOption { type = str; description = "Private key"; };
591 };
592 });
593 };
594 postfix = mkOption {
595 description = "Postfix configuration";
596 type = submodule {
597 options = {
598 additional_mailbox_domains = mkOption {
599 description = ''
600 List of domains that are used as mailbox final destination, in addition to those defined in the DNS records
601 '';
602 type = listOf str;
603 };
87a8bffd
IB
604 mysql = mkMysqlOptions "Postfix" {
605 password_encrypt = mkOption { type = str; description = "Key to encrypt relay password in database"; };
606 };
ab8f306d
IB
607 backup_domains = mkOption {
608 description = ''
609 Domains that are accepted for relay as backup domain
610 '';
611 type = attrsOf (submodule {
612 options = {
613 domains = mkOption { type = listOf str; description = "Domains list"; };
614 relay_restrictions = mkOption {
615 type = lines;
616 description = ''
617 Restrictions for relaying the e-mails from the domains
618 '';
619 };
620 recipient_maps = mkOption {
621 description = ''
622 Recipient map to accept relay for.
623 Must be specified for domain, the rules apply to everyone!
624 '';
625 type = listOf (submodule {
626 options = {
627 type = mkOption {
628 type = enum [ "hash" ];
629 description = "Map type";
630 };
631 content = mkOption {
632 type = str;
633 description = "Map content";
634 };
635 };
636 });
637 };
638 };
639 });
640 };
641 };
642 };
643 };
644 dovecot = mkOption {
645 description = "Dovecot configuration";
646 type = submodule {
647 options = {
648 ldap = mkLdapOptions "Dovecot" {
649 pass_attrs = mkOption { type = str; description = "Password attribute in LDAP"; };
650 user_attrs = mkOption { type = str; description = "User attribute mapping in LDAP"; };
651 iterate_attrs = mkOption { type = str; description = "User attribute mapping for listing in LDAP"; };
652 iterate_filter = mkOption { type = str; description = "User attribute filter for listing in LDAP"; };
653 };
654 };
655 };
656 };
657 rspamd = mkOption {
658 description = "rspamd configuration";
659 type = submodule {
660 options = {
661 redis = mkRedisOptions "Redis";
662 read_password_hashed = mkOption { type = str; description = "Hashed read password for rspamd"; };
663 write_password_hashed = mkOption { type = str; description = "Hashed write password for rspamd"; };
664 read_password = mkOption {
665 type = str;
666 description = "Read password for rspamd. Unused";
667 apply = x: "";
668 };
669 write_password = mkOption {
670 type = str;
671 description = "Write password for rspamd. Unused";
672 apply = x: "";
673 };
674 };
675 };
676 };
677 scripts = mkOption {
678 description = "Mail script recipients";
679 type = attrsOf (submodule {
680 options = {
5b53d86f 681 external = mkEnableOption "Create a script_<name>@mail.immae.eu external address";
ab8f306d
IB
682 src = mkOption {
683 description = ''
684 git source to fetch the script from.
685 It must have a default.nix file as its root accepting a scriptEnv parameter
686 '';
687 type = submodule {
688 options = {
689 url = mkOption { type = str; description = "git url to fetch"; };
690 rev = mkOption { type = str; description = "git reference to fetch"; };
691 };
692 };
693 };
694 env = mkOption {
695 description = "Variables to pass to the script";
696 type = unspecified;
697 };
698 };
699 });
700 };
701 };
702 };
703 };
704 buildbot = mkOption {
705 description = "Buildbot configuration";
706 type = submodule {
707 options = {
708 user = mkOption {
709 description = "Buildbot user";
710 type = submodule {
711 options = {
712 uid = mkOption {
713 description = "user uid";
714 type = int;
715 };
716 gid = mkOption {
717 description = "user gid";
718 type = int;
719 };
720 };
721 };
722 };
723 ldap = mkOption {
724 description = "Ldap configuration for buildbot";
725 type = submodule {
726 options = {
727 password = mkOption { type = str; description = "Buildbot password"; };
728 };
729 };
730 };
731 projects = mkOption {
732 description = "Projects to make a buildbot for";
733 type = attrsOf (submodule {
734 options = {
735 name = mkOption { type = str; description = "Project name"; };
736 packages = mkOption {
737 type = unspecified;
738 example = literalExample ''
739 pkgs: [ pkgs.bash pkgs.git pkgs.gzip pkgs.openssh ];
740 '';
741 description = ''
742 Function.
743 Builds packages list to make available to buildbot project.
744 Takes pkgs as argument.
745 '';
746 };
747 pythonPackages = mkOption {
748 type = unspecified;
749 example = literalExample ''
750 p: pkgs: [ pkgs.python3Packages.pip ];
751 '';
752 description = ''
753 Function.
754 Builds python packages list to make available to buildbot project.
755 Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
756 '';
757 };
758 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
759 secrets = mkOption {
760 type = attrsOf str;
761 description = "Secrets for the project to dump as files";
762 };
763 environment = mkOption {
764 type = attrsOf str;
765 description = ''
766 Environment variables for the project.
767 BUILDBOT_ is prefixed to the variable names
768 '';
769 };
770 activationScript = mkOption {
771 type = lines;
772 description = ''
773 Activation script to run during deployment
774 '';
775 };
776 builderPaths = mkOption {
777 type = attrsOf unspecified;
778 default = {};
779 description = ''
780 Attrs of functions to make accessible specifically per builder.
781 Takes pkgs as argument and should return a single path containing binaries.
782 This path will be accessible as BUILDBOT_PATH_<attrskey>
783 '';
784 };
785 webhookTokens = mkOption {
786 type = nullOr (listOf str);
787 default = null;
788 description = ''
789 List of tokens allowed to push to project’s change_hook/base endpoint
790 '';
791 };
792 };
793 });
794 };
795 };
796 };
797 };
798 tools = mkOption {
799 description = "Tools configurations";
800 type = submodule {
801 options = {
251c0a13 802 contact = mkOption { type = str; description = "Contact e-mail address"; };
ab8f306d
IB
803 davical = mkOption {
804 description = "Davical configuration";
805 type = submodule {
806 options = {
807 postgresql = mkPsqlOptions "Davical";
808 ldap = mkLdapOptions "Davical" {};
809 };
810 };
811 };
812 diaspora = mkOption {
813 description = "Diaspora configuration";
814 type = submodule {
815 options = {
816 postgresql = mkPsqlOptions "Diaspora";
817 redis = mkRedisOptions "Diaspora";
818 ldap = mkLdapOptions "Diaspora" {};
819 secret_token = mkOption { type = str; description = "Secret token"; };
820 };
821 };
822 };
7df5e532
IB
823 dmarc_reports = mkOption {
824 description = "DMARC reports configuration";
825 type = submodule {
826 options = {
827 mysql = mkMysqlOptions "DMARC" {};
9c08c3bc 828 anonymous_key = mkOption { type = str; description = "Anonymous hashing key"; };
7df5e532
IB
829 };
830 };
831 };
ab8f306d
IB
832 etherpad-lite = mkOption {
833 description = "Etherpad configuration";
834 type = submodule {
835 options = {
836 postgresql = mkPsqlOptions "Etherpad";
837 ldap = mkLdapOptions "Etherpad" {
838 group_filter = mkOption { type = str; description = "Filter for groups"; };
839 };
f0d942ac 840 adminPassword = mkOption { type = str; description = "Admin password for mypads / admin"; };
ab8f306d
IB
841 session_key = mkOption { type = str; description = "Session key"; };
842 api_key = mkOption { type = str; description = "API key"; };
843 redirects = mkOption { type = str; description = "Redirects for apache"; };
844 };
845 };
846 };
847 gitolite = mkOption {
848 description = "Gitolite configuration";
849 type = submodule {
850 options = {
851 ldap = mkLdapOptions "Gitolite" {};
852 };
853 };
854 };
855 kanboard = mkOption {
856 description = "Kanboard configuration";
857 type = submodule {
858 options = {
859 postgresql = mkPsqlOptions "Kanboard";
860 ldap = mkLdapOptions "Kanboard" {
861 admin_dn = mkOption { type = str; description = "Admin DN"; };
862 };
863 };
864 };
865 };
866 mantisbt = mkOption {
867 description = "Mantisbt configuration";
868 type = submodule {
869 options = {
870 postgresql = mkPsqlOptions "Mantisbt";
871 ldap = mkLdapOptions "Mantisbt" {};
872 master_salt = mkOption { type = str; description = "Master salt for password hash"; };
873 };
874 };
875 };
876 mastodon = mkOption {
877 description = "Mastodon configuration";
878 type = submodule {
879 options = {
880 postgresql = mkPsqlOptions "Mastodon";
881 redis = mkRedisOptions "Mastodon";
882 ldap = mkLdapOptions "Mastodon" {};
883 paperclip_secret = mkOption { type = str; description = "Paperclip secret"; };
884 otp_secret = mkOption { type = str; description = "OTP secret"; };
885 secret_key_base = mkOption { type = str; description = "Secret key base"; };
886 vapid = mkOption {
887 description = "vapid key";
888 type = submodule {
889 options = {
890 private = mkOption { type = str; description = "Private key"; };
891 public = mkOption { type = str; description = "Public key"; };
892 };
893 };
894 };
895 };
896 };
897 };
898 mediagoblin = mkOption {
899 description = "Mediagoblin configuration";
900 type = submodule {
901 options = {
902 postgresql = mkPsqlOptions "Mediagoblin";
903 redis = mkRedisOptions "Mediagoblin";
904 ldap = mkLdapOptions "Mediagoblin" {};
905 };
906 };
907 };
908 nextcloud = mkOption {
909 description = "Nextcloud configuration";
910 type = submodule {
911 options = {
912 postgresql = mkPsqlOptions "Peertube";
913 redis = mkRedisOptions "Peertube";
914 password_salt = mkOption { type = str; description = "Password salt"; };
915 instance_id = mkOption { type = str; description = "Instance ID"; };
916 secret = mkOption { type = str; description = "App secret"; };
917 };
918 };
919 };
920 peertube = mkOption {
921 description = "Peertube configuration";
922 type = submodule {
923 options = {
924 listenPort = mkOption { type = port; description = "Port to listen to"; };
925 postgresql = mkPsqlOptions "Peertube";
926 redis = mkRedisOptions "Peertube";
927 ldap = mkLdapOptions "Peertube" {};
928 };
929 };
930 };
8a05c7fb
IB
931 syden_peertube = mkOption {
932 description = "Peertube Syden configuration";
933 type = submodule {
934 options = {
935 listenPort = mkOption { type = port; description = "Port to listen to"; };
936 postgresql = mkPsqlOptions "Peertube";
937 redis = mkRedisOptions "Peertube";
938 };
939 };
940 };
ab8f306d
IB
941 phpldapadmin = mkOption {
942 description = "phpLdapAdmin configuration";
943 type = submodule {
944 options = {
945 ldap = mkLdapOptions "phpldapadmin" {};
946 };
947 };
948 };
949 rompr = mkOption {
950 description = "Rompr configuration";
951 type = submodule {
952 options = {
953 mpd = mkOption {
954 description = "MPD configuration";
955 type = submodule {
956 options = {
957 host = mkOption { type = str; description = "Host for MPD"; };
958 port = mkOption { type = port; description = "Port to access MPD host"; };
959 };
960 };
961 };
962 };
963 };
964 };
965 roundcubemail = mkOption {
966 description = "Roundcubemail configuration";
967 type = submodule {
968 options = {
969 postgresql = mkPsqlOptions "TT-RSS";
970 secret = mkOption { type = str; description = "Secret"; };
971 };
972 };
973 };
974 shaarli = mkOption {
975 description = "Shaarli configuration";
976 type = submodule {
977 options = {
978 ldap = mkLdapOptions "Shaarli" {};
979 };
980 };
981 };
982 task = mkOption {
983 description = "Taskwarrior configuration";
984 type = submodule {
985 options = {
986 ldap = mkLdapOptions "Taskwarrior" {};
987 taskwarrior-web = mkOption {
988 description = "taskwarrior-web profiles";
989 type = attrsOf (submodule {
990 options = {
991 uid = mkOption {
992 type = listOf str;
993 description = "List of ldap uids having access to this profile";
994 };
995 org = mkOption { type = str; description = "Taskd organisation"; };
996 key = mkOption { type = str; description = "Taskd key"; };
997 date = mkOption { type = str; description = "Preferred date format"; };
998 };
999 });
1000 };
1001 };
1002 };
1003 };
1004 ttrss = mkOption {
1005 description = "TT-RSS configuration";
1006 type = submodule {
1007 options = {
1008 postgresql = mkPsqlOptions "TT-RSS";
1009 ldap = mkLdapOptions "TT-RSS" {};
1010 };
1011 };
1012 };
1013 wallabag = mkOption {
1014 description = "Wallabag configuration";
1015 type = submodule {
1016 options = {
1017 postgresql = mkPsqlOptions "Wallabag";
1018 ldap = mkLdapOptions "Wallabag" {
1019 admin_filter = mkOption { type = str; description = "Admin users filter"; };
1020 };
1021 redis = mkRedisOptions "Wallabag";
1022 secret = mkOption { type = str; description = "App secret"; };
1023 };
1024 };
1025 };
251c0a13
IB
1026 webhooks = mkOption {
1027 type = attrsOf str;
1028 description = "Mapping 'name'.php => script for webhooks";
1029 };
ab8f306d
IB
1030 ympd = mkOption {
1031 description = "Ympd configuration";
1032 type = submodule {
1033 options = {
1034 listenPort = mkOption { type = port; description = "Port to listen to"; };
1035 mpd = mkOption {
1036 description = "MPD configuration";
1037 type = submodule {
1038 options = {
1039 password = mkOption { type = str; description = "Password to access MPD host"; };
1040 host = mkOption { type = str; description = "Host for MPD"; };
1041 port = mkOption { type = port; description = "Port to access MPD host"; };
1042 };
1043 };
1044 };
1045 };
1046 };
1047 };
1048 yourls = mkOption {
1049 description = "Yourls configuration";
1050 type = submodule {
1051 options = {
87a8bffd 1052 mysql = mkMysqlOptions "Yourls" {};
ab8f306d
IB
1053 ldap = mkLdapOptions "Yourls" {};
1054 cookieKey = mkOption { type = str; description = "Cookie key"; };
1055 };
1056 };
1057 };
1058 };
1059 };
1060 };
1061 websites = mkOption {
1062 description = "Websites configurations";
1063 type = submodule {
1064 options = {
829ef7f1
IB
1065 isabelle = mkOption {
1066 description = "Isabelle configurations by environment";
ab8f306d
IB
1067 type =
1068 let
1069 atenSubmodule = mkOption {
1070 description = "environment configuration";
1071 type = submodule {
1072 options = {
1073 environment = mkOption { type = str; description = "Symfony environment"; };
1074 secret = mkOption { type = str; description = "Symfony App secret"; };
1075 postgresql = mkPsqlOptions "Aten";
1076 };
1077 };
1078 };
1079 in
1080 submodule {
1081 options = {
829ef7f1
IB
1082 aten_production = atenSubmodule;
1083 aten_integration = atenSubmodule;
423c3f1c
IB
1084 iridologie = mkOption {
1085 description = "environment configuration";
1086 type = submodule {
1087 options = {
1088 environment = mkOption { type = str; description = "SPIP environment"; };
1089 mysql = mkMysqlOptions "Iridologie" {};
1090 ldap = mkLdapOptions "Iridologie" {};
1091 };
1092 };
1093 };
ab8f306d
IB
1094 };
1095 };
1096 };
1097 chloe = mkOption {
1098 description = "Chloe configurations by environment";
1099 type =
1100 let
1101 chloeSubmodule = mkOption {
1102 description = "environment configuration";
1103 type = submodule {
1104 options = {
423c3f1c 1105 environment = mkOption { type = str; description = "SPIP environment"; };
87a8bffd 1106 mysql = mkMysqlOptions "Chloe" {};
ab8f306d
IB
1107 ldap = mkLdapOptions "Chloe" {};
1108 };
1109 };
1110 };
1111 in
1112 submodule {
1113 options = {
1114 production = chloeSubmodule;
1115 integration = chloeSubmodule;
1116 };
1117 };
1118 };
1119 connexionswing = mkOption {
1120 description = "Connexionswing configurations by environment";
1121 type =
1122 let
1123 csSubmodule = mkOption {
1124 description = "environment configuration";
1125 type = submodule {
1126 options = {
1127 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1128 mysql = mkMysqlOptions "Connexionswing" {};
ab8f306d
IB
1129 secret = mkOption { type = str; description = "Symfony App secret"; };
1130 email = mkOption { type = str; description = "Symfony email notification"; };
1131 };
1132 };
1133 };
1134 in
1135 submodule {
1136 options = {
1137 production = csSubmodule;
1138 integration = csSubmodule;
1139 };
1140 };
1141 };
1142 jerome = mkOption {
1143 description = "Naturaloutil configuration";
1144 type = submodule {
1145 options = {
87a8bffd 1146 mysql = mkMysqlOptions "Naturaloutil" {};
ab8f306d
IB
1147 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1148 };
1149 };
1150 };
d3452fc5 1151 telio_tortay = mkOption {
ab8f306d
IB
1152 description = "Telio Tortay configuration";
1153 type = submodule {
1154 options = {
1155 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1156 };
1157 };
1158 };
d3452fc5 1159 ludivine = mkOption {
ab8f306d
IB
1160 description = "Ludivinecassal configurations by environment";
1161 type =
1162 let
1163 lcSubmodule = mkOption {
1164 description = "environment configuration";
1165 type = submodule {
1166 options = {
1167 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1168 mysql = mkMysqlOptions "LudivineCassal" {};
ab8f306d
IB
1169 ldap = mkLdapOptions "LudivineCassal" {};
1170 secret = mkOption { type = str; description = "Symfony App secret"; };
1171 };
1172 };
1173 };
1174 in
1175 submodule {
1176 options = {
1177 production = lcSubmodule;
1178 integration = lcSubmodule;
1179 };
1180 };
1181 };
1182 emilia = mkOption {
1183 description = "Emilia configuration";
1184 type = submodule {
1185 options = {
1186 postgresql = mkPsqlOptions "Emilia";
1187 };
1188 };
1189 };
1190 florian = mkOption {
1191 description = "Florian configuration";
1192 type = submodule {
1193 options = {
1194 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1195 };
1196 };
1197 };
1198 nassime = mkOption {
1199 description = "Nassime configuration";
1200 type = submodule {
1201 options = {
1202 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1203 };
1204 };
1205 };
1206 piedsjaloux = mkOption {
1207 description = "Piedsjaloux configurations by environment";
1208 type =
1209 let
1210 pjSubmodule = mkOption {
1211 description = "environment configuration";
1212 type = submodule {
1213 options = {
1214 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1215 mysql = mkMysqlOptions "Piedsjaloux" {};
ab8f306d
IB
1216 secret = mkOption { type = str; description = "Symfony App secret"; };
1217 };
1218 };
1219 };
1220 in
1221 submodule {
1222 options = {
1223 production = pjSubmodule;
1224 integration = pjSubmodule;
1225 };
1226 };
1227 };
91b75ffe
IB
1228 richie = mkOption {
1229 description = "Europe Richie configurations by environment";
1230 type = submodule {
1231 options = {
87a8bffd 1232 mysql = mkMysqlOptions "Richie" {};
91b75ffe
IB
1233 smtp_mailer = mkOption {
1234 description = "SMTP mailer configuration";
1235 type = submodule {
1236 options = {
1237 user = mkOption { type = str; description = "Username"; };
1238 password = mkOption { type = str; description = "Password"; };
1239 };
1240 };
1241 };
1242 };
1243 };
1244 };
ab8f306d
IB
1245 tellesflorian = mkOption {
1246 description = "Tellesflorian configurations by environment";
1247 type =
1248 let
1249 tfSubmodule = mkOption {
1250 description = "environment configuration";
1251 type = submodule {
1252 options = {
1253 environment = mkOption { type = str; description = "Symfony environment"; };
87a8bffd 1254 mysql = mkMysqlOptions "Tellesflorian" {};
ab8f306d
IB
1255 secret = mkOption { type = str; description = "Symfony App secret"; };
1256 invite_passwords = mkOption { type = str; description = "Password basic auth"; };
1257 };
1258 };
1259 };
1260 in
1261 submodule {
1262 options = {
1263 integration = tfSubmodule;
1264 };
1265 };
1266 };
1267 };
1268 };
1269 };
1270
1271 privateFiles = mkOption {
1272 type = path;
1273 description = ''
1274 Path to secret files to make available during build
1275 '';
1276 };
1277 };
619e4f46
IB
1278 options.hostEnv = mkOption {
1279 readOnly = true;
1280 type = hostEnv;
1281 default = config.myEnv.servers."${name}";
1282 description = "Host environment";
ab8f306d
IB
1283 };
1284}