]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - lib/private/default.nix
Upgrade syden peertube to flake
[perso/Immae/Config/Nix.git] / lib / private / default.nix
CommitLineData
fe696f35
IB
1{}:
2{
3 # This adds header colors to the builds, but it rebuilds the whole
4 # world from scratch, so only use it to debug!
5 # add it as postHook in derivations
6 immaePostHook = ''
7 header() {
8 echo -ne "\033[1;36m"
9 echo -n "$1"
10 echo -e "\033[0m"
11 }
12
13 echoCmd() {
14 printf "\033[1;34m%s:\033[0m" "$1"
15 shift
16 printf ' %q' "$@"
17 echo
18 }
19 '';
20}