]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add anonymize for dmarc_reports
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index f7994a1e7894c28be410e9df70382b554f005f11..00026227dba94172a7b14b484e5654f8472d72a9 100644 (file)
@@ -820,6 +820,15 @@ in
               };
             };
           };
+          dmarc_reports = mkOption {
+            description = "DMARC reports configuration";
+            type = submodule {
+              options = {
+                mysql = mkMysqlOptions "DMARC" {};
+                anonymous_key = mkOption { type = str; description = "Anonymous hashing key"; };
+              };
+            };
+          };
           etherpad-lite = mkOption {
             description = "Etherpad configuration";
             type = submodule {