1 { config, lib, name, ... }:
7 base = mkOption { description = "Base of the LDAP tree"; type = str; };
8 host = mkOption { description = "Host to access LDAP"; type = str; };
9 root_dn = mkOption { description = "DN of the root user"; type = str; };
10 root_pw = mkOption { description = "Hashed password of the root user"; type = str; };
11 replication_dn = mkOption { description = "DN of the user allowed to replicate the LDAP directory"; type = str; };
12 replication_pw = mkOption { description = "Password of the user allowed to replicate the LDAP directory"; type = str; };
14 mkLdapOptions = name: more: mkOption {
15 description = "${name} LDAP configuration";
17 options = ldapOptions // {
18 dn = mkOption { description = "DN of the ${name} user"; type = str; };
19 password = mkOption { description = "password of the ${name} user"; type = str; };
20 filter = mkOption { description = "Filter for ${name} users"; type = str; default = ""; };
25 host = mkOption { description = "Host to access Mysql"; type = str; };
26 remoteHost = mkOption { description = "Host to access Mysql from outside"; type = str; };
27 port = mkOption { description = "Port to access Mysql"; type = str; };
28 socket = mkOption { description = "Socket to access Mysql"; type = path; };
29 systemUsers = mkOption {
30 description = "Attrs of user-passwords allowed to access mysql";
34 description = "PAM configuration for mysql";
37 dn = mkOption { description = "DN to connect as to check users"; type = str; };
38 password = mkOption { description = "DN password to connect as to check users"; type = str; };
39 filter = mkOption { description = "filter to match users"; type = str; };
44 mkMysqlOptions = name: more: mkOption {
45 description = "${name} mysql configuration";
47 options = mysqlOptions // {
48 database = mkOption { description = "${name} database"; type = str; };
49 user = mkOption { description = "${name} user"; type = str; };
50 password = mkOption { description = "mysql password of the ${name} user"; type = str; };
55 host = mkOption { description = "Host to access Postgresql"; type = str; };
56 port = mkOption { description = "Port to access Postgresql"; type = str; };
57 socket = mkOption { description = "Socket to access Postgresql"; type = path; };
59 description = "PAM configuration for psql";
62 dn = mkOption { description = "DN to connect as to check users"; type = str; };
63 password = mkOption { description = "DN password to connect as to check users"; type = str; };
64 filter = mkOption { description = "filter to match users"; type = str; };
69 mkPsqlOptions = name: mkOption {
70 description = "${name} psql configuration";
72 options = psqlOptions // {
73 database = mkOption { description = "${name} database"; type = str; };
74 schema = mkOption { description = "${name} schema"; type = nullOr str; default = null; };
75 user = mkOption { description = "${name} user"; type = str; };
76 password = mkOption { description = "psql password of the ${name} user"; type = str; };
81 host = mkOption { description = "Host to access Redis"; type = str; };
82 port = mkOption { description = "Port to access Redis"; type = str; };
83 socket = mkOption { description = "Socket to access Redis"; type = path; };
85 description = "Attrs of db number. Each number should be unique to avoid collision!";
88 spiped_key = mkOption {
91 Key to use with spiped to make a secure channel to replication
95 description = "Predixy configuration. Unused yet";
98 read = mkOption { type = str; description = "Read password"; };
103 mkRedisOptions = name: mkOption {
104 description = "${name} redis configuration";
106 options = redisOptions // {
107 db = mkOption { description = "${name} database"; type = str; };
111 hostEnv = submodule {
114 description = "Host FQDN";
121 Sublist of users from realUsers. Function that takes pkgs as
122 argument and gives an array as a result
127 description = "List of e-mails that the server can be a sender of";
132 LDAP credentials for the host
136 password = mkOption { type = str; description = "Password for the LDAP connection"; };
137 dn = mkOption { type = str; description = "DN for the LDAP connection"; };
142 description = "subdomain and priority for MX server";
143 default = { enable = false; };
146 enable = mkEnableOption "Enable MX";
147 subdomain = mkOption { type = nullOr str; description = "Subdomain name (mx-*)"; };
148 priority = mkOption { type = nullOr str; description = "Priority"; };
154 attrs of ip4/ip6 grouped by section
156 type = attrsOf (submodule {
161 ip4 address of the host
168 ip6 addresses of the host
181 Attrs of servers information in the cluster (not necessarily handled by nixops)
184 type = attrsOf hostEnv;
186 hetznerCloud = mkOption {
188 Hetzner Cloud credential information
192 authToken = mkOption {
203 Hetzner credential information
207 user = mkOption { type = str; description = "User"; };
208 pass = mkOption { type = str; description = "Password"; };
214 sshd service credential information
220 LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
224 password = mkOption { description = "Password"; type = str; };
233 non-standard reserved ports. Must be unique!
238 noDupl = x: builtins.length (builtins.attrValues x) == builtins.length (unique (builtins.attrValues x));
240 x: if isAttrs x && noDupl x then x else throw "Non unique values for ports";
244 httpd service credential information
250 LDAP credentials for cn=httpd,ou=services,dc=immae,dc=eu dn
254 password = mkOption { description = "Password"; type = str; };
263 LDAP server configuration
266 options = ldapOptions;
269 databases = mkOption {
270 description = "Databases configuration";
274 type = submodule { options = mysqlOptions; };
275 description = "Mysql configuration";
278 type = submodule { options = redisOptions; };
279 description = "Redis configuration";
281 postgresql = mkOption {
282 type = submodule { options = psqlOptions; };
283 description = "Postgresql configuration";
289 description = "Jabber configuration";
292 postfix_user_filter = mkOption { type = str; description = "Postfix filter to get xmpp users"; };
293 ldap = mkLdapOptions "Jabber" {};
294 postgresql = mkPsqlOptions "Jabber";
298 realUsers = mkOption {
300 Attrset of function taking pkgs as argument.
301 Real users settings, should provide a subattr of users.users.<name>
302 with at least: name, (hashed)Password, shell
304 type = attrsOf unspecified;
307 description = "System and regular users uid/gid";
308 type = attrsOf (submodule {
311 description = "user uid";
315 description = "user gid";
322 description = "DNS configuration";
326 description = "SOA information";
330 description = "Serial number. Should be incremented at each change and unique";
334 description = "Refresh time";
338 description = "Retry time";
342 description = "Expire time";
346 description = "Default TTL time";
350 description = "hostmaster e-mail";
354 description = "Primary NS";
361 description = "Attrs of NS servers group";
364 "ns1.foo.com" = [ "198.51.100.10" "2001:db8:abcd::1" ];
365 "ns2.foo.com" = [ "198.51.100.15" "2001:db8:1234::1" ];
368 type = attrsOf (attrsOf (listOf str));
370 slaveZones = mkOption {
371 description = "List of slave zones";
372 type = listOf (submodule {
374 name = mkOption { type = str; description = "zone name"; };
376 description = "NS master groups of this zone";
382 masterZones = mkOption {
383 description = "List of master zones";
384 type = listOf (submodule {
386 name = mkOption { type = str; description = "zone name"; };
388 description = "NS slave groups of this zone";
392 description = "groups names that should have their NS entries listed here";
396 description = "Extra zone configuration for bind";
402 entries = mkOption { type = lines; description = "Regular entries of the NS zone"; };
403 withEmail = mkOption {
404 description = "List of domains that should have mail entries (MX, dkim, SPF, ...)";
406 type = listOf (submodule {
408 domain = mkOption { type = str; description = "Which subdomain is concerned"; };
409 send = mkOption { type = bool; description = "Whether there can be e-mails originating from the subdomain"; };
410 receive = mkOption { type = bool; description = "Whether there can be e-mails arriving to the subdomain"; };
422 Remote backup with duplicity
426 password = mkOption { type = str; description = "Password for encrypting files"; };
427 remote = mkOption { type = str; description = "Remote url access"; };
428 accessKeyId = mkOption { type = str; description = "Remote access-key"; };
429 secretAccessKey = mkOption { type = str; description = "Remote access secret"; };
433 rsync_backup = mkOption {
435 Rsync backup configuration from controlled host
440 description = "SSH key information";
443 public = mkOption { type = str; description = "Public part of the key"; };
444 private = mkOption { type = lines; description = "Private part of the key"; };
448 profiles = mkOption {
449 description = "Attrs of profiles to backup";
450 type = attrsOf (submodule {
452 keep = mkOption { type = int; description = "Number of backups to keep"; };
453 login = mkOption { type = str; description = "Login to connect to host"; };
454 port = mkOption { type = str; default = "22"; description = "Port to connect to host"; };
455 host = mkOption { type = str; description = "Host to connect to"; };
456 host_key = mkOption { type = str; description = "Host key"; };
457 host_key_type = mkOption { type = str; description = "Host key type"; };
459 description = "Parts to backup for this host";
460 type = attrsOf (submodule {
462 remote_folder = mkOption { type = path; description = "Remote folder to backup";};
463 exclude_from = mkOption {
466 description = "List of folders/files to exclude from the backup";
468 files_from = mkOption {
471 description = "List of folders/files to backup in the base folder";
476 description = "Extra arguments to pass to rsync";
487 monitoring = mkOption {
488 description = "Monitoring configuration";
491 status_url = mkOption { type = str; description = "URL to push status to"; };
492 status_token = mkOption { type = str; description = "Token for the status url"; };
493 http_user_password = mkOption { type = str; description = "HTTP credentials to check services behind wall"; };
494 email = mkOption { type = str; description = "Admin E-mail"; };
495 ssh_public_key = mkOption { type = str; description = "SSH public key"; };
496 ssh_secret_key = mkOption { type = str; description = "SSH secret key"; };
497 imap_login = mkOption { type = str; description = "IMAP login"; };
498 imap_password = mkOption { type = str; description = "IMAP password"; };
499 eriomem_keys = mkOption { type = listOf (listOf str); description = "Eriomem keys"; default = []; };
501 description = "OVH credentials for sms script";
504 endpoint = mkOption { type = str; default = "ovh-eu"; description = "OVH endpoint"; };
505 application_key = mkOption { type = str; description = "Application key"; };
506 application_secret = mkOption { type = str; description = "Application secret"; };
507 consumer_key = mkOption { type = str; description = "Consumer key"; };
508 account = mkOption { type = str; description = "Account"; };
512 nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
513 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
514 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
515 contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
516 email_check = mkOption {
517 description = "Emails services to check";
518 type = attrsOf (submodule {
520 local = mkOption { type = bool; default = false; description = "Use local configuration"; };
521 port = mkOption { type = nullOr str; default = null; description = "Port to connect to ssh"; };
522 login = mkOption { type = nullOr str; default = null; description = "Login to connect to ssh"; };
523 targets = mkOption { type = listOf str; description = "Hosts to send E-mails to"; };
524 mail_address = mkOption { type = nullOr str; default = null; description = "E-mail recipient part to send e-mail to"; };
525 mail_domain = mkOption { type = nullOr str; default = null; description = "E-mail domain part to send e-mail to"; };
533 description = "MPD configuration";
536 folder = mkOption { type = str; description = "Folder to serve from the MPD instance"; };
537 password = mkOption { type = str; description = "Password to connect to the MPD instance"; };
538 host = mkOption { type = str; description = "Host to connect to the MPD instance"; };
539 port = mkOption { type = str; description = "Port to connect to the MPD instance"; };
544 description = "FTP configuration";
547 ldap = mkLdapOptions "FTP" {};
552 description = "VPN configuration";
553 type = attrsOf (submodule {
555 prefix = mkOption { type = str; description = "ipv6 prefix for the vpn subnet"; };
556 privateKey = mkOption { type = str; description = "Private key for the host"; };
557 publicKey = mkOption { type = str; description = "Public key for the host"; };
562 description = "Mail configuration";
566 description = "DMARC configuration";
569 ignore_hosts = mkOption {
572 Hosts to ignore when checking for dmarc
579 description = "DKIM configuration";
580 type = attrsOf (submodule {
586 "p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQC3w1a2aMxWw9+hdcmbqX4UevcVqr204y0K73Wdc7MPZiOOlUJQYsMNSYR1Y/SC7jmPKeitpcJCpQgn/cveJZbuikjjPLsDReHyFEYmC278ZLRTELHx6f1IXM8WE08JIRT69CfZiMi1rVcOh9qRT4F93PyjCauU8Y5hJjtg9ThsWwIDAQAB" )
588 description = "Public entry to put in DNS TXT field";
590 private = mkOption { type = str; description = "Private key"; };
595 description = "Postfix configuration";
598 additional_mailbox_domains = mkOption {
600 List of domains that are used as mailbox final destination, in addition to those defined in the DNS records
604 mysql = mkMysqlOptions "Postfix" {
605 password_encrypt = mkOption { type = str; description = "Key to encrypt relay password in database"; };
607 backup_domains = mkOption {
609 Domains that are accepted for relay as backup domain
611 type = attrsOf (submodule {
613 domains = mkOption { type = listOf str; description = "Domains list"; };
614 relay_restrictions = mkOption {
617 Restrictions for relaying the e-mails from the domains
620 recipient_maps = mkOption {
622 Recipient map to accept relay for.
623 Must be specified for domain, the rules apply to everyone!
625 type = listOf (submodule {
628 type = enum [ "hash" ];
629 description = "Map type";
633 description = "Map content";
645 description = "Dovecot configuration";
648 ldap = mkLdapOptions "Dovecot" {
649 pass_attrs = mkOption { type = str; description = "Password attribute in LDAP"; };
650 user_attrs = mkOption { type = str; description = "User attribute mapping in LDAP"; };
651 iterate_attrs = mkOption { type = str; description = "User attribute mapping for listing in LDAP"; };
652 iterate_filter = mkOption { type = str; description = "User attribute filter for listing in LDAP"; };
658 description = "rspamd configuration";
661 redis = mkRedisOptions "Redis";
662 read_password_hashed = mkOption { type = str; description = "Hashed read password for rspamd"; };
663 write_password_hashed = mkOption { type = str; description = "Hashed write password for rspamd"; };
664 read_password = mkOption {
666 description = "Read password for rspamd. Unused";
669 write_password = mkOption {
671 description = "Write password for rspamd. Unused";
678 description = "Mail script recipients";
679 type = attrsOf (submodule {
681 external = mkEnableOption "Create a script_<name>@mail.immae.eu external address";
684 git source to fetch the script from.
685 It must have a default.nix file as its root accepting a scriptEnv parameter
689 url = mkOption { type = str; description = "git url to fetch"; };
690 rev = mkOption { type = str; description = "git reference to fetch"; };
695 description = "Variables to pass to the script";
704 buildbot = mkOption {
705 description = "Buildbot configuration";
709 description = "Buildbot user";
713 description = "user uid";
717 description = "user gid";
724 description = "Ldap configuration for buildbot";
727 password = mkOption { type = str; description = "Buildbot password"; };
731 projects = mkOption {
732 description = "Projects to make a buildbot for";
733 type = attrsOf (submodule {
735 name = mkOption { type = str; description = "Project name"; };
736 packages = mkOption {
738 example = literalExample ''
739 pkgs: [ pkgs.bash pkgs.git pkgs.gzip pkgs.openssh ];
743 Builds packages list to make available to buildbot project.
744 Takes pkgs as argument.
747 pythonPackages = mkOption {
749 example = literalExample ''
750 p: pkgs: [ pkgs.python3Packages.pip ];
754 Builds python packages list to make available to buildbot project.
755 Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
758 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
761 description = "Secrets for the project to dump as files";
763 environment = mkOption {
766 Environment variables for the project.
767 BUILDBOT_ is prefixed to the variable names
770 activationScript = mkOption {
773 Activation script to run during deployment
776 builderPaths = mkOption {
777 type = attrsOf unspecified;
780 Attrs of functions to make accessible specifically per builder.
781 Takes pkgs as argument and should return a single path containing binaries.
782 This path will be accessible as BUILDBOT_PATH_<attrskey>
785 webhookTokens = mkOption {
786 type = nullOr (listOf str);
789 List of tokens allowed to push to project’s change_hook/base endpoint
799 description = "Tools configurations";
802 contact = mkOption { type = str; description = "Contact e-mail address"; };
804 description = "Davical configuration";
807 postgresql = mkPsqlOptions "Davical";
808 ldap = mkLdapOptions "Davical" {};
812 diaspora = mkOption {
813 description = "Diaspora configuration";
816 postgresql = mkPsqlOptions "Diaspora";
817 redis = mkRedisOptions "Diaspora";
818 ldap = mkLdapOptions "Diaspora" {};
819 secret_token = mkOption { type = str; description = "Secret token"; };
823 dmarc_reports = mkOption {
824 description = "DMARC reports configuration";
827 mysql = mkMysqlOptions "DMARC" {};
828 anonymous_key = mkOption { type = str; description = "Anonymous hashing key"; };
832 etherpad-lite = mkOption {
833 description = "Etherpad configuration";
836 postgresql = mkPsqlOptions "Etherpad";
837 ldap = mkLdapOptions "Etherpad" {
838 group_filter = mkOption { type = str; description = "Filter for groups"; };
840 session_key = mkOption { type = str; description = "Session key"; };
841 api_key = mkOption { type = str; description = "API key"; };
842 redirects = mkOption { type = str; description = "Redirects for apache"; };
846 gitolite = mkOption {
847 description = "Gitolite configuration";
850 ldap = mkLdapOptions "Gitolite" {};
854 kanboard = mkOption {
855 description = "Kanboard configuration";
858 postgresql = mkPsqlOptions "Kanboard";
859 ldap = mkLdapOptions "Kanboard" {
860 admin_dn = mkOption { type = str; description = "Admin DN"; };
865 mantisbt = mkOption {
866 description = "Mantisbt configuration";
869 postgresql = mkPsqlOptions "Mantisbt";
870 ldap = mkLdapOptions "Mantisbt" {};
871 master_salt = mkOption { type = str; description = "Master salt for password hash"; };
875 mastodon = mkOption {
876 description = "Mastodon configuration";
879 postgresql = mkPsqlOptions "Mastodon";
880 redis = mkRedisOptions "Mastodon";
881 ldap = mkLdapOptions "Mastodon" {};
882 paperclip_secret = mkOption { type = str; description = "Paperclip secret"; };
883 otp_secret = mkOption { type = str; description = "OTP secret"; };
884 secret_key_base = mkOption { type = str; description = "Secret key base"; };
886 description = "vapid key";
889 private = mkOption { type = str; description = "Private key"; };
890 public = mkOption { type = str; description = "Public key"; };
897 mediagoblin = mkOption {
898 description = "Mediagoblin configuration";
901 postgresql = mkPsqlOptions "Mediagoblin";
902 redis = mkRedisOptions "Mediagoblin";
903 ldap = mkLdapOptions "Mediagoblin" {};
907 nextcloud = mkOption {
908 description = "Nextcloud configuration";
911 postgresql = mkPsqlOptions "Peertube";
912 redis = mkRedisOptions "Peertube";
913 password_salt = mkOption { type = str; description = "Password salt"; };
914 instance_id = mkOption { type = str; description = "Instance ID"; };
915 secret = mkOption { type = str; description = "App secret"; };
919 peertube = mkOption {
920 description = "Peertube configuration";
923 listenPort = mkOption { type = port; description = "Port to listen to"; };
924 postgresql = mkPsqlOptions "Peertube";
925 redis = mkRedisOptions "Peertube";
926 ldap = mkLdapOptions "Peertube" {};
930 syden_peertube = mkOption {
931 description = "Peertube Syden configuration";
934 listenPort = mkOption { type = port; description = "Port to listen to"; };
935 postgresql = mkPsqlOptions "Peertube";
936 redis = mkRedisOptions "Peertube";
940 phpldapadmin = mkOption {
941 description = "phpLdapAdmin configuration";
944 ldap = mkLdapOptions "phpldapadmin" {};
949 description = "Rompr configuration";
953 description = "MPD configuration";
956 host = mkOption { type = str; description = "Host for MPD"; };
957 port = mkOption { type = port; description = "Port to access MPD host"; };
964 roundcubemail = mkOption {
965 description = "Roundcubemail configuration";
968 postgresql = mkPsqlOptions "TT-RSS";
969 secret = mkOption { type = str; description = "Secret"; };
974 description = "Shaarli configuration";
977 ldap = mkLdapOptions "Shaarli" {};
982 description = "Taskwarrior configuration";
985 ldap = mkLdapOptions "Taskwarrior" {};
986 taskwarrior-web = mkOption {
987 description = "taskwarrior-web profiles";
988 type = attrsOf (submodule {
992 description = "List of ldap uids having access to this profile";
994 org = mkOption { type = str; description = "Taskd organisation"; };
995 key = mkOption { type = str; description = "Taskd key"; };
996 date = mkOption { type = str; description = "Preferred date format"; };
1004 description = "TT-RSS configuration";
1007 postgresql = mkPsqlOptions "TT-RSS";
1008 ldap = mkLdapOptions "TT-RSS" {};
1012 wallabag = mkOption {
1013 description = "Wallabag configuration";
1016 postgresql = mkPsqlOptions "Wallabag";
1017 ldap = mkLdapOptions "Wallabag" {
1018 admin_filter = mkOption { type = str; description = "Admin users filter"; };
1020 redis = mkRedisOptions "Wallabag";
1021 secret = mkOption { type = str; description = "App secret"; };
1025 webhooks = mkOption {
1027 description = "Mapping 'name'.php => script for webhooks";
1030 description = "Ympd configuration";
1033 listenPort = mkOption { type = port; description = "Port to listen to"; };
1035 description = "MPD configuration";
1038 password = mkOption { type = str; description = "Password to access MPD host"; };
1039 host = mkOption { type = str; description = "Host for MPD"; };
1040 port = mkOption { type = port; description = "Port to access MPD host"; };
1048 description = "Yourls configuration";
1051 mysql = mkMysqlOptions "Yourls" {};
1052 ldap = mkLdapOptions "Yourls" {};
1053 cookieKey = mkOption { type = str; description = "Cookie key"; };
1060 websites = mkOption {
1061 description = "Websites configurations";
1064 isabelle = mkOption {
1065 description = "Isabelle configurations by environment";
1068 atenSubmodule = mkOption {
1069 description = "environment configuration";
1072 environment = mkOption { type = str; description = "Symfony environment"; };
1073 secret = mkOption { type = str; description = "Symfony App secret"; };
1074 postgresql = mkPsqlOptions "Aten";
1081 aten_production = atenSubmodule;
1082 aten_integration = atenSubmodule;
1083 iridologie = mkOption {
1084 description = "environment configuration";
1087 environment = mkOption { type = str; description = "SPIP environment"; };
1088 mysql = mkMysqlOptions "Iridologie" {};
1089 ldap = mkLdapOptions "Iridologie" {};
1097 description = "Chloe configurations by environment";
1100 chloeSubmodule = mkOption {
1101 description = "environment configuration";
1104 environment = mkOption { type = str; description = "SPIP environment"; };
1105 mysql = mkMysqlOptions "Chloe" {};
1106 ldap = mkLdapOptions "Chloe" {};
1113 production = chloeSubmodule;
1114 integration = chloeSubmodule;
1118 connexionswing = mkOption {
1119 description = "Connexionswing configurations by environment";
1122 csSubmodule = mkOption {
1123 description = "environment configuration";
1126 environment = mkOption { type = str; description = "Symfony environment"; };
1127 mysql = mkMysqlOptions "Connexionswing" {};
1128 secret = mkOption { type = str; description = "Symfony App secret"; };
1129 email = mkOption { type = str; description = "Symfony email notification"; };
1136 production = csSubmodule;
1137 integration = csSubmodule;
1142 description = "Naturaloutil configuration";
1145 mysql = mkMysqlOptions "Naturaloutil" {};
1146 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1150 telio_tortay = mkOption {
1151 description = "Telio Tortay configuration";
1154 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1158 ludivine = mkOption {
1159 description = "Ludivinecassal configurations by environment";
1162 lcSubmodule = mkOption {
1163 description = "environment configuration";
1166 environment = mkOption { type = str; description = "Symfony environment"; };
1167 mysql = mkMysqlOptions "LudivineCassal" {};
1168 ldap = mkLdapOptions "LudivineCassal" {};
1169 secret = mkOption { type = str; description = "Symfony App secret"; };
1176 production = lcSubmodule;
1177 integration = lcSubmodule;
1182 description = "Emilia configuration";
1185 postgresql = mkPsqlOptions "Emilia";
1189 florian = mkOption {
1190 description = "Florian configuration";
1193 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1197 nassime = mkOption {
1198 description = "Nassime configuration";
1201 server_admin = mkOption { type = str; description = "Server admin e-mail"; };
1205 piedsjaloux = mkOption {
1206 description = "Piedsjaloux configurations by environment";
1209 pjSubmodule = mkOption {
1210 description = "environment configuration";
1213 environment = mkOption { type = str; description = "Symfony environment"; };
1214 mysql = mkMysqlOptions "Piedsjaloux" {};
1215 secret = mkOption { type = str; description = "Symfony App secret"; };
1222 production = pjSubmodule;
1223 integration = pjSubmodule;
1228 description = "Europe Richie configurations by environment";
1231 mysql = mkMysqlOptions "Richie" {};
1232 smtp_mailer = mkOption {
1233 description = "SMTP mailer configuration";
1236 user = mkOption { type = str; description = "Username"; };
1237 password = mkOption { type = str; description = "Password"; };
1244 tellesflorian = mkOption {
1245 description = "Tellesflorian configurations by environment";
1248 tfSubmodule = mkOption {
1249 description = "environment configuration";
1252 environment = mkOption { type = str; description = "Symfony environment"; };
1253 mysql = mkMysqlOptions "Tellesflorian" {};
1254 secret = mkOption { type = str; description = "Symfony App secret"; };
1255 invite_passwords = mkOption { type = str; description = "Password basic auth"; };
1262 integration = tfSubmodule;
1270 privateFiles = mkOption {
1273 Path to secret files to make available during build
1277 options.hostEnv = mkOption {
1280 default = config.myEnv.servers."${name}";
1281 description = "Host environment";