]>
Commit | Line | Data |
---|---|---|
1 | { stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, bitlbee, glib, lib }: | |
2 | stdenv.mkDerivation rec { | |
3 | name = "bitlbee-mastodon-${version}"; | |
4 | version = "v1.4.2"; | |
5 | ||
6 | src = fetchFromGitHub { | |
7 | rev = version; | |
8 | owner = "kensanata"; | |
9 | repo = "bitlbee-mastodon"; | |
10 | sha256 = "04rakgr1pfsg1vhfwlfbggbzw249j7dmk88xrsnf3n84c5ccdyas"; | |
11 | }; | |
12 | ||
13 | nativeBuildInputs = [ autoreconfHook pkgconfig ]; | |
14 | buildInputs = [ bitlbee glib ]; | |
15 | ||
16 | preConfigure = '' | |
17 | export BITLBEE_PLUGINDIR=$out/lib/bitlbee | |
18 | ./autogen.sh | |
19 | ''; | |
20 | ||
21 | meta = { | |
22 | description = "Bitlbee plugin for Mastodon"; | |
23 | ||
24 | homepage = https://github.com/kensanata/bitlbee-mastodon; | |
25 | license = lib.licenses.gpl2Plus; | |
26 | platforms = lib.platforms.linux; | |
27 | }; | |
28 | } |