]>
Commit | Line | Data |
---|---|---|
1 | self: super: | |
2 | { | |
3 | taskwarrior = super.taskwarrior.overrideAttrs (old: { | |
4 | patches = old.patches or [] ++ [ | |
5 | ./TW-1778_patch.diff | |
6 | ]; | |
7 | postInstall = ''${old.postInstall} | |
8 | mkdir -p "$out/share/vim/vimfiles/ftdetect" | |
9 | mkdir -p "$out/share/vim/vimfiles/syntax" | |
10 | ln -s "../../../../share/doc/task/scripts/vim/ftdetect/task.vim" "$out/share/vim/vimfiles/ftdetect/" | |
11 | ln -s "../../../../share/doc/task/scripts/vim/syntax/taskrc.vim" "$out/share/vim/vimfiles/syntax/" | |
12 | ln -s "../../../../share/doc/task/scripts/vim/syntax/taskdata.vim" "$out/share/vim/vimfiles/syntax/" | |
13 | ln -s "../../../../share/doc/task/scripts/vim/syntax/taskedit.vim" "$out/share/vim/vimfiles/syntax/" | |
14 | ''; | |
15 | }); | |
16 | } |