]>
Commit | Line | Data |
---|---|---|
24fd1fe6 IB |
1 | { stdenv, fetchurl, mpfr, glib, hicolor-icon-theme, gtk2, intltool, gnome-doc-utils, python3, gnome2, autoconf, automake, libtool, ncurses, readline, pkg-config, }: |
2 | stdenv.mkDerivation rec { | |
3 | name = "genius-${version}"; | |
4 | version = "1.0.24"; | |
5 | src = fetchurl { | |
6 | url = "https://download.gnome.org/sources/genius/1.0/${name}.tar.xz"; | |
7 | sha256 = "772f95f6ae4716d39bb180cd50e8b6b9b074107bee0cd083b825e1e6e55916b6"; | |
8 | }; | |
9 | buildInputs = [ | |
10 | mpfr glib hicolor-icon-theme gtk2 intltool gnome-doc-utils python3 gnome2.gtksourceview | |
11 | autoconf automake libtool ncurses readline pkg-config | |
12 | ]; | |
13 | preConfigure = '' | |
14 | autoreconf -fi | |
15 | ''; | |
16 | preBuild = '' | |
17 | sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool | |
18 | ''; | |
19 | } |