]>
Commit | Line | Data |
---|---|---|
f8026b6e IB |
1 | let |
2 | set = { | |
581c499c | 3 | # adatped from nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix |
6c97d2d7 IB |
4 | httpdInte = import ../websites/httpd-service-builder.nix { httpdName = "Inte"; withUsers = false; }; |
5 | httpdProd = import ../websites/httpd-service-builder.nix { httpdName = "Prod"; withUsers = false; }; | |
6 | httpdTools = import ../websites/httpd-service-builder.nix { httpdName = "Tools"; withUsers = true; }; | |
182ae57f IB |
7 | |
8 | databases = ./databases; | |
9 | mariadb = ./databases/mariadb.nix; | |
10 | openldap = ./databases/openldap; | |
11 | postgresql = ./databases/postgresql.nix; | |
12 | redis = ./databases/redis.nix; | |
ec9b6564 | 13 | postgresqlReplication = ./databases/postgresql_replication.nix; |
9f6a7862 | 14 | mariadbReplication = ./databases/mariadb_replication.nix; |
dded6699 | 15 | redisReplication = ./databases/redis_replication.nix; |
16b80abd | 16 | openldapReplication = ./databases/openldap_replication.nix; |
ffb14c1c | 17 | |
f8026b6e | 18 | websites = ./websites; |
d3452fc5 IB |
19 | |
20 | ||
21 | # Personal websites | |
22 | capitainesLandingPages = ./websites/capitaines/landing_pages.nix; | |
23 | ||
f8026b6e IB |
24 | chloeInte = ./websites/chloe/integration.nix; |
25 | chloeProd = ./websites/chloe/production.nix; | |
d3452fc5 | 26 | |
6c7d42fc IB |
27 | cipcaSympa = ./websites/cip-ca/sympa.nix; |
28 | ||
f8026b6e IB |
29 | connexionswingInte = ./websites/connexionswing/integration.nix; |
30 | connexionswingProd = ./websites/connexionswing/production.nix; | |
d3452fc5 IB |
31 | |
32 | deniseDenisejeromeProd = ./websites/denise/denisejerome.nix; | |
33 | deniseEvariste = ./websites/denise/evariste.nix; | |
a295d69f IB |
34 | deniseOMS = ./websites/denise/oms.nix; |
35 | deniseProduction = ./websites/denise/production.nix; | |
d3452fc5 IB |
36 | |
37 | emiliaMoodle = ./websites/emilia/moodle.nix; | |
38 | ||
f8026b6e IB |
39 | florianApp = ./websites/florian/app.nix; |
40 | florianInte = ./websites/florian/integration.nix; | |
41 | florianProd = ./websites/florian/production.nix; | |
d3452fc5 | 42 | |
f8026b6e IB |
43 | immaeProd = ./websites/immae/production.nix; |
44 | immaeRelease = ./websites/immae/release.nix; | |
45 | immaeTemp = ./websites/immae/temp.nix; | |
d3452fc5 IB |
46 | |
47 | isabelleAtenInte = ./websites/isabelle/aten_integration.nix; | |
48 | isabelleAtenProd = ./websites/isabelle/aten_production.nix; | |
49 | isabelleIridologie = ./websites/isabelle/iridologie.nix; | |
50 | ||
51 | jeromeNaturaloutil = ./websites/jerome/naturaloutil.nix; | |
52 | ||
f8026b6e | 53 | leilaProd = ./websites/leila/production.nix; |
d3452fc5 IB |
54 | |
55 | ludivineInte = ./websites/ludivine/integration.nix; | |
56 | ludivineProd = ./websites/ludivine/production.nix; | |
57 | ||
f8026b6e | 58 | nassimeProd = ./websites/nassime/production.nix; |
d3452fc5 | 59 | |
8722d693 IB |
60 | nathanaelVillon = ./websites/nathanael/villon.nix; |
61 | ||
9a414bd6 | 62 | papaMaisonBbc = ./websites/papa/maison_bbc.nix; |
f8026b6e | 63 | papaSurveillance = ./websites/papa/surveillance.nix; |
d3452fc5 | 64 | |
f8026b6e IB |
65 | piedsjalouxInte = ./websites/piedsjaloux/integration.nix; |
66 | piedsjalouxProd = ./websites/piedsjaloux/production.nix; | |
d3452fc5 IB |
67 | |
68 | richieProd = ./websites/richie/production.nix; | |
69 | ||
8a05c7fb | 70 | sydenPeertube = ./websites/syden/peertube.nix; |
f8026b6e | 71 | |
d3452fc5 IB |
72 | teliotortayProd = ./websites/telio_tortay/production.nix; |
73 | ||
74 | # Tools | |
4288c2f2 | 75 | cloudTool = ./websites/tools/cloud; |
6338573a | 76 | commentoTool = ./websites/tools/commento; |
4288c2f2 | 77 | davTool = ./websites/tools/dav; |
ea9c6fe8 | 78 | vpnTool = ./websites/tools/vpn; |
4288c2f2 IB |
79 | dbTool = ./websites/tools/db; |
80 | diasporaTool = ./websites/tools/diaspora; | |
81 | etherTool = ./websites/tools/ether; | |
82 | gitTool = ./websites/tools/git; | |
3f453c7d | 83 | imTool = ./websites/tools/im; |
4288c2f2 IB |
84 | mastodonTool = ./websites/tools/mastodon; |
85 | mgoblinTool = ./websites/tools/mgoblin; | |
86 | peertubeTool = ./websites/tools/peertube; | |
a97118c4 | 87 | performanceTool = ./websites/tools/performance; |
4288c2f2 | 88 | toolsTool = ./websites/tools/tools; |
afcc5de0 | 89 | mailTool = ./websites/tools/mail; |
4288c2f2 | 90 | |
de6002a1 IB |
91 | # Games |
92 | codenamesGame = ./websites/tools/games/codenames; | |
93 | ||
a929614f | 94 | mail = ./mail; |
a929614f | 95 | |
8d213e2b IB |
96 | buildbot = ./buildbot; |
97 | certificates = ./certificates.nix; | |
98 | gitolite = ./gitolite; | |
ffb14c1c | 99 | irc = ./irc.nix; |
8d213e2b IB |
100 | pub = ./pub; |
101 | tasks = ./tasks; | |
102 | dns = ./dns.nix; | |
103 | ftp = ./ftp.nix; | |
8d213e2b | 104 | mpd = ./mpd.nix; |
3f453c7d | 105 | ejabberd = ./ejabberd; |
8d213e2b | 106 | ssh = ./ssh; |
3bc32d9e | 107 | monitoring = ./monitoring; |
6e9f30f4 | 108 | status = ./monitoring/status.nix; |
a97118c4 | 109 | status_engine = ./monitoring/status_engine.nix; |
ea9c6fe8 | 110 | vpn = ./vpn; |
8d213e2b | 111 | |
ab8f306d | 112 | environment = ./environment.nix; |
8d213e2b | 113 | system = ./system.nix; |
7f286353 | 114 | loginctl-linger = ./loginctl-linger.nix; |
f8026b6e IB |
115 | }; |
116 | in | |
117 | builtins.listToAttrs (map (attr: { name = "priv${attr}"; value = set.${attr}; }) (builtins.attrNames set)) |