]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/default.nix
Add cip-ca mail website
[perso/Immae/Config/Nix.git] / modules / private / default.nix
CommitLineData
f8026b6e
IB
1let
2set = {
581c499c 3 # adatped from nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
6c97d2d7
IB
4 httpdInte = import ../websites/httpd-service-builder.nix { httpdName = "Inte"; withUsers = false; };
5 httpdProd = import ../websites/httpd-service-builder.nix { httpdName = "Prod"; withUsers = false; };
6 httpdTools = import ../websites/httpd-service-builder.nix { httpdName = "Tools"; withUsers = true; };
182ae57f
IB
7
8 databases = ./databases;
9 mariadb = ./databases/mariadb.nix;
10 openldap = ./databases/openldap;
11 postgresql = ./databases/postgresql.nix;
12 redis = ./databases/redis.nix;
ec9b6564 13 postgresqlReplication = ./databases/postgresql_replication.nix;
9f6a7862 14 mariadbReplication = ./databases/mariadb_replication.nix;
dded6699 15 redisReplication = ./databases/redis_replication.nix;
16b80abd 16 openldapReplication = ./databases/openldap_replication.nix;
ffb14c1c 17
f8026b6e 18 websites = ./websites;
d3452fc5
IB
19
20
21 # Personal websites
22 capitainesLandingPages = ./websites/capitaines/landing_pages.nix;
23
f8026b6e
IB
24 chloeInte = ./websites/chloe/integration.nix;
25 chloeProd = ./websites/chloe/production.nix;
d3452fc5 26
6c7d42fc
IB
27 cipcaSympa = ./websites/cip-ca/sympa.nix;
28
f8026b6e
IB
29 connexionswingInte = ./websites/connexionswing/integration.nix;
30 connexionswingProd = ./websites/connexionswing/production.nix;
d3452fc5
IB
31
32 deniseDenisejeromeProd = ./websites/denise/denisejerome.nix;
33 deniseEvariste = ./websites/denise/evariste.nix;
34
35 emiliaMoodle = ./websites/emilia/moodle.nix;
36
f8026b6e
IB
37 florianApp = ./websites/florian/app.nix;
38 florianInte = ./websites/florian/integration.nix;
39 florianProd = ./websites/florian/production.nix;
d3452fc5 40
f8026b6e
IB
41 immaeProd = ./websites/immae/production.nix;
42 immaeRelease = ./websites/immae/release.nix;
43 immaeTemp = ./websites/immae/temp.nix;
d3452fc5
IB
44
45 isabelleAtenInte = ./websites/isabelle/aten_integration.nix;
46 isabelleAtenProd = ./websites/isabelle/aten_production.nix;
47 isabelleIridologie = ./websites/isabelle/iridologie.nix;
48
49 jeromeNaturaloutil = ./websites/jerome/naturaloutil.nix;
50
f8026b6e 51 leilaProd = ./websites/leila/production.nix;
d3452fc5
IB
52
53 ludivineInte = ./websites/ludivine/integration.nix;
54 ludivineProd = ./websites/ludivine/production.nix;
55
f8026b6e 56 nassimeProd = ./websites/nassime/production.nix;
d3452fc5 57
8722d693
IB
58 nathanaelVillon = ./websites/nathanael/villon.nix;
59
9a414bd6 60 papaMaisonBbc = ./websites/papa/maison_bbc.nix;
f8026b6e 61 papaSurveillance = ./websites/papa/surveillance.nix;
d3452fc5 62
f8026b6e
IB
63 piedsjalouxInte = ./websites/piedsjaloux/integration.nix;
64 piedsjalouxProd = ./websites/piedsjaloux/production.nix;
d3452fc5
IB
65
66 richieProd = ./websites/richie/production.nix;
67
8a05c7fb 68 sydenPeertube = ./websites/syden/peertube.nix;
f8026b6e 69
d3452fc5
IB
70 teliotortayProd = ./websites/telio_tortay/production.nix;
71
72 # Tools
4288c2f2
IB
73 cloudTool = ./websites/tools/cloud;
74 davTool = ./websites/tools/dav;
ea9c6fe8 75 vpnTool = ./websites/tools/vpn;
4288c2f2
IB
76 dbTool = ./websites/tools/db;
77 diasporaTool = ./websites/tools/diaspora;
78 etherTool = ./websites/tools/ether;
79 gitTool = ./websites/tools/git;
3f453c7d 80 imTool = ./websites/tools/im;
4288c2f2
IB
81 mastodonTool = ./websites/tools/mastodon;
82 mgoblinTool = ./websites/tools/mgoblin;
83 peertubeTool = ./websites/tools/peertube;
84 toolsTool = ./websites/tools/tools;
afcc5de0 85 mailTool = ./websites/tools/mail;
4288c2f2 86
de6002a1
IB
87 # Games
88 codenamesGame = ./websites/tools/games/codenames;
89
a929614f 90 mail = ./mail;
a929614f 91
8d213e2b
IB
92 buildbot = ./buildbot;
93 certificates = ./certificates.nix;
94 gitolite = ./gitolite;
ffb14c1c 95 irc = ./irc.nix;
8d213e2b
IB
96 pub = ./pub;
97 tasks = ./tasks;
98 dns = ./dns.nix;
99 ftp = ./ftp.nix;
8d213e2b 100 mpd = ./mpd.nix;
3f453c7d 101 ejabberd = ./ejabberd;
8d213e2b 102 ssh = ./ssh;
3bc32d9e 103 monitoring = ./monitoring;
6e9f30f4 104 status = ./monitoring/status.nix;
ea9c6fe8 105 vpn = ./vpn;
8d213e2b 106
ab8f306d 107 environment = ./environment.nix;
8d213e2b 108 system = ./system.nix;
7f286353 109 loginctl-linger = ./loginctl-linger.nix;
f8026b6e
IB
110};
111in
112builtins.listToAttrs (map (attr: { name = "priv${attr}"; value = set.${attr}; }) (builtins.attrNames set))