]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/buildbot/default.nix
Flake webapps
[perso/Immae/Config/Nix.git] / modules / private / buildbot / default.nix
CommitLineData
ab8f306d 1{ lib, pkgs, config, ... }:
9fb4205e
IB
2let
3 varDir = "/var/lib/buildbot";
bc0f9fcf
IB
4 bb-python = buildbot.pythonModule;
5 buildbot = pkgs.immae-buildbot;
9fb4205e
IB
6in
7{
8 options = {
8d213e2b 9 myServices.buildbot.enable = lib.mkOption {
9fb4205e
IB
10 type = lib.types.bool;
11 default = false;
12 description = ''
13 Whether to enable buildbot.
14 '';
15 };
16 };
17
8d213e2b 18 config = lib.mkIf config.myServices.buildbot.enable {
f6e48e3a
IB
19 nixpkgs.overlays = [
20 (self: super: {
21 follow-systemd-unit = self.writeScriptBin "follow-systemd-unit" ''
22 #!${self.stdenv.shell}
23
24 set -euo pipefail
25
26 service=$1
27 before_invocation_id=$2
28
29 get_id() {
30 systemctl show -p InvocationID --value "$service"
31 }
32
33 while [ "$(get_id)" = "$before_invocation_id" ]; do sleep 1; done
34
35 invocation_id="$(get_id)"
36 cursor="$(mktemp)"
37 trap "rm -f $cursor" EXIT
38
39 get_logs() {
40 journalctl --quiet --cursor-file=$cursor INVOCATION_ID=$invocation_id + _SYSTEMD_INVOCATION_ID=$invocation_id
41 }
42
43 while [ -n "$(systemctl show -p Job --value "$service")" ]; do
44 get_logs
45 done
46 get_logs
47 '';
48 })
49 ];
ab8f306d
IB
50 ids.uids.buildbot = config.myEnv.buildbot.user.uid;
51 ids.gids.buildbot = config.myEnv.buildbot.user.gid;
9fb4205e
IB
52
53 users.groups.buildbot.gid = config.ids.gids.buildbot;
54 users.users.buildbot = {
55 name = "buildbot";
56 uid = config.ids.uids.buildbot;
57 group = "buildbot";
58 description = "Buildbot user";
59 home = varDir;
f6e48e3a
IB
60 extraGroups = [ "keys" "systemd-journal" ];
61 useDefaultShell = true;
62 openssh.authorizedKeys.keys = [ config.myEnv.buildbot.ssh_key.public ];
9fb4205e
IB
63 };
64
29f8cb85 65 services.websites.env.tools.watchPaths = lib.attrsets.mapAttrsToList
da30ae4f 66 (k: project: config.secrets.fullPaths."buildbot/${project.name}/webhook-httpd-include")
ab8f306d 67 config.myEnv.buildbot.projects;
17f6eae9 68
29f8cb85 69 services.websites.env.tools.vhostConfs.git.extraConfig = lib.attrsets.mapAttrsToList (k: project: ''
9fb4205e
IB
70 RedirectMatch permanent "^/buildbot/${project.name}$" "/buildbot/${project.name}/"
71 RewriteEngine On
72 RewriteRule ^/buildbot/${project.name}/ws(.*)$ unix:///run/buildbot/${project.name}.sock|ws://git.immae.eu/ws$1 [P,NE,QSA,L]
73 ProxyPass /buildbot/${project.name}/ unix:///run/buildbot/${project.name}.sock|http://${project.name}-git.immae.eu/
74 ProxyPassReverse /buildbot/${project.name}/ unix:///run/buildbot/${project.name}.sock|http://${project.name}-git.immae.eu/
75 <Location /buildbot/${project.name}/>
76 Use LDAPConnect
e2b96bf5 77 Require ldap-group cn=users,ou=${project.name},cn=buildbot,ou=services,dc=immae,dc=eu
9fb4205e
IB
78
79 SetEnvIf X-Url-Scheme https HTTPS=1
80 ProxyPreserveHost On
81 </Location>
82 <Location /buildbot/${project.name}/change_hook/base>
85817848
IB
83 <RequireAny>
84 Require local
85 Require ldap-group cn=users,ou=${project.name},cn=buildbot,ou=services,dc=immae,dc=eu
da30ae4f 86 Include ${config.secrets.fullPaths."buildbot/${project.name}/webhook-httpd-include"}
85817848 87 </RequireAny>
9fb4205e 88 </Location>
ab8f306d 89 '') config.myEnv.buildbot.projects;
9fb4205e
IB
90
91 system.activationScripts = lib.attrsets.mapAttrs' (k: project: lib.attrsets.nameValuePair "buildbot-${project.name}" {
92 deps = [ "users" "wrappers" ];
8fa7ff2c
IB
93 text = ''
94 install -m 755 -o buildbot -g buildbot -d ${varDir}/${project.name}
95
96 ${project.activationScript}
97 '';
ab8f306d 98 }) config.myEnv.buildbot.projects;
6984f454 99
4c4652aa 100 secrets.keys = lib.listToAttrs (
6984f454
IB
101 lib.lists.flatten (
102 lib.attrsets.mapAttrsToList (k: project:
103 lib.attrsets.mapAttrsToList (k: v:
4c4652aa 104 (lib.nameValuePair "buildbot/${project.name}/${k}" {
6984f454
IB
105 permissions = "0600";
106 user = "buildbot";
107 group = "buildbot";
f6e48e3a 108 text = if builtins.isFunction v then v pkgs config else v;
4c4652aa 109 })
6984f454
IB
110 ) project.secrets
111 ++ [
4c4652aa 112 (lib.nameValuePair "buildbot/${project.name}/webhook-httpd-include" {
6984f454
IB
113 permissions = "0600";
114 user = "wwwrun";
115 group = "wwwrun";
ab8f306d 116 text = lib.optionalString (project.webhookTokens != null) ''
6984f454
IB
117 Require expr "req('Access-Key') in { ${builtins.concatStringsSep ", " (map (x: "'${x}'") project.webhookTokens)} }"
118 '';
4c4652aa
IB
119 })
120 (lib.nameValuePair "buildbot/${project.name}/environment_file" {
dcb8ad4c
IB
121 permissions = "0600";
122 user = "buildbot";
123 group = "buildbot";
dcb8ad4c
IB
124 text = let
125 project_env = with lib.attrsets;
2ff9258e 126 mapAttrs' (k: v: nameValuePair "BUILDBOT_${k}" (if builtins.isFunction v then v pkgs else v)) project.environment //
dcb8ad4c 127 mapAttrs' (k: v: nameValuePair "BUILDBOT_PATH_${k}" (v pkgs)) (attrByPath ["builderPaths"] {} project) //
200690c9
IB
128 {
129 BUILDBOT_PROJECT_DIR = ./projects + "/${project.name}";
130 BUILDBOT_WORKER_PORT = builtins.toString project.workerPort;
131 BUILDBOT_HOST = config.hostEnv.fqdn;
132 BUILDBOT_VIRT_URL = "qemu+ssh://libvirt@dilion.immae.eu/system";
133 };
dcb8ad4c
IB
134 in builtins.concatStringsSep "\n"
135 (lib.mapAttrsToList (envK: envV: "${envK}=${envV}") project_env);
4c4652aa 136 })
6984f454 137 ]
ab8f306d 138 ) config.myEnv.buildbot.projects
6984f454 139 )
4c4652aa
IB
140 ) // {
141 "buildbot/ldap" = {
6984f454
IB
142 permissions = "0600";
143 user = "buildbot";
144 group = "buildbot";
ab8f306d 145 text = config.myEnv.buildbot.ldap.password;
4c4652aa
IB
146 };
147 "buildbot/worker_password" = {
200690c9
IB
148 permissions = "0600";
149 user = "buildbot";
150 group = "buildbot";
151 text = config.myEnv.buildbot.workerPassword;
4c4652aa
IB
152 };
153 "buildbot/ssh_key" = {
6984f454
IB
154 permissions = "0600";
155 user = "buildbot";
156 group = "buildbot";
282c67a1 157 text = config.myEnv.buildbot.ssh_key.private;
4c4652aa
IB
158 };
159 };
6984f454 160
17f6eae9
IB
161 services.filesWatcher = lib.attrsets.mapAttrs' (k: project: lib.attrsets.nameValuePair "buildbot-${project.name}" {
162 restart = true;
163 paths = [
da30ae4f
IB
164 config.secrets.fullPaths."buildbot/ldap"
165 config.secrets.fullPaths."buildbot/worker_password"
166 config.secrets.fullPaths."buildbot/ssh_key"
167 config.secrets.fullPaths."buildbot/${project.name}/environment_file"
168 ] ++ lib.attrsets.mapAttrsToList (k: v: config.secrets.fullPaths."buildbot/${project.name}/${k}") project.secrets;
ab8f306d 169 }) config.myEnv.buildbot.projects;
17f6eae9 170
850adcf4
IB
171 systemd.slices.buildbot = {
172 description = "buildbot slice";
173 };
174
200690c9 175 networking.firewall.allowedTCPPorts = lib.attrsets.mapAttrsToList (k: v: v.workerPort) config.myEnv.buildbot.projects;
6984f454
IB
176 systemd.services = lib.attrsets.mapAttrs' (k: project: lib.attrsets.nameValuePair "buildbot-${project.name}" {
177 description = "Buildbot Continuous Integration Server ${project.name}.";
ca330baa 178 after = [ "network-online.target" ];
6984f454 179 wantedBy = [ "multi-user.target" ];
bc0f9fcf 180 path = project.packages pkgs;
6984f454 181 preStart = let
bc0f9fcf 182 master-cfg = "${buildbot.buildbot_common}/${bb-python.pythonForBuild.sitePackages}/buildbot_common/master.cfg";
e2b96bf5
IB
183 tac_file = pkgs.writeText "buildbot.tac" ''
184 import os
185
186 from twisted.application import service
187 from buildbot.master import BuildMaster
188
189 basedir = '${varDir}/${project.name}'
190 rotateLength = 10000000
191 maxRotatedFiles = 10
192 configfile = '${master-cfg}'
193
194 # Default umask for server
195 umask = None
196
197 # if this is a relocatable tac file, get the directory containing the TAC
198 if basedir == '.':
199 import os
200 basedir = os.path.abspath(os.path.dirname(__file__))
201
202 # note: this line is matched against to check that this is a buildmaster
203 # directory; do not edit it.
204 application = service.Application('buildmaster')
205 from twisted.python.logfile import LogFile
206 from twisted.python.log import ILogObserver, FileLogObserver
207 logfile = LogFile.fromFullPath(os.path.join(basedir, "twistd.log"), rotateLength=rotateLength,
208 maxRotatedFiles=maxRotatedFiles)
209 application.setComponent(ILogObserver, FileLogObserver(logfile).emit)
210
211 m = BuildMaster(basedir, configfile, umask)
212 m.setServiceParent(application)
213 m.log_rotation.rotateLength = rotateLength
214 m.log_rotation.maxRotatedFiles = maxRotatedFiles
215 '';
9fb4205e 216 in ''
9fb4205e 217 if [ ! -f ${varDir}/${project.name}/buildbot.tac ]; then
6984f454 218 ${buildbot}/bin/buildbot create-master -c "${master-cfg}" "${varDir}/${project.name}"
9fb4205e 219 rm -f ${varDir}/${project.name}/master.cfg.sample
e2b96bf5 220 rm -f ${varDir}/${project.name}/buildbot.tac
9fb4205e 221 fi
e2b96bf5 222 ln -sf ${tac_file} ${varDir}/${project.name}/buildbot.tac
ca330baa 223 # different buildbots may be trying that simultaneously, add the || true to avoid complaining in case of race
da30ae4f 224 install -Dm600 -o buildbot -g buildbot -T ${config.secrets.fullPaths."buildbot/ssh_key"} ${varDir}/buildbot_key || true
9fb4205e 225 buildbot_secrets=${varDir}/${project.name}/secrets
6984f454 226 install -m 0700 -o buildbot -g buildbot -d $buildbot_secrets
da30ae4f
IB
227 install -Dm600 -o buildbot -g buildbot -T ${config.secrets.fullPaths."buildbot/ldap"} $buildbot_secrets/ldap
228 install -Dm600 -o buildbot -g buildbot -T ${config.secrets.fullPaths."buildbot/worker_password"} $buildbot_secrets/worker_password
9fb4205e 229 ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList
da30ae4f 230 (k: v: "install -Dm600 -o buildbot -g buildbot -T ${config.secrets.fullPaths."buildbot/${project.name}/${k}"} $buildbot_secrets/${k}") project.secrets
9fb4205e 231 )}
5400b9b6 232 ${buildbot}/bin/buildbot upgrade-master ${varDir}/${project.name}
9fb4205e 233 '';
9fb4205e 234 environment = let
9fb4205e 235 HOME = "${varDir}/${project.name}";
bc0f9fcf
IB
236 PYTHONPATH = "${bb-python.withPackages (self:
237 buildbot.common_packages self ++
238 [ (buildbot.buildbot_config project) ]
239 )}/${bb-python.sitePackages}${if project.pythonPathHome then ":${varDir}/${project.name}/.local/${bb-python.sitePackages}" else ""}";
dcb8ad4c 240 in { inherit PYTHONPATH HOME; };
9fb4205e
IB
241
242 serviceConfig = {
850adcf4 243 Slice = "buildbot.slice";
9fb4205e
IB
244 Type = "forking";
245 User = "buildbot";
246 Group = "buildbot";
81b9ff89
IB
247 RuntimeDirectory = "buildbot";
248 RuntimeDirectoryPreserve = "yes";
249 StateDirectory = "buildbot";
6984f454 250 SupplementaryGroups = "keys";
9fb4205e
IB
251 WorkingDirectory = "${varDir}/${project.name}";
252 ExecStart = "${buildbot}/bin/buildbot start";
da30ae4f 253 EnvironmentFile = config.secrets.fullPaths."buildbot/${project.name}/environment_file";
9fb4205e 254 };
ab8f306d 255 }) config.myEnv.buildbot.projects;
9fb4205e
IB
256 };
257}