]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/buildbot/default.nix
Add backup module
[perso/Immae/Config/Nix.git] / modules / private / buildbot / default.nix
CommitLineData
a1a8649a 1{ lib, pkgs, config, myconfig, ... }:
9fb4205e
IB
2let
3 varDir = "/var/lib/buildbot";
caa08508 4 buildbot_common = pkgs.python3Packages.buildPythonPackage rec {
e2b96bf5
IB
5 name = "buildbot_common";
6 src = ./common;
9fb4205e
IB
7 format = "other";
8 installPhase = ''
caa08508
IB
9 mkdir -p $out/${pkgs.python3.pythonForBuild.sitePackages}
10 cp -a $src $out/${pkgs.python3.pythonForBuild.sitePackages}/buildbot_common
9fb4205e 11 '';
e2b96bf5 12 };
b798cf6d 13 buildbot = pkgs.python3Packages.buildbot-full;
9fb4205e
IB
14in
15{
16 options = {
8d213e2b 17 myServices.buildbot.enable = lib.mkOption {
9fb4205e
IB
18 type = lib.types.bool;
19 default = false;
20 description = ''
21 Whether to enable buildbot.
22 '';
23 };
24 };
25
8d213e2b 26 config = lib.mkIf config.myServices.buildbot.enable {
6a8252b1
IB
27 services.backup.profiles.buildbot = {
28 rootDir = varDir;
29 };
9fb4205e
IB
30 ids.uids.buildbot = myconfig.env.buildbot.user.uid;
31 ids.gids.buildbot = myconfig.env.buildbot.user.gid;
32
33 users.groups.buildbot.gid = config.ids.gids.buildbot;
34 users.users.buildbot = {
35 name = "buildbot";
36 uid = config.ids.uids.buildbot;
37 group = "buildbot";
38 description = "Buildbot user";
39 home = varDir;
6984f454 40 extraGroups = [ "keys" ];
9fb4205e
IB
41 };
42
29f8cb85 43 services.websites.env.tools.watchPaths = lib.attrsets.mapAttrsToList
17f6eae9
IB
44 (k: project: "/var/secrets/buildbot/${project.name}/webhook-httpd-include")
45 myconfig.env.buildbot.projects;
46
29f8cb85 47 services.websites.env.tools.vhostConfs.git.extraConfig = lib.attrsets.mapAttrsToList (k: project: ''
9fb4205e
IB
48 RedirectMatch permanent "^/buildbot/${project.name}$" "/buildbot/${project.name}/"
49 RewriteEngine On
50 RewriteRule ^/buildbot/${project.name}/ws(.*)$ unix:///run/buildbot/${project.name}.sock|ws://git.immae.eu/ws$1 [P,NE,QSA,L]
51 ProxyPass /buildbot/${project.name}/ unix:///run/buildbot/${project.name}.sock|http://${project.name}-git.immae.eu/
52 ProxyPassReverse /buildbot/${project.name}/ unix:///run/buildbot/${project.name}.sock|http://${project.name}-git.immae.eu/
53 <Location /buildbot/${project.name}/>
54 Use LDAPConnect
e2b96bf5 55 Require ldap-group cn=users,ou=${project.name},cn=buildbot,ou=services,dc=immae,dc=eu
9fb4205e
IB
56
57 SetEnvIf X-Url-Scheme https HTTPS=1
58 ProxyPreserveHost On
59 </Location>
60 <Location /buildbot/${project.name}/change_hook/base>
85817848
IB
61 <RequireAny>
62 Require local
63 Require ldap-group cn=users,ou=${project.name},cn=buildbot,ou=services,dc=immae,dc=eu
ca330baa 64 Include /var/secrets/buildbot/${project.name}/webhook-httpd-include
85817848 65 </RequireAny>
9fb4205e
IB
66 </Location>
67 '') myconfig.env.buildbot.projects;
68
69 system.activationScripts = lib.attrsets.mapAttrs' (k: project: lib.attrsets.nameValuePair "buildbot-${project.name}" {
70 deps = [ "users" "wrappers" ];
81b9ff89 71 text = project.activationScript;
6984f454
IB
72 }) myconfig.env.buildbot.projects;
73
1a718805 74 secrets.keys = (
6984f454
IB
75 lib.lists.flatten (
76 lib.attrsets.mapAttrsToList (k: project:
77 lib.attrsets.mapAttrsToList (k: v:
ca330baa 78 {
6984f454
IB
79 permissions = "0600";
80 user = "buildbot";
81 group = "buildbot";
82 text = v;
ca330baa 83 dest = "buildbot/${project.name}/${k}";
6984f454
IB
84 }
85 ) project.secrets
86 ++ [
ca330baa 87 {
6984f454
IB
88 permissions = "0600";
89 user = "wwwrun";
90 group = "wwwrun";
91 text = lib.optionalString (lib.attrsets.hasAttr "webhookTokens" project) ''
92 Require expr "req('Access-Key') in { ${builtins.concatStringsSep ", " (map (x: "'${x}'") project.webhookTokens)} }"
93 '';
ca330baa
IB
94 dest = "buildbot/${project.name}/webhook-httpd-include";
95 }
6984f454
IB
96 ]
97 ) myconfig.env.buildbot.projects
98 )
ca330baa
IB
99 ) ++ [
100 {
6984f454
IB
101 permissions = "0600";
102 user = "buildbot";
103 group = "buildbot";
104 text = myconfig.env.buildbot.ldap.password;
ca330baa
IB
105 dest = "buildbot/ldap";
106 }
107 {
6984f454
IB
108 permissions = "0600";
109 user = "buildbot";
110 group = "buildbot";
111 text = builtins.readFile "${myconfig.privateFiles}/buildbot_ssh_key";
ca330baa
IB
112 dest = "buildbot/ssh_key";
113 }
114 ];
6984f454 115
17f6eae9
IB
116 services.filesWatcher = lib.attrsets.mapAttrs' (k: project: lib.attrsets.nameValuePair "buildbot-${project.name}" {
117 restart = true;
118 paths = [
119 "/var/secrets/buildbot/ldap"
120 "/var/secrets/buildbot/ssh_key"
121 ] ++ lib.attrsets.mapAttrsToList (k: v: "/var/secrets/buildbot/${project.name}/${k}") project.secrets;
122 }) myconfig.env.buildbot.projects;
123
6984f454
IB
124 systemd.services = lib.attrsets.mapAttrs' (k: project: lib.attrsets.nameValuePair "buildbot-${project.name}" {
125 description = "Buildbot Continuous Integration Server ${project.name}.";
ca330baa 126 after = [ "network-online.target" ];
6984f454
IB
127 wantedBy = [ "multi-user.target" ];
128 path = project.packages pkgs ++ (project.pythonPackages buildbot.pythonModule pkgs);
129 preStart = let
caa08508 130 master-cfg = "${buildbot_common}/${pkgs.python3.pythonForBuild.sitePackages}/buildbot_common/master.cfg";
e2b96bf5
IB
131 tac_file = pkgs.writeText "buildbot.tac" ''
132 import os
133
134 from twisted.application import service
135 from buildbot.master import BuildMaster
136
137 basedir = '${varDir}/${project.name}'
138 rotateLength = 10000000
139 maxRotatedFiles = 10
140 configfile = '${master-cfg}'
141
142 # Default umask for server
143 umask = None
144
145 # if this is a relocatable tac file, get the directory containing the TAC
146 if basedir == '.':
147 import os
148 basedir = os.path.abspath(os.path.dirname(__file__))
149
150 # note: this line is matched against to check that this is a buildmaster
151 # directory; do not edit it.
152 application = service.Application('buildmaster')
153 from twisted.python.logfile import LogFile
154 from twisted.python.log import ILogObserver, FileLogObserver
155 logfile = LogFile.fromFullPath(os.path.join(basedir, "twistd.log"), rotateLength=rotateLength,
156 maxRotatedFiles=maxRotatedFiles)
157 application.setComponent(ILogObserver, FileLogObserver(logfile).emit)
158
159 m = BuildMaster(basedir, configfile, umask)
160 m.setServiceParent(application)
161 m.log_rotation.rotateLength = rotateLength
162 m.log_rotation.maxRotatedFiles = maxRotatedFiles
163 '';
9fb4205e 164 in ''
9fb4205e 165 if [ ! -f ${varDir}/${project.name}/buildbot.tac ]; then
6984f454 166 ${buildbot}/bin/buildbot create-master -c "${master-cfg}" "${varDir}/${project.name}"
9fb4205e 167 rm -f ${varDir}/${project.name}/master.cfg.sample
e2b96bf5 168 rm -f ${varDir}/${project.name}/buildbot.tac
9fb4205e 169 fi
e2b96bf5 170 ln -sf ${tac_file} ${varDir}/${project.name}/buildbot.tac
ca330baa
IB
171 # different buildbots may be trying that simultaneously, add the || true to avoid complaining in case of race
172 install -Dm600 -o buildbot -g buildbot -T /var/secrets/buildbot/ssh_key ${varDir}/buildbot_key || true
9fb4205e 173 buildbot_secrets=${varDir}/${project.name}/secrets
6984f454 174 install -m 0700 -o buildbot -g buildbot -d $buildbot_secrets
ca330baa 175 install -Dm600 -o buildbot -g buildbot -T /var/secrets/buildbot/ldap $buildbot_secrets/ldap
9fb4205e 176 ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList
ca330baa 177 (k: v: "install -Dm600 -o buildbot -g buildbot -T /var/secrets/buildbot/${project.name}/${k} $buildbot_secrets/${k}") project.secrets
9fb4205e 178 )}
9fb4205e 179 '';
9fb4205e
IB
180 environment = let
181 project_env = lib.attrsets.mapAttrs' (k: v: lib.attrsets.nameValuePair "BUILDBOT_${k}" v) project.environment;
caa08508 182 buildbot_config = pkgs.python3Packages.buildPythonPackage (rec {
9fb4205e 183 name = "buildbot_config-${project.name}";
e2b96bf5 184 src = ./projects + "/${project.name}";
9fb4205e
IB
185 format = "other";
186 installPhase = ''
caa08508
IB
187 mkdir -p $out/${pkgs.python3.pythonForBuild.sitePackages}
188 cp -a $src $out/${pkgs.python3.pythonForBuild.sitePackages}/buildbot_config
9fb4205e
IB
189 '';
190 });
191 HOME = "${varDir}/${project.name}";
caa08508 192 PYTHONPATH = "${buildbot.pythonModule.withPackages (self: project.pythonPackages self pkgs ++ [
256d607c 193 pkgs.python3Packages.wokkel
caa08508
IB
194 pkgs.python3Packages.treq pkgs.python3Packages.ldap3 buildbot
195 pkgs.python3Packages.buildbot-worker
9fb4205e 196 buildbot_common buildbot_config
caa08508 197 ])}/${buildbot.pythonModule.sitePackages}${if project.pythonPathHome then ":${varDir}/${project.name}/.local/${pkgs.python3.pythonForBuild.sitePackages}" else ""}";
9fb4205e
IB
198 in project_env // { inherit PYTHONPATH HOME; };
199
200 serviceConfig = {
201 Type = "forking";
202 User = "buildbot";
203 Group = "buildbot";
81b9ff89
IB
204 RuntimeDirectory = "buildbot";
205 RuntimeDirectoryPreserve = "yes";
206 StateDirectory = "buildbot";
6984f454 207 SupplementaryGroups = "keys";
9fb4205e
IB
208 WorkingDirectory = "${varDir}/${project.name}";
209 ExecStart = "${buildbot}/bin/buildbot start";
210 };
211 }) myconfig.env.buildbot.projects;
212 };
213}