aboutsummaryrefslogtreecommitdiff
path: root/virtual/modules/websites/tools/mediagoblin/mediagoblin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/modules/websites/tools/mediagoblin/mediagoblin.nix')
-rw-r--r--virtual/modules/websites/tools/mediagoblin/mediagoblin.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/virtual/modules/websites/tools/mediagoblin/mediagoblin.nix b/virtual/modules/websites/tools/mediagoblin/mediagoblin.nix
index 2e62242..54470a4 100644
--- a/virtual/modules/websites/tools/mediagoblin/mediagoblin.nix
+++ b/virtual/modules/websites/tools/mediagoblin/mediagoblin.nix
@@ -1,4 +1,4 @@
1{ env, makeWrapper, stdenv, writeText, fetchurl, fetchedGit, fetchedGithub, which, python3, pkgs, automake, autoconf, nodejs, nodePackages, git, cacert }: 1{ env, makeWrapper, stdenv, writeText, fetchurl, buildBowerComponents, fetchedGit, fetchedGithub, which, python3, pkgs, automake, autoconf, nodejs, nodePackages, git, cacert }:
2let 2let
3 plugins = { 3 plugins = {
4 basicsearch = stdenv.mkDerivation (fetchedGithub ./mediagoblin-plugin-basicsearch.json // rec { 4 basicsearch = stdenv.mkDerivation (fetchedGithub ./mediagoblin-plugin-basicsearch.json // rec {
@@ -108,6 +108,11 @@ in
108 rec { 108 rec {
109 socketsDir = "/run/mediagoblin"; 109 socketsDir = "/run/mediagoblin";
110 varDir = "/var/lib/mediagoblin"; 110 varDir = "/var/lib/mediagoblin";
111 bowerComponents = buildBowerComponents {
112 name = "mediagoblin-bower-components";
113 generated = ./bower-packages.nix;
114 src = (fetchedGit ./mediagoblin.json).src;
115 };
111 mediagoblin = stdenv.mkDerivation (fetchedGit ./mediagoblin.json // rec { 116 mediagoblin = stdenv.mkDerivation (fetchedGit ./mediagoblin.json // rec {
112 preConfigure = '' 117 preConfigure = ''
113 # ./bootstrap.sh 118 # ./bootstrap.sh
@@ -120,6 +125,8 @@ in
120 ''; 125 '';
121 configureFlags = [ "--with-python3" "--without-virtualenv" ]; 126 configureFlags = [ "--with-python3" "--without-virtualenv" ];
122 postBuild = '' 127 postBuild = ''
128 cp -a ${bowerComponents}/bower_components/* extlib
129 chmod -R u+w extlib
123 make extlib 130 make extlib
124 ''; 131 '';
125 installPhase = '' 132 installPhase = ''